Call for testing OMLx 3.02 build 775

From @TPG in cooker ML:

I’ve produced new 3.02 ISO with patched calamares that does support LVM/RAID disk setups by using kpmcore 3.0.x and partitionmanager 3.0.x .

https://abf.openmandriva.org/platforms/3.0/products/38/product_build_lists/775

It should fix issues:
1998 – Calamares places EFI boot loader on the wrong disk
https://calamares.io/bugs/browse/CAL-417
https://calamares.io/bugs/browse/CAL-388
https://calamares.io/bugs/browse/CAL-441

Please try it.

Hi,
I did, yesterday…

Well, in fact I didn’t, since the ISO did not want to start 2 times of the 3 I tried it.

I explain (burnt DVD and 3 tests in live mode) :

  • 1 start : Bad start! Just black screen. I think the boot went on, but I am not sure. I noted anyway, the message with firmware error for APIC has disappeared at he start…
  • 2 start : Good complete start. But same problem here, with internet connection. No connection.
  • 3 start : Good start but no graphic session completely open. The screen remained black and the “Openmandriva-Welcome” window appeared like a chess-board. Impossible to do anything.

With these results I didn’t try to install. I don’t know whether my DVD disk or the ISO is failing…

Bye

Finally, as the matter is to test calamares, I decided to install on hard drive…

The new boot in live mode worked and I installed from the icon on the screen.

The install went well but in the end it didn’t finish with a message (I give you here under).


L’installation a échoué

Erreur Boost.Python pour le job "package"

<class ‘subprocess.CalledProcessError’>
Command ‘urpmi.update -a’ returned non-zero exit status 10
**Traceback : **

File “/usr/lib64/calamares/modules/package/main.py”, line 153, in run pkgman.update_db( )
File “/usr/lib64/calamares/modules/package/main.py”, line 101, in update_db
check_target_env_call ([“urpmi.update”, “-a”])

File “”, line2, in module

Nevertheless, rebooting without the DVD disk, a new Grub2 was present, and the boot was complete, though I had to re-enter the language, time and keyboard choices as if calamares had not taken in count the choices of live session.

All seems to be working except the “habitual” graphic bugs (Nvidia user).

bye

There are some graphic anomalies here otherwise it works OK.

Edit: https://store.kde.org/p/1168001

Graphic anomalies like screen flashing and kwin errors sometimes when first opening applications. bero (Bernhard Rosenkranzer) says that this may be caused by software making graphic changes faster than hardware can do so. If I’m paraphrasing correctly… Anyway the explanation fits what I am seeing.