Booting into GRUB after last update


  • _OpenMandriva Lx version:_Lx.3.03

  • Desktop environment (KDE, LXQT…): KDE

  • Description of the issue (screenshots if relevant):

  • Relevant informations (hardware involved, software version, logs or output…):

After my last update and rebooting the system (asked by OM), it booted into GRUB (black screen with GRUB cursor).
I have OM on my computer as one of a multiboot.
Everything went fine until now. In my GRUB Legacy file I chainload OM with these strings:

title OpenMandriva
rootnoverify (hd2,1)
chainloader (hd2,1)+1

Everything went perfect until this last update.
What can I do to get things back to normal?

I don’t use grub legacy also I presume you are not using OM Lx 3.03 boot loader but a boot loader in another distro. So this is an educated guess. First thing is that there has been a big change in the microcode package that changes how systems boot. As far as I know this change is oriented to UEFI booting and I don’t know how it works with grub legacy. So check (in Lx 3.03) and see if you have ‘microcode-intel’ package:

$ rpm -qa microcode-intel

and if you do have remove it and run ‘update-grub2’ and see if that will boot. Also if someone has a problem right after an update it is very helpful to post what packages were updated:

$ LC_ALL=C rpm -qa --last | more

note the date and only post packages from most recent update.

Note: You may have to mount and chroot in to Lx 3 from another Linux partition or from a ‘Live’ ISO, or Recovery CD.

The most obvious answer is if you are using urpmi.recover to simply roll back system to before the update.

$ man urpmi.recover

Edit: This post is meant to be educational for all of us. I just recently started using urpmi.recover myself and quickly realized I should have been using it long ago.

Have you already tried to reinstall grub?

It would be helpful if you do mount the root partition of hd2 as ben79 describes
to copy /boot/grub2/grub.cfg to this thread so that we can check it’s content.


have done this in another distro because I cannot boot into OM:
rpm -qa microcode-intel
the prompt came back without some response…

about using urpmi.recover : how can I do this without having booted into OM?

have you tried to reinstall grub” :

Which grub? GRUB-legacy or GRUB2? I do not have the knowledge to modify GRUB2 so…

Ben79 was right in his assumption that I boot using the bootloader of another distro : PCLinuxOS.
This has GRUB-Legacy as boot device.

That’s useless. You have to mount your OM / partition and chroot in to it. You can Google how to do this or ask here if you don’t know how. We’re trying to find out if the update added microcode-intel to your OM installation. You can only do that within your OM partition. If it is present you want to remove it and run ‘update-grub2’. Then see if that boots.

Also if you are using a PCLinuxOS boot loader and they support and use grub legacy I would ask on their forum for help. We’ll try to help here but in my case since I’ve made the effort to learn and use Grub2 I’ve forgotten about Grub Legacy.

Again you mount and chroot in to you OM / partition. I can guarantee if something is wrong with your OM causing it not to boot you have to enter you OM system to fix it. And mounting and chrooting in to it is most common way. I you are multi-booting Linux systems you need to know how to do this anyway as Linux isn’t reliable enough to expect to never have problems multi-booting. That is not a realistic expectation.

Managed to mount OM / partition and navigating to boot I noticed a "microcode.img file.
Is that the file to be removed?

“update grub2” did not solve the boot problem.

hmmm… Let me think about this.

Edit: And no I did not at any point say to remove a file I was talking about a specific package.

Edit: Other than what I suggested might help in my first post I don’t have anything to suggest. Of course you have to actually do what I suggested to find out if it might help.

Did the following: booted from another distro, mounted the OM-root and after activated Konsole there, I executed “rpm -qa microcode-intel” (after having installed rpm). It responded with just the cursor.
Then I executed “LC_ALL=C rpm -qa --last | more” and it responded with just the cursor also.
As last action I did “man urpmi.recover” with this result: “No manual entry for urpmi.recover”
So what next?

And wanted to show the contents of the grub but too many characters. Do not see how to
activate it using the code possibility.

You may upload it as an attachment or used Preformatted text.

Can you boot into OM in some way? In the case you may re-install grub from there with grub2-install /dev/sdX if /dev/sdX is your main disk.

Do not know what you mean with booting into OM someway. I only can boot into another distro and from there mount the OM root partition. Also it is not clear for me which string I have to enter in terminal then:
“grub2-install /dev/sdx” must there be a space between “install” and “/dev/sdx” (x = OM root partition)?
But I think the most straightforward way is to UNINSTALL OM root and to re-install that giving the instruction to install its bootloader in OM “/”, as I have done when installing OM for the first time.
After the last update OM has installed GRUB somewhere but definitely NOT in OM “/” as I want due to
the way I install different distros along each other by using 'chainloader".

Now your scenario is more clear for me. You may try to force the boot even from you grub legacy by writing some a simple menu item like the following:

 title OpenMandriva-emergency
 kernel  (hd2,1)/boot/vmlinuz-4.13.6-desktop-1omv root=/dev/sdX3 ro
 initrd    (hd2,1)/boot/1234567890/vmlinuz-4.13.6-desktop-1omv/initrd

You have to change the paths and kernel version according to the one you are using. If you have access to the /boot partition of OMA root you may retrieve these information from the OMA’s grub.fg.

This post leaves to many questions unanswered.

Please post exactly what you did as code.

Exactly, and all of it every single step. Please learn to make a habit of this with technical problems. Your are wasting a lot of time by being imprecise.

I did EXACTLY what you suggested in your first response and I wrote EXACTLY what those results were, and this time in OM-root.

You suggested:

“rpm -qa microcode-intel”

which I did and wrote the result : the prompt came back with no results

You suggested:

LC_ALL=C rpm -qa --last | more

which I did and wrote the result : the prompt came back with no results

what else do you expect?

Then other responders came with suggestions which I greatly appreciated and the results are
in my responds.

Sorry, but I do have some experience gathered when facing problems with other O.S.'s on my
computers and this is the first time someone is complaining about my so called imprecise
responses. Thank you very much…:disappointed:

I have just decided to stop trying to get rid of this problem and are leaving this Forum.
Thank everybody for all your responses and help in the past time when I had installed this O.S.
and found my way in it. I must confess that it is a nice O.S., but I think I am no longer able to
get thinks working correctly.
All the best.

@AnalogueMan Maybe I didn’t read your posts with all necessary attention so I didn’t understand you was using a GRUB Legacy from another distro. I apologize for that. Also I don’t thing @ben79 wanted to hurt your feeling, but, you see, it not so easy to help you in a issues like this doesn’t let you to provide some log information especially because you are not using the most common configuration. However I thins a solution like the one I suggested in the above post may let you to start from OMA and then you may reinstall GRUB2 from here into the / partition. The command is

grub2-install /dev/sdXn

where sdX is the disk where you installed OMA and n is the number of the root partition.

1 Like

No I did not want to hurt anyone’s feelings but apparently I did. So I do apologize for that.

It’s not a secret that I am very frustrated in general with trying to help people on this forum. We post this but to many people here won’t follow the suggestions. And that is disrespectful of the time and effort people make in trying to help them. I’m not mentally capable of understanding why people can’t see this.

Edit: A simple example in this thread is that after repeated request to post code as code how many times has OP posted anything as code? That simply is not a difficult thing and not doing so is disrespectful.

1 Like

Your first request: check and see if you have ‘microcode-intel’ package by executing:

rpm -qa microcode-intel

I did that but my first attempt was wrongly done with another O.S. active, so I corrected this
by navigating from another O.S. into OM-root and, using terminal and executed

rpm -qa microcode-intel

again with as result that the system responded by just returning the cursor . See my third
Then your second request : To post what packages were updated by executing

LC_ALL=C rpm -qa --last | more

I did execute this and posted the result in that same third response: “…and it responded with just
the cursor also
So it was impossible to let you know the results due to the fact that there were simply no results to show.

Then your third request which was in fact a suggestion: simply roll back by executing

$ man urpmi.recover

In that same response I wrote as a result that a “No manual entry for urpmi.recover” was shown.
So your complaint about not following your suggestions is, in my humble opinion, not true.
Apart from this, when I want to post anything as code I am glad and of course willing to do so
if I knew HOW to do it in THIS particular forum.
In for instance the American PCLinuxOS forum, I know how to do this and used it there when
forum members were asking for that.