Boot hang

Tags: #<Tag:0x00007f250db17310>

openMandriva doesn’t boot.
After yesterday system update boot stop and I get an error message.
The last row of error message is something like:

acpi MSFT0101:00 platform device creation failed: -16
  • OpenMandriva Lx version: 4.1

  • Desktop environment (KDE, LXQT…): KDE

There were no updates yesterday afaik.

Yesterday I updated few packages, may be they are several days old. But almost sure that the problem appears just after update then probably the origin is in updated packages.

Then you know what to do: the list of latest packages updated.

I know what I’d do. But boot hang then OMLx don’t start, how is possible to make this list?
If useful I remember that for one of these packages was possible to keep old settings (default) or change with new ones. May be the package is “sdd” ?

Is you system English or Italian locales ?

Italian

Try:
At GRUB screen
Advanced Options for… > OpenMandriva Lx … (console mode)

At terminal prompt, login. Then type command

rpm -qa --last | grep mar\ 5\ mag

If you can get the terminal, you should be able to read there the few packages installed yesterday.

Here’s yesterday updates:

oma-welcome-2.1.25-1.noarch                   mar 12 mag 2020, 23:08:06
microcode-intel-20200508-1.noarch             mar 12 mag 2020, 23:08:06
sddm-0.18.1-6.20200507.4.x86_64               mar 12 mag 2020, 23:08:05
rng-tools-6.10-2.x86_64                       mar 12 mag 2020, 23:08:05

Update: I have tested this and downgrading sddm works.

Try this: Log in to console mode again and:

$ sudo dnf downgrade sddm

reboot and see if that affects anything.

Post-edit: This package:

sddm-0.18.1-6.20200507.4.x86_64

is only in main/testing so I would suggest to disable testing repositories. (All of the packages in @Giorgio’s list are in main/testing repo.)

Please post output of:

$ sudo dnf clean all;dnf clean all;dnf repolist

Postedit:
oh, if it’s too hard to do (sorry) please at least write which repos it says are enabled.

Here’s what I get

id repo                         nome repo
rock-testing-x86_64             OpenMandriva Rock - x86_64 - Testing
rock-testing-x86_64-non-free    OpenMandriva Rock - Non-free - x86_64 - Testing
rock-testing-x86_64-restricted  OpenMandriva Rock - Restricted - x86_64 - Testing
rock-testing-x86_64-unsupported OpenMandriva Rock - Unsupported - x86_64 - Testing
rock-updates-x86_64             OpenMandriva Rock - x86_64 - Updates
rock-updates-x86_64-non-free    OpenMandriva Rock - Non-free - x86_64 - Updates
rock-updates-x86_64-restricted  OpenMandriva Rock - Restricted - x86_64 - Updates
rock-updates-x86_64-unsupported OpenMandriva Rock - Unsupported - x86_64 - Updates
rock-x86_64                     OpenMandriva Rock - x86_64
rock-x86_64-non-free            OpenMandriva Rock - Non-free - x86_64
rock-x86_64-restricted          OpenMandriva Rock - Restricted - x86_64
rock-x86_64-unsupported         OpenMandriva Rock - Unsupported - x86_64

This solved partially. Boot worked one time.
Then I set autologin and now it hang again. Not in the same way as before. Now it stops showing a window similar to konsole with white background. No menu.

ok

Type there:

$ cat /etc/sddm.conf

at line 3, should be:

Session=plasma

at line 11, should be:

[Theme]
Current=breeze

if not, edit it.
$ sudo nano /etc/sddm.conf

.

Yep, it confirms my early suspect, it’s the reason why I asked :stuck_out_tongue_winking_eye: :nerd_face:
Common users should never enable /testing repos in stable release.
If ever/when there is the rare needing, just enable for current transaction and disable it immediately after.

Now, once you can get back to plasma desktop please run om-repo-picker utility and disable whatever except main.

run again the holy command
$ sudo dnf clean all ; dnf clean all ; dnf repolist

Hope this helps. Good luck.

This is my sddm.conf after edit sddm.conf.txt (912 Byte) but unfortunately nothing change.

This is mine, from OMLx 4.1 machine
https://pastebin.com/XvqG17Sj

Compared mine and your sddm.conf show few differences. I added few lines with no result.
I solved moving Session=plasma almost at the beginning:

[Autologin]
Relogin=false
Session=plasma

[General]
InputMethod=
Numlock=none

Now it seems that all works. Thanks.

Great!
Hope it keeps working.
Time to fix repos in om-repo-picker :wink:

Just tried to set autologin but this setting isn’t saved. Anyway OMLx seems working.

id repo                                                         nome repo
rock-updates-x86_64                                             OpenMandriva Rock - x86_64 - Updates
rock-updates-x86_64-non-free                                    OpenMandriva Rock - Non-free - x86_64 - Updates
rock-updates-x86_64-restricted                                  OpenMandriva Rock - Restricted - x86_64 - Updates
rock-updates-x86_64-unsupported                                 OpenMandriva Rock - Unsupported - x86_64 - Updates
rock-x86_64                                                     OpenMandriva Rock - x86_64
rock-x86_64-non-free                                            OpenMandriva Rock - Non-free - x86_64
rock-x86_64-restricted                                          OpenMandriva Rock - Restricted - x86_64
rock-x86_64-unsupported                                         OpenMandriva Rock - Unsupported - x86_64

Your system was a bit messed so I’d suggest to let it as is now and use it for a while. Then to deal with one issue at time.