Bluetooth pairing

Tags: #<Tag:0x00007fabf2b66a48> #<Tag:0x00007fabf2b66728>

Fresh install, Bluetooth not working I have a mouse and headphones cannot add bluetooth icon to system trey. In system settings Bluetooth is a blank page no way to do anything I must need a package I do not have but I do not know what it should be.

Operating System: OpenMandriva Lx 4.2
KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.2
Kernel Version: 5.10.3-desktop-2omv4002
OS Type: 64-bit
Processors: 8 × Intel® Core™ i5-8259U CPU @ 2.30GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa Intel® Iris® Plus Graphics 655

1 Like

Post-edit: Thanks for reporting this @Tommy. This is no doubt an issue that will affect a few users.

There appears to be something off or amiss with bluetooth support in OM Lx 4.2 (and I think in 4.1 also).

But I’m not a dev and am not sure how this stuff should work. What I found is that there is a systemd service “bluetooth” and it is shown as “vendor preset enabled”. But it is disabled. To check status of bluetooth.service open Konsole and run:

$ sudo systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; disabled; vendor preset: enabled)
     Active: inactive (dead)
       Docs: man:bluetoothd(8)

To turn it on:

$ sudo systemctl start bluetooth

To enable bluetooth.service so it starts when you boot:

$ sudo systemctl enable bluetooth

So regardless of how things should be the fix for this is really easy. When I turned bluetooth.service on then the icon in system tray popped up immediately and I was able to pair my device. After starting and enabling bluetooth.service you should now see:

$ sudo systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
     Active: active (running) since Wed 2021-01-06 17:45:31 CST; 2min 9s ago
       Docs: man:bluetoothd(8)
   Main PID: 2937 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 38366)
     Memory: 1.8M
     CGroup: /system.slice/bluetooth.service
             └─2937 /usr/libexec/bluetooth/bluetoothd
1 Like

Honestly it is faster to copy and paste the commands in Konsole than than to do this in SystemSettings.
But this can be done in SystemSettings also. Note that you have to have “Show Inactive” and “Show unloaded” boxes selected.

You right click on the line with the service you want to modify and make your selections. You will be asked for administrator password.

Hi, i have the same problem, i don’t have the bluetooth icon in the tray…

In my dmesg i have this error:

[gio gen 7 21:26:50 2021] Bluetooth: hci0: don’t support firmware rome 0x31010000

I think it’s a kernel error or linux-firmware.

In other distro with kernel 5.4.x - 4.15.x - 4.9.x work.

My adapter is:

05:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

Bye.

P.S. Sorry for my english. :smiley:

1 Like

sudo systemctl enable bluetooth worked.

1 Like

Hi, I followed the guide.

Now i have the icon in the tray but no adapter in my system.

Maybe I have another problem. :man_shrugging:

1 Like

I will try to explain but I am not expert on this, basically learned what I know yesterday.
Hardware recognition is separate matter. You can check that with command lspci. The systemctl command is to turn on the bluetooth.service in systemd. Literally it turns on the bluetooth software in your computer:

I do not know what you are trying to do. For a smartphone to connect to KDEConnect you have to install the KDEConnect app on the phone. I had to wait awhile before my phone was recognized.

Hi, look at this linkhttps://bugzilla.kernel.org/show_bug.cgi?id=210681, the problem is more serious than expected. It’s a kernell bug. If possible apply the patch before the final release.

Thank’s for your help.

1 Like

This is beyond what I can do. I posted a question for developers on IRC. You can ask developers questions there yourself if you wish. The best way to get attention of developers is with a bug report or to post you question at #openmandriva @ Freenode IRC.

The purpose of my reports is only to make them known to improve the distro.

Thanks