Black screen after startup in Oracle VirtualBox[Solved]

Hello, newbee here.
Before I install a distro I always install it on Oracle VBox first.
The version of VBox is 5.1.22.
After installing, the splash screen is displayed then the screen goes black with:

“error sparse file not allowed
loading linux 4.9.0-desktop-1omv
loading initial ramdisk
press any key to continue”

then a blinking cursor
then again the splash screen without text
finally a black screen and that’s it.

No " FAILED : vboxvideo" after running inxi -b in terminal

Installed version Lx.3.0.2

I am running Oracle VirtualBox under PCLinuxOS KDE4 64 bit

Any suggestions?

1 Like


Please try re-install choosing manual partitioning and select ext4 file system instead of default f2fs.

1 Like

Did that, although the error message was not there anymore, the result was the same:
Black screen after a few second of the OpenMandriva wallpaper (without the text).

1 Like

This is just an error created because grub2 doesn’t well support f2fs. As you have seen system will still boot with a small delay.

However based on the kernel version loading you have a rather older ISO of 3.02 latest is here. There will be a newer Release Candidate ISO soon as well.

1 Like

Now before going forward we need to be sure all requirements here have been met:

"Recommended Hardware

OpenMandriva Lx 3.01 requires at least 2.0 GB of memory (min 1,5GB), at least 10 GB of hard drive space (see below for known issues with partitioning).

If you wish to run the live distribution (the option to Start OpenMandriva Lx at the CD boot screen), you must have at minimum 1.5 GB of memory. At least 2 GB of memory is recommended for optimal performance.

Release is available for x86_64 architecture, The i586 and ARM architectures are being worked on, but are not yet available for this release.

Important Note

The KDE Plasma Desktop requires a 3D graphics card that supports OpenGL 2.0 or above
Virtual Machines

The same hardware requirements apply when running in virtual machines.

For VirtualBox, however, you must ALWAYS have at least 1536 MB of memory or OpenMandriva Lx will fail to boot. Please ensure that VirtualBox is configured with “Enable PAE/NX” This option can be found under the System>Processor tab.
Also for VirtualBox you must install to a fresh VM, as trying to install to an existing one may fail. This recent problem is being investigated.

Note that if you use qemu, you may need to select an alternative graphics driver other than your distribution default or you will boot to a black screen."

Though my best guess is that if can run the ISO in ‘Live’ then this isn’t an issue. But we need to be sure especially about having enough RAM, 2GB or more is even better and that “Enable PAE/NX” is selected. Also / partition size in VBox needs to be at least 8GB. A little more is even better (I’m currently using 9.2GB for /).

1 Like

Could you please write the link where you downloaded the ISO?

1 Like

@ ben79

Recommended Hardware

16GB RAM memory

In virtual machine I use 26GB virtual disk memory and partitioning is
10GB for “/” , 4 GB for “swap” , the remaining space for “/home” .

Have x86_64 architecture

The KDE Plasma Desktop requires a 3D graphics card that supports OpenGL 2.0 or above
Virtual Machines

I always check “Enable 3D acceleration” and my PC has an Intel i3 3.6GHz processor.

May I conclude that it does support OpenGL 2.0 when the Live DVD does not give any problems
when I run this on my computer?

Please ensure that VirtualBox is configured with “Enable PAE/NX”

After having done some “homework” ( =internet search), I checked this also and after a restart
there was still a “black screen”.

Though my best guess is that if can run the ISO in ‘Live’ then this isn’t an issue.”

That was my though also and that is the reason why I always install a distro when it is already running from a Live DVD.

Question: Does it make a difference when I start installing the distro using Terminal?
If so, what command do I have to use to get things done?

@ rugyada:

I cannot recall this anymore but it certainly must be the official OpenMandriva site.

An update here!!

I downloaded and installed on my Oracle VBox the .iso ben79 supplied in one of his responses and guess what…
THAT WORKS :slight_smile:
Do not know what was wrong with the other one but I did realize that that .iso was not accompanied with a
md5sum so I used it without checking. Something I ALWAYS do, but in this case, because when something
will go terribly wrong, it goes only wrong in the virtual machine.

Problem SOLVED!
Thanks for all your suggestions.

1 Like

Good that you solved.
md5sum and sha1sum are available right in the same page you downloaded the ISO file.

It’s a great thing to do if there are problems to solve. The command is:

$ pkexec /usr/bin/calamares

There is also a debug mode:

$ pkexec /usr/bin/calamares -d

when you use that when Calamares opens you’ll see in lower right corner some type to the effect of “debug information provided” or similar. Click on it and another window opens with whatever debug captures. (Full disclosure: I’ve never seen it capture anything useful but surely it’s there for a reason).