Attempt at workaround for TV as monitor ('Live' ISO and installed system)

Tags: #<Tag:0x00007fc0bea1cbe8> #<Tag:0x00007fc0bea1ca30> #<Tag:0x00007fc0bea1c800>

This is in response to this post snd this bug report where user that was used to using TV as monitor in Lx 3 is now unable to do so in Lx 4. In this case user has visual difficulties seeing regular laptop screen so that is a major handicap to resolving the issue.

In my case I have Intel computers with Intel graphics. I tried this on an ASUS X550CA notebook. The notebook has 12GB RAM.

Booted the x86_64 ISO to ‘Live’ environment. Then plugged TV with HDMI cable. No display on TV. xrandr shows the TV as connected but does not show a default res for the TV. The file created in ~/.local/share/kscreen/ shows an entry for the Vizio TV but it shows it as:

"enabled": false,

and there is no resolution section in the file. However I think it is very important to note at this point that if I switch to a VT (Virtual Terminal) that is visible on the TV. So this is not hardware that does not work. The computer and TV are communicating. To me this definitely seems like a problem within Plasma desktop.

So I changed the “enabled”: false to “enabled”: true and restarted notebook from Virtual Terminal with ‘sudo systemctl restart sddm’ still no display on TV. Repeated this a number of times.

So that did not work.

1 Like

So next I tried this. Turn off notebook. Plug in TV with HDMI cable. Turn on notebook and let ISO boot to ‘Live’.

The first thing I notice is that grub2 menu, and ksplash are visible just fine on both notebook screen and TV.

When ‘Live’ Plasma desktop is logged in there is now a display on TV as well. The display on TV is different with different background but it is now working.

There is that blue window that pops up to select which display to use, I’ve found the hard way that it is best to select ‘Unified’ which does not work but does not break things. Just do that, for me it does not ‘Unify’ outputs but it lets things work as I want.

In SystemSettings>Display and Monitor>Display the laptop screen is listed as Primary but the Vizio TV is also listed and I can switch it to Primary so I can then use TV as monitor. So this is working for me. I’m fairly certain the same approach will work with an installed system but that is yet to be tested.

Would be interesting to see if other people get similar results or not.

When I get some more time I may try this on another older ASUS K53E notebook (4GB RAM).

1 Like

This is the original file created in ‘~/.local/share/kscreen/’:

[
    {
        "enabled": true,
        "id": "b84b8e40584b606859ff83c9d05cbbd2",
        "metadata": {
            "fullname": "xrandr-unknown",
            "name": "LVDS-1"
        },
        "mode": {
            "refresh": 59.95867919921875,
            "size": {
                "height": 768,
                "width": 1366
            }
        },
        "pos": {
            "x": 0,
            "y": 0
        },
        "primary": true,
        "rotation": 1,
        "scale": 1
    },
    {
        "enabled": false,
        "id": "14d27a4dc6c36e15538fecff736d8a21",
        "metadata": {
            "fullname": "xrandr-VIZIO, Inc-E320i-B2-16843009",
            "name": "HDMI-1"
        },
        "pos": {
            "x": 0,
            "y": 0
        },
        "primary": false,
        "rotation": 1,
        "scale": 1
    }
]

Note the TV is “enabled”: false, and there is no section for it’s resolution. Now (still using ISO) after I turn off notebook and plugin TV and reboot we have a little bit different file:

[
    {
        "enabled": true,
        "id": "b84b8e40584b606859ff83c9d05cbbd2",
        "metadata": {
            "fullname": "xrandr-unknown",
            "name": "LVDS-1"
        },
        "mode": {
            "refresh": 59.95867919921875,
            "size": {
                "height": 768,
                "width": 1366
            }
        },
        "pos": {
            "x": 0,
            "y": 0
        },
        "primary": true,
        "rotation": 1,
        "scale": 1
    },
    {
        "enabled": true,
        "id": "14d27a4dc6c36e15538fecff736d8a21",
        "metadata": {
            "fullname": "xrandr-VIZIO, Inc-E320i-B2-16843009",
            "name": "HDMI-1"
        },
        "mode": {
            "refresh": 60.01516342163086,
            "size": {
                "height": 768,
                "width": 1360
            }
        },
        "pos": {
            "x": 1366,
            "y": 0
        },
        "primary": false,
        "rotation": 1,
        "scale": 1
    }
]

Now we have “enabled”: true, in the TV section and a resolution section for the TV. Notice the refresh rate. I certainly did not do that manually. And now we have a working TV display.

1 Like

To get this to work on an installed system I had to delete all files from ~/.local/share/kscreen. Turn off notebook. Plug in TV with HDMI cable. Turn on and boot as normal. Then when the blue dialog window to switch display pops up select “Unified display”. And works as it did with ISO ‘Live’.

1 Like

So far for me the upshot of all this is that this does not work the same or as smoothly as it does in OM Lx 3 but I can get it to work. Now if we can figure out how to get this to work for @zaivala.

1 Like

Please provide output from xrandr fora all displays and screens same for xdpyinfo
This may help a bit HDMI to TV Monitor Not Working - Linux Mint Forums

1 Like

This information is in bug report also.

That TV connected via HDMI to ASUS X550CA (Intel 4000 graphics) notebook.
Here is the requested command outputs in a file:

Vizio-TV.txt (25.0 KB)

In case this helps here is omv-bug-report-log.xz:

omv-bug-report.log.xz (63.6 KB)

Anything else I can do let me know.

Adding boot parameter:

video=HDMI-A-1:e

did not help.

To me and my user knowledge it seems OM Lx 4 is missing whatever turns the TV to enabled. Or whatever is supposed to turn it to enabled is not functioning correctly.

And keep in mind the grub2 menu, boot splash, sddm login screen, and ksplash are visible on TV it is not until Plasma desktop logs in that I lose TV screen display. So the computer is recognizing and working with the TV just fine. Plasma desktop is not. There is the problem or so it seems. Plus this behavior is reproduced very consistently on multiple computers and 2 different TV’s.

Again: This occurs on either Rock or Rolling systems.

The following should tell us something: If I run either of:

$ xrandr --output HDMI-1 --mode 1360x768 --rate 60 --right-of LVDS-1
  xrandr: Configure crtc 1 failed

$ xrandr --output HDMI-1 --off && xrandr --output HDMI-1 --mode 1360x768 --rate 60 --right-of LVDS-1
  xrandr: Configure crtc 1 failed

first notebook screen goes black then returns but is unresponsive with no mouse and I have to Ctrl>Alt>Bksp out of desktop.

I am seeing the same thing in a dual monitor setup. When I run the xrandr command to configure it the whole desktop hangs. Ctrl>Alt>Bksp is the only fix. Dual monitor config only works in mirrored mode. Using KDE settings I can not configure the setup as it does not apply the changes.

@clb thanks for reporting. There has not been any work on this recently. Don’t know if @TPG has discovered anything to help with this.

You probably saw this but there is more here.