After update to kernel 4.8.1, system no longer shutdown

Up to kernel 4.7, system used to shutdown properly when requested. After update to kernel 4.8.1, it no longer happens.


$ poweroff
$ poweroff -p
$ /bin/systemctl poweroff

Did not work. System seems to follow a given script to shutdown but it fails.

It seems to shutdown only with,

$ su
$ rootspassword
$ poweroff -f

Do anybody else have this problem?

Before going further log in to another kernel know fo work previously and test to be sure the problem doesn’t exit there.

Yes. I’ve done it. Booted 4.7.3 and shutdown, everything worked properly: a black screen and after few seconds the computer was off. Then I’ve booted 4.8.1 and tried again: a black screen, a openmandriva splash screen that lasts (maybe) forever.

Maybe my poor english let it misunderstood. The computer does not turn off if I boot it with kernel 4.8.1 (as it still does with kernel 4.7.3) and use regular

$/bin/systemctl poweroff -p

but, as I said in the first message, it does shutdown if I, as root, do

$/bin/systemctl poweroff -f

Next login to kernel 4.7.3 and reinstall kernel 4.8.1:

# urpmi --replacepkgs kernel-release-desktop-4.8.1-1omv

As you’ve probably noticed you keep having problems no one else does. Also you have a complicated and unusual graphics setup. Now that you know how to get your graphics to work I’d consider a fresh install and see if that doesn’t minimize problems.

I did it three times. The third attempt, I uninstall kernel 4.8.1 and reinstalled it since simple urpmi --replacepkgs refuse to change some inits. But it did not change the picture. It does shutdown properly with kernel 4.7.3 and not with new kernel 4.8.1.

I’ll file a bug on it because it can be something that one could figure out how to improve the distro. Although nobody else seems to have this problem, I don’t believe I am so different …

Thanks any way.