A way to control CPU Speed?

Hi there,

I’m a Linux Newbie. I installed LX 3 on my Acer V5 laptop. It is working ok. I did had graphical glitches but it was fixed after updating. I would like to know if there is a way to control CPU speed. The battery is not lasting as it does on Windows 7. I get around 6-8 hours depending on what I’m doing on it. But on Mandriva I get just 3. I noticed that the CPU speed is always going up and doing and it never gets idle. One of the uses of my laptop is Office work and reading comics. In those tasks on windows 7 the cpu gets as low as 800Mhz and it stays that way. On mandriva it’s always changing. Even opening a folder causes it to go almost fullspeed. Is this caused by bad throttling configuration or is it that KDE is just heavier on resources and perhaps I need a Linux with XFCE of something.

Hi and welcome,
I don’t know if there is a graphical tool for that but you can use cpupower in command line as root.

  • to determine the minimum and maximum CPU frequency allowed:

    cpupower frequency-info -l

  • to list the governors available (they determine the behaviour of the processors):

    cpupower frequency-info -g

  • to set the maximum CPU frequency to 1200 Mz:

    cpupower frequency-set --max 1200M

More infos with

man cpupower

Note: a convenient way to watch the cpu’s behaviour is to run gkrellm available in the repos.

While your suggestion could help I don’t want to reduce the speed permanently. I just want the performance when it’s really needed. How do I select powersave governor ?

edit I did this:

[jan@james-pc ~]$ sudo cpupower frequency-set -g powersave
[sudo] password for jan:
[jan@james-pc ~]$
Is that ok ? It didn’t give me any confirmation.

I’m getting these frequencies:

Apparently there’s also a software that can help but I can’t install it. Here: PowerTOP | 01.org
I manage to extract the file but I’m not able to create the install. It gives me error.

There are some things but they disable functionality of Baloo and all Akonadi.

SystemSettings5>Search>File Search - uncheck Enable File Search

Disable akonadi. Edit ‘~/.config/akonadi/akonadiserverrc’. Change the line StartServer=true to StartServer=false as shown below. And reboot.

For information about why you should or shouldn’t disable Akonadi or Baloo:

https://userbase.kde.org/Akonadi

https://community.kde.org/Baloo

And as always you can find a wealth of information by Googling. For safer/more private internet search I use IXquick/StartPage or DuckDuckGo. Also maybe YouTube How To videos have some suprising tips and tricks.

The thing is I’m not getting high cpu usage to warrant the cpu spikes. Let’s say I’m reading an article online and i’m scrolling down. That makes the cpu jump to 1.5 ghz which is the top speed. I have both the system monitor window and the konsole. The usage is 20% to 40% when scrolling a page yet it goes to fullspeed as if it was needed.

File a bug report.

https://wiki.openmandriva.org/en/How_to_report_a_bug

https://forum3.openmandriva.org/t/bug-report-tool-for-openmandriva-lx

And if it helps anyone there is also this:

https://forum3.openmandriva.org/t/how-to-get-better-results-when-posting-about-problems/

The specs of the laptop are

Acer Model V5-131
Celeron 1.5Ghz
8GB DDR3 1333 Ram
500GB 7200rpm HDD

For testing I tried Manjaro Linux with KDE and there is a difference in the amount of processes running at a time. I get around 214 process vs 150 processes in Manjaro. And while there are cpu spikes as well it does go down as low as 800mhz. In Mandriva the CPU never gets to idle state. It’s most of the time close to full speed like you see in the picture.

That’s why you need to file a bug report. We need a developer/developers help on this and the way to do that is with a bug report. Developers don’t typically hang out in forums.