Wake on lan

Devo impostare il wakeonlan per risvegliare il PC dalla sospensione (uso PowerdownMethod 3 nel file /etc/hibernate/tuxonice.conf)

il comando “ethtool -s eth0 wol g” funziona ma devo darlo manualmente e lo stato della scheda di rete si resetta allo spegnimento: c’è un modo per renderlo permanente o almeno perché si imposti automaticamente all’ avvio? Grazie

puoi provare ad attivare rc.local.

  • crea il file eseguibile /etc/rc.d/rc.local con un contenuto tipo questo

#!/bin/sh

RETVAL=0

case “$1” in
start)
ethtool -s eth0 wol g

    RETVAL=$?
    ;;

esac

exit $RETVAL

poi attivi il servizio rc-local

# systemctl enable rc-local.service
# systemctl start rc-local.service

in questo modo i comandi presenti in rc.local verranno eseguiti al boot

1 Like