Using sof-firmware on HP EliteBook 850 G6 makes HDMI audio no longer work

I have upgraded my Linux by https://forum.openmandriva.org/t/upgrading-om-lx-4-2-system-to-om-lx-4-3/4338
Everything went smoothly.

[mila@mila-hpelitebook850g6 etc]$ cat lsb-release
LSB_VERSION=
DISTRIB_ID=OpenMandrivaLinux
DISTRIB_RELEASE=4.3
DISTRIB_CODENAME=Dysprosium
DISTRIB_DESCRIPTION="OpenMandriva Lx 4.3"
[mila@mila-hpelitebook850g6 etc]$ uname -a
Linux mila-hpelitebook850g6 5.16.13-desktop-1omv4003 #1 SMP PREEMPT Wed Mar 9 19:33:24 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

But the problem was with HDMI audio.
I have tried both pipewire-pulse and pulseaudio-server.

When I tried pulseaudio-server I did not see any HOMI profile to choose.

When I tried pipewire-pulse I did not see any HOMI profile to choose but I could choose Pro Audio with 3 -5.
I could switch to Pro Audio 3 and I saw that it works but without any sound.

The main problem was with my old setting from OpenMandriva Lx 4.2
I have install sof driver there. During that time it was a good solution,
See my post OMA 4.2 Sound and microphone on HP EliteBook 850 G6.
But the time has changed.

How have I solved it?
I have upgraded into sof 1.8. https://github.com/thesofproject/sof/releases/tag/v1.8
It did not help me.
I found a solution on these sites.
https://bbs.archlinux.org/viewtopic.php?id=271421
https://github.com/thesofproject/sof/issues/2251
https://bugzilla.kernel.org/show_bug.cgi?id=205959
I have run echo "options snd-intel-dspcfg dsp_driver=1" > /etc/modprobe.d/alsa.conf
Now I use the kernel driver and there are many HDMI profiles to choose.
See https://elixir.bootlin.com/linux/v5.16.13/source/sound/hda/intel-dsp-config.c for possible numbers.