User Review - OpenMandriva Lx 4.1-2020.05

Hello all,

I am a chronic distro hopper, that I have used a lot of Linux Distros from 2002 to 2020 - I always have a softcorner with RPMs distros but usually the DEBian family edges one step ahead than the other.

Mandriva was and still is my all time favorite Linux Distro - I always consider Mandriva as the Ubuntu in RPM arena but Mandriva itself is so much better than Ubuntu. It was so painful that awesome distro had to stop. Then I followed with Mageia since all those news and hype showed its the direct descendant of Mandriva. Mageia 7, I used for the last time, its stable cool and works - never disappointed the Mandriva legacy.

This is the first time I am using OpenMadriva, I wanted to try it earlier but mostly reviews were bad, says the distro was not matured etc. However today I installed it on my Lenovo IdeaPad 330 Ryzen 5. I downloaded the zenver ISO and dumped into the USB using Fedora Image writer ( I was testing Fedora 32 and it seriously disappointed me in multi ways :-\ ) .

Ok, good news first -

    1. installation was butter smooth, no confusion - The installer is way too better than Anaconda ( seriously complicated installer in Linux )
    1. total installation time was around 12 minutes - super fast
    1. WIFI picked up automatically - Super cool, I have tried PCLINUXOS, Fedora 32, MXLinux19, KUBUNTU 19, Manjaro & Mageia - only Mageia picked it automatically, so I was positive OpenMadriva would do same. Good job. My WiFi is Realtek RTL8821CE 802.11ac

well, thats all, now the bad news as below -

I have some vision related health issues, so I always keep the laptop brightness low - The fresh installation of OpenMandriva Lx 4.1 x86_64 has issues with BackLight. I tried to set it with my keys, only an icon in the screen shows its decreasing, but nothing happening actually. I tried the applet in the panel and used mouse to decrease the brightness, nothing happened. So I went to install xbacklight app, so I opened DNFDragora. OK it opened up but in my Fedora32 it always hanged. But the the REPOs are not refreshed. So I clicked refresh metadata, some screen activity happened but no refreshment happened actually.

well, then I opened the Konsole, and fire dnf update and dnf upgrade then the repos are refreshed.

then I done dnf search xbacklight - result nothing found. So I downloaded the RPM file from rpmfind website

then I installed and again

 [root@jeevan-81d2 light-master]# xbacklight 
No outputs have backlight property

so no backlight control property, and yes that line acpi_backlight=vendor is already added in GRUB line, I checked.

OK, moving on - NO Touchpad, nothing… so I tried xinput commandline, no such package installed ! hmm ok , I installed using dnf and xinput again. Result as below

[root@jeevan-81d2 light-master]# xinput 
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SIGMACHIP Usb Mouse                       id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ EasyCamera: EasyCamera                    id=11   [slave  keyboard (3)]
    ↳ Ideapad extra buttons                     id=12   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard
yes, Touchpand is not detected. This was an issue in Fedora 32 as well.  

my MXLinux19 picked up the TouchPad with no issue. 

Now I need to optimize my laptop for battery save, by default I tried to install
#dnf install tlp tlp-rdw

[root@jeevan-81d2 light-master]# dnf install tlp
Last metadata expiration check: 1:59:48 ago on Friday 12 June 2020 06:38:51 PM IST.
No match for argument: tlp
Error: Unable to find a match: tlp

Meh, should not it be there ? :frowning: ok, I then installed the next option - powertop. Then I fired the commands as below

[root@jeevan-81d2 boot]# systemctl start powertop
Failed to start powertop.service: Unit powertop.service not found.
[root@jeevan-81d2 boot]# systemctl start powertop.service
Failed to start powertop.service: Unit powertop.service not found.

again, Meh :-/

by the time I am writing these - Battery performance - took 28 minutes to reach 63% from full charge. Well, the boot time is not so good as well.

[root@jeevan-81d2 light-master]# systemd-analyze 
Startup finished in 2.116s (kernel) + 15.259s (initrd) + 37.387s (userspace) = 54.762s reached after 22.601s in userspace

Now, I tried this Desktop Preset option, I went for MacOS way. So it asked me the root password and I waited for some time. Then my desktop layout changed with top panel and dock below. Well, its super ugly, I reverted to Breeze back. Now what happened, is that the DOCK in the bottom stayed. Yes that large DOCK stayed and I tried my level best to remove it, tried many options, no options to remove it. So I logged out and logged in again. Now the system got a screen-flickering, system went hang ! I had to hard reboot. Now again, the DOCK is still there and system went hanged. I had to hard switch off.

Man, I hate to say this but its disappointing. I really wish this distro gets better in next-next releases, I always liked Mandriva, I hope OpenMandrivaLx gets better soon.

My Laptop Hardware info -

[root@jeevan-81d2 jeevan]# inxi -Fxxxza
System:    Host: jeevan-81d2 Kernel: 5.5.12-desktop-1omv4001 x86_64 bits: 64 compiler: gcc v: 9.2.1 
          parameters: BOOT_IMAGE=/boot/vmlinuz-5.5.12-desktop-1omv4001 root=UUID=b3b24193-40a2-464a-8ea1-57d334f78890 ro 
          quiet splash logo.nologo acpi_osi=Linux "acpi_osi=!Windows 2012" acpi_backlight=vendor audit=0 rd.timeout=120 
          scsi_mod.use_blk_mq=1 dm_mod.use_blk_mq=1 rd.systemd.show_status=0 systemd.show_status=0 
          Desktop: KDE Plasma 5.17.5 wm: kwin_x11 dm: SDDM Distro: OpenMandrivaLinux 4.1 Mercury 
Machine:   Type: Laptop System: LENOVO product: 81D2 v: Lenovo ideapad 330-15ARR serial: <filter> Chassis: type: 10 
          v: Lenovo ideapad 330-15ARR serial: <filter> 
          Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO v: 7VCN24WW date: 06/15/2018 
Battery:   ID-1: BAT0 charge: 18.7 Wh condition: 25.8/35.0 Wh (74%) volts: 8.2/7.6 model: LGC L17L2PF0 type: Li-poly 
          serial: <filter> status: Charging 
CPU:       Topology: Quad Core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen 
          family: 17 (23) model-id: 11 (17) stepping: N/A microcode: 8101007 L1 cache: 384 KiB L2 cache: 2048 KiB 
          L3 cache: 4096 KiB 
          flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 31941 
          Speed: 2792 MHz min/max: 1600/2000 MHz boost: enabled Core speeds (MHz): 1: 2789 2: 2785 3: 2792 4: 2793 5: 2794 
          6: 2779 7: 2802 8: 2796 
          Vulnerabilities: Type: itlb_multihit status: Not affected 
          Type: l1tf status: Not affected 
          Type: mds status: Not affected 
          Type: meltdown status: Not affected 
          Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
          Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
          Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
          Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] vendor: Lenovo driver: amdgpu v: kernel 
          bus ID: 03:00.0 chip ID: 1002:15dd 
          Display: x11 server: OpenMandriva 1.20.7 driver: none compositor: kwin_x11 resolution: 1366x768~60Hz 
          OpenGL: renderer: AMD RAVEN (DRM 3.36.0 5.5.12-desktop-1omv4001 LLVM 9.0.1) v: 4.6 Mesa 20.0.2 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo 
          driver: snd_hda_intel v: kernel bus ID: 03:00.1 chip ID: 1002:15de 
          Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
          bus ID: 03:00.6 chip ID: 1022:15e3 
          Sound Server: ALSA v: k5.5.12-desktop-1omv4001 
Network:   Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo driver: rtl8821ce v: N/A 
          port: 3000 bus ID: 01:00.0 chip ID: 10ec:c821 
          IF: wlp1s0 state: up mac: <filter> 
          Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 2000 
          bus ID: 02:00.0 chip ID: 10ec:8168 
          IF: enp2s0 state: down mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 7.12 GiB (0.8%) 
          ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB block size: physical: 4096 B 
          logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: LCM2 scheme: GPT 
Partition: ID-1: / raw size: 465.51 GiB size: 457.20 GiB (98.22%) used: 7.02 GiB (1.5%) fs: ext4 block size: 4096 B 
          dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 54.2 C mobo: N/A gpu: amdgpu temp: 54 C 
          Fan Speeds (RPM): N/A 
Info:      Processes: 220 Uptime: 1h 05m Memory: 7.39 GiB used: 2.18 GiB (29.5%) Init: systemd v: 244 runlevel: 5 Compilers: 
          gcc: N/A Shell: bash (su) v: 5.0.11 running in: konsole inxi: 3.0.37 

Welcome @jeevanism

1 Like

Thanks for the comments including the kind words and the criticism. We will do what we can to address what we are able to.

OpenMandriva is descended directly and legally from Mandriva but is very obviously not the same as Mandriva. IMO opinion Mandriva was unique in the ability to engineer Linux operating system that did so much for so many different types of computer users. Mandriva SA had employees including full time paid developers a luxury OM does not share. OpenMandriva is all volunteer, part time, unpaid, community contributors and is presently a small group. If something gets done it is because someone from the OM Community volunteers and does it. Very, very different from Mandriva days.

Did not take long searching internet to find this. That thread includes these gems:

Upon checking, the IdeaPad 330 is not tested for Linux operating system.

You may try to install Linux operating system, but we cannot guarantee that all features will function properly.

Apparently we don’t have available touchpad driver for Ubuntu.

Granted that is from 2018. Anyway there is enough in the Lenova forums to indicate that laptop hardware issues with some models are general to Linux not OpenMandriva alone.

The software issues are different and I’ll answer what I can in other posts when I get some time to investigate.


First so you know I am not a developer just a user attempting to help other users. I do not know more than other user necessarily but may know more specific details about OM Lx. I am not infallible.

I have a couple of ASUS notebooks and all the screen brightness, and touchpad stuff works. I don’t use battery as much as some folks so am less aware of battery saving issues.

xbacklight package is in unsupported repository. Unsupported repository is not enabled by default and user must enable it.

$ xbacklight 
No outputs have backlight property

I get the same here. Looked around the internet and this is a very common thing usually related to a missing or incorrect path. We can pass this along to developers. However this package does not have a package maintainer that is why it is in unsupported repositoy.

I have one touchpad computer and it works. It does not have xinput installed so that is not what makes it work. I don’t know what does make touchpads work but my guess would be a kernel module? We see on the Lenova forum that they may not have touchpad drivers (or modules) for all their models for LInux? (Yes those are questions not statements.) AFAIK such modules are added to kernel upstream.

tlp looks like it may be worthwhile to look at adding that software. I mentioned this to a developer already.

Most people report relatively fast boot time with OM Lx so slow boot times are not what we expect but it happens. Impossible to say more without information as to what is taking the time.

Don’t use the Desktop Preset. My perspective: Tried it did not care for it. Some people like it some don’t. If you don’t like it then don’t use it. Seems simple enough to me. Why would I want a computer that “looks like” Windows, Apple, of gag_worst_of_all Ubuntu.


KDE users powerdevil for power management. Don’t think this is the same type of software as powerdevil or tlp.

Don’t really know much about PowerTop but there is this. I did not see any systemd commands in that guide, the commands I did try work here. As far as how well PowerTop does or does not work in OM Lx I don’t really know.

PowerTOP is a Linux* tool used to diagnose issues related to power consumption and power management. PowerTOP has an interactive mode where the user can experiment with various power management settings for cases where the Linux distribution has not enabled these power saving settings.

I’m not having any power consumption issues that I’m aware of at present so don’t have much reason to need it. Powertop may be great software and I just am not aware of that yet.


Hi @jeevanism!

Powertop does not have a systemd service when coming from upstream. Distributions offering that service add it by themselves, e.g. openSUSE as you can see here.

That said, you’re right. It’s something useful to be there right from the start. But these services are only very basic. It’s better if you set it up according to the needs of your laptop:

  1. Plug off external devices
  2. powertop --calibrate
  3. powertop --html=powerreport.html
  4. Plug external devices back in, open powerreport.html and go to tab Tuning.
  5. Copy values to a new service file. It should similar to this:
Description=Powertop tunings for laptop

ExecStart=/bin/sh -c "echo '1500' > '/proc/sys/vm/dirty_writeback_centisecs';"
ExecStart=/bin/sh -c "echo '0' > '/proc/sys/kernel/nmi_watchdog';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/pci/devices/0000:00:14.2/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/pci/devices/0000:00:1f.6/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/pci/devices/0000:00:1d.0/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/pci/devices/0000:3d:00.0/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/pci/devices/0000:00:14.0/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/pci/devices/0000:00:00.0/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/pci/devices/0000:00:1f.3/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/pci/devices/0000:00:04.0/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/pci/devices/0000:00:08.0/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/pci/devices/0000:00:1c.0/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/pci/devices/0000:00:1f.2/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/pci/devices/0000:03:00.0/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/pci/devices/0000:00:1f.0/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/i2c/devices/i2c-1/device/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/i2c/devices/i2c-2/device/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/i2c/devices/i2c-3/device/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/usb/devices/2-3/power/control';"
ExecStart=/bin/sh -c "echo 'auto' > '/sys/bus/pci/devices/0000:00:02.0/power/control';"


Hope that helps!


A quick search revealed that grub parameter ivrs_ioapic[32]=00:14.0 should help getting this to work. That is most likely an upstream kernel problem as this affects other distributions as well.


That’s too few details to check. I’d run systemd-analyze blame to see what exact service is slowing your boot process. Here’s mine:

[vinz@elitebook840 ~]$ sudo systemd-analyze 
Startup finished in 4.461s (kernel) + 3.030s (initrd) + 15.804s (userspace) = 23.296s reached after 15.079s in userspace

The machine I use for testing is some old i5-4300U with 8GB RAM. So the difference to your system shouldn’t be that huge.


Thank you all for the replies. I was busy with work and family stuff. I try the fixes you have mentioned and will update back

1 Like

I think so, I would need to update the kernel, the touchpad is working on Mageia 8 Alpha 5.7.7-desktop-1.mga8

However, I am gonna install the Rolling version of OMA since it has latest packages

1 Like

Ok guys, I just download the rolling ISO znver as I run a Ryzen Laptop (Lenovo Ideapad 330 )

Just booted the live medium - as I expected, the touchpad and backlight control keys are not working. Both of them working fine in Mageia 7.1 and Mageia 8Alpha.
So what could be the problem ? the Kernel version or any missing package ?

This rolling snapshot has

[live@jeevanism ~]$ uname -r

while my Mageia 8 Alpha has 5.7.7-desktop-1.mga8

so I hope a new kernel update would do the trick. I will do that later and update my reuslt back

1 Like

@jeevanism Please notice that we are using some modern tools to manage system performace like tuned ( which i installed and started by default.

If you want to play with you battery please run tuned-adm and choose profile that will meet your needs.

Speaking of not working backlight controls, please switch acpi_backlight=vendor to acpi_backlight=native in /etc/default/grub and run then update-grub2

For your touchpad please run libinput list-devices to see a list of your input devices like touchapd, then run libinput debug-events and use your touchpad to see if anything comes out of kernel.


I’m a new user with a desktop running a Ryzen 3 1300x. I’m used to Ubuntu and had been running MATE 20.04 before installing OM Lx 4.1 (Rock). I’m also not as familiar with KDE, having preferred GTK apps in the past. Gnome and MATE have easy panel add-ons to access the CPU governor settings, and I was a bit disappointed that KDE doesn’t have an equivalent tool.

However, since you mentioned “tuned-adm,” I did some research and now have control of system performance. I set a ‘balanced’ profile and enjoy a quieter system. I’m also quite pleased that GameMode is included by default. Using GameMode in my .desktop launchers allows me to put the pedal to the metal as needed. I’m close to installing Steam as well, hoping that the Steam files I left in my /home partition will continue to work as before and avoiding the need to do a clean install (I have dozens of games already installed from when I was running Ubuntu.)

I think more attention could be given to the fact that OM already has the tools needed to optimize computer performance.

So far, I’m very pleased with OM! Great work!

1 Like

Thank you.

Here is the update of the review

1 Like