USB mouse problem


#1

The topic,

seems to deal with the same problem. I don’t speak italian. Tried google translator and it seems not solved.

Is there any news on this problem:

At every boot, mouse changes on/off. Once SDDM authentication is displayed mouse is off, if I right click it turns on but will turn off again if not touched for a few seconds.

This turn on/turn off behaviour only stop if I disconnect the USB cable and reconnect.

Of course, this does not block OMV LX 3.0 use, but it is undesirable …

System updated every day (kernel 4.9.6).
Thanks


Usb mouse si blocca all'avvio
Problemino mouse
Usb mouse si blocca all'avvio
(rugyada) #2

In short:
@mandian suggests to look in /var/log/Xorg.0.log;
@luca to look also in journal to see if at boot there are noticed any problem related to usb;
@bruno found that is running nouveau drivers, so he installed the usual intel and that did the trick.

Hope it helps.


#3

Thanks for the answer,

It seems not to help here. I have blacklisted nouveau at /etc/defaults/grub and nvidia-current drivers are loaded.

I’m sending summaries of Journalctl and Xorg.0.log in what refers to “mouse”. Hope somebody can see something …

After unplugging and plugging usb mouse, Journalctl has the following mentions to mouse:

=============
fev 07 11:47:50 localhost kernel: mousedev: PS/2 mouse device common for all mice
fev 07 11:47:52 pc-central kernel: usb 3-8: Product: Optical Mouse
fev 07 11:47:54 pc-central kernel: input: Genius Optical Mouse as /devices/pci0000:00/0000:00:14.0/usb3/3-8/3-8:1.0/0003:0458:003A.0003/input/input17
fev 07 11:47:54 pc-central kernel: hid-generic 0003:0458:003A.0003: input,hidraw2: USB HID v1.11 Mouse [Genius Optical Mouse] on usb-0000:00:14.0-8/input0
fev 07 11:53:33 pc-central kernel: usb 3-8: Product: Optical Mouse
fev 07 11:53:33 pc-central kernel: input: Genius Optical Mouse as /devices/pci0000:00/0000:00:14.0/usb3/3-8/3-8:1.0/0003:0458:003A.0004/input/input18
fev 07 11:53:33 pc-central kernel: hid-generic 0003:0458:003A.0004: input,hidraw2: USB HID v1.11 Mouse [Genius Optical Mouse] on usb-0000:00:14.0-8/input0

Xorg.0.log before unplugging/replugging usb mouse (grep -i mouse)

=====================
[ 8.564] () Option “AllowMouseOpenFail”
[ 9.320] (==) NVIDIA(0): Silken mouse enabled
[ 9.471] (II) XINPUT: Adding extended input device “Microsoft Comfort Curve Keyboard 3000” (type: MOUSE, id 10)
[ 9.471] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event14)
[ 9.471] (
) Genius Optical Mouse: Applying InputClass “evdev pointer catchall”
[ 9.471] () Genius Optical Mouse: Applying InputClass “libinput pointer catchall”
[ 9.471] (
) Genius Optical Mouse: Applying InputClass “touchpad catchall”
[ 9.471] (II) Using input driver ‘libinput’ for ‘Genius Optical Mouse’
[ 9.471] () Genius Optical Mouse: always reports core events
[ 9.523] (II) input device ‘Genius Optical Mouse’, /dev/input/event14 is tagged by udev as: Mouse
[ 9.523] (II) input device ‘Genius Optical Mouse’, /dev/input/event14 is a pointer caps
[ 9.537] (II) XINPUT: Adding extended input device “Genius Optical Mouse” (type: MOUSE, id 11)
[ 9.537] (
) Genius Optical Mouse: (accel) selected scheme none/0
[ 9.537] () Genius Optical Mouse: (accel) acceleration factor: 2.000
[ 9.537] (
) Genius Optical Mouse: (accel) acceleration threshold: 4
[ 9.589] (II) input device ‘Genius Optical Mouse’, /dev/input/event14 is tagged by udev as: Mouse
[ 9.589] (II) input device ‘Genius Optical Mouse’, /dev/input/event14 is a pointer caps
[ 9.589] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0)
[ 9.589] (**) Genius Optical Mouse: Applying InputClass “touchpad catchall”

Changes (diff) in Xorg.0.log after unplugging/replugging usb mouse are (all in the new log file),

==================
< [ 271.580] (II) input device ‘Genius Optical Mouse’, /dev/input/event14 is tagged by udev as: Mouse
< [ 271.580] (II) input device ‘Genius Optical Mouse’, /dev/input/event14 is a pointer caps
< [ 344.491] (II) config/udev: removing device Genius Optical Mouse
< [ 346.487] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0)
< [ 346.487] () Genius Optical Mouse: Applying InputClass “touchpad catchall”
< [ 346.522] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event14)
< [ 346.522] (
) Genius Optical Mouse: Applying InputClass “evdev pointer catchall”
< [ 346.522] () Genius Optical Mouse: Applying InputClass “libinput pointer catchall”
< [ 346.522] (
) Genius Optical Mouse: Applying InputClass “touchpad catchall”
< [ 346.522] (II) Using input driver ‘libinput’ for ‘Genius Optical Mouse’
< [ 346.522] () Genius Optical Mouse: always reports core events
< [ 346.567] (II) input device ‘Genius Optical Mouse’, /dev/input/event14 is tagged by udev as: Mouse
< [ 346.567] (II) input device ‘Genius Optical Mouse’, /dev/input/event14 is a pointer caps
< [ 346.573] (II) XINPUT: Adding extended input device “Genius Optical Mouse” (type: MOUSE, id 11)
< [ 346.573] (
) Genius Optical Mouse: (accel) selected scheme none/0
< [ 346.573] () Genius Optical Mouse: (accel) acceleration factor: 2.000
< [ 346.573] (
) Genius Optical Mouse: (accel) acceleration threshold: 4
< [ 346.573] (II) input device ‘Genius Optical Mouse’, /dev/input/event14 is tagged by udev as: Mouse
< [ 346.573] (II) input device ‘Genius Optical Mouse’, /dev/input/event14 is a pointer caps


(Bruno) #4

Effettivamente la sostituzione dei driver video da nouveau a intel mi ha tratto in inganno. Dopo un breve periodo il mouse ha ripreso il suo comportamento anomalo, non l’avevo più segnalato perché credevo d’essere il solo (e d’altra parte anche la saracinesca del mio box, con nuovissima scheda elettronica, ha richiesto più di otto interventi prima di funzionare bene).

Provo ad essere più preciso:
computer spento,
avvio e si accende il mouse,
arrivo alla schermata di grub e all’avvio di omalx il mouse si spegne e riaccende istantaneamente,
con mouse acceso arrivo a circa metà del boot, qui il mouse si spegne e resta spento.
A questo punto devo staccare e riattaccare la spina usb, posso farlo sia prima della schermata di login che a login effettuato, il comportamento non cambia.
Ho provato anche a disabilitare il touchpad in presenza del mouse ma non ci sono stati cambiamenti.
Anzi dopo il login esce un avviso di touchpad disattivato perché è stato collegato un mouse: ma il mouse è spento! devo staccare e riattaccare.
Aggiungo che anche a me la pressione di un tasto accende il mouse, solo per pochi secondi: nuova funzione risparmio energetico? Solo il distacco e riattacco lo rende operativo stabilmente.
Il comando lsusb sia con mouse non funzionante che funzionante rende identica risposta; questa:

[~]$ lsusb
Bus 004 Device 002: ID 8087:8000 Intel Corp.
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 004: ID 0930:0220 Toshiba Corp.
Bus 003 Device 002: ID 8087:8008 Intel Corp.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
Bus 001 Device 003: ID 2040:7070 Hauppauge Nova-T Stick 3
Bus 001 Device 002: ID 046d:c03e Logitech, Inc. Premium Optical Wheel Mouse (M-BT58)
Bus 001 Device 005: ID 04ca:7017 Lite-On Technology Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

A disposizione per compiere eventuali manovre suggerite.


Problemino mouse
#5

In a graphical environment the mouse is handled by X.org. So you may search in Xorg.0.log for a line starting with (EE) org eventually (WW). Otherwise is a kernel problem you should view with journalctl. In your log mouse only appears but never disconnect.


#6

Yes. The mouse is not disconnect, if I right click it turn its lights on and works as long as I don’t stop using it for a period longer than a few seconds (less than 10 seconds). It really seems to be some kind of energy saving. This “saving energy” only stops when I unplug and plug it again.

Still googling around, found something about mouse autosuspend options here:

https://bbs.archlinux.org/viewtopic.php?id=186579

and here,

The latter seems to have a real solution but I did not tried yet (more details in the link!):

" Ubuntu 14.04 to 15.04

Edit the /etc/default/grub file and change the GRUB_CMDLINE_LINUX_DEFAULT line to add the usbcore.autosuspend=-1 option:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash usbcore.autosuspend=-1”

Note that quit splash were already present options. So keep other options you have too.

After save the file, update grub:

sudo update-grub

And reboot.

Now check autosuspend value:

cat /sys/module/usbcore/parameters/autosuspend

And it should display -1.
Ubuntu 15.10 and above

The procedure is the same, but the param to change is autosuspend_delay_ms (instead of autosuspend)."


(Bruno) #7

Ricordando quello che aveva chiesto @luca e cioè provare con mouse diverso, appena ho potuto, ho provato con altro mouse ottico (Semtek).
Risultato: quello funziona! è il mio Logitech (antico) che non va.
Spulciando in giro… sembra sia un problema correlato a laptop-mode.
Alcuni mouse ottici quando sono in modalità autosuspend non riescono più ad essere riattivati.
Soluzione trovata su forum
(http://superuser.com/questions/408683/why-my-usb-mouse-gets-suspended-after-3-seconds-of-inactivity
da me funziona.
Riassumendo: recupero informazioni con

> # lsusb | grep Mouse
> Bus 001 Device 002: ID 046d:c03e Logitech, Inc. Premium Optical Wheel Mouse (M-BT58)

da root apro il file /etc/laptop-mode/conf.d/runtime-pm.conf
nella sezione autosuspend_devid_blacklist cambio da:

# The list of Device IDs that should not use autosuspend. Use system commands or
# look into sysfs to find out the IDs of your devices.
# Example: AUTOSUSPEND_DEVID_BLACKLIST="046d:c025 0123:abcd"
AUTOSUSPEND_RUNTIME_DEVID_BLACKLIST=""

a:

# The list of Device IDs that should not use autosuspend. Use system commands or
# look into sysfs to find out the IDs of your devices.
# Example: AUTOSUSPEND_DEVID_BLACKLIST="046d:c025 0123:abcd"
##AUTOSUSPEND_RUNTIME_DEVID_BLACKLIST=""
AUTOSUSPEND_RUNTIME_DEVID_BLACKLIST="046d:c03e"

Riavvio il sistema.

Dovrebbe essere sufficiente riavviare il servizio con:
# systemctl reload-or-restart laptop-mode.service


(Giorgio) #8

My mouse is a recent low cost Trust optical mouse that works normally with different distribution but hang on OpenMandriva.
$ lsusb

Bus 001 Device 008: ID 1a2c:0042 China Resource Semico Co., Ltd


(Giorgio) #9

Removed laptop-mode-tools-1.67-2-omv2015.0.noarch and mouse works normally. Bug reappear if reinstalled.


#10

Maybe there is a solution,
at least starting from version 1.69 of laptop-mode-tools. Actually in 3.0 version 1.67 is packaged so an upgrade to latest version may be request on bugzilla.


#11

I’ve followed the steps described in the post above and it solved my problem.

I guess the best alternative would be having a way to customize the autosupending function in something like systemsettings or MCC.


(Giorgio) #12

[quote=“adelson.oliveira, post:11, topic:968”]
I guess the best alternative would be having a way to customize the autosupending function in something like systemsettings or MCC.
[/quote]I agree.
Waiting for this solution I asked for laptop-mode-tools update, see bug 2202


#13

Newer version of the package provides a graphical configuration tool named /usr/sbin/lmt-config-gui and written in python-qt4.


(Giorgio) #14

Last version of laptop- mode-tools available here. I installed it (after removing previous version) and mouse seems working.
I think more “tester” is needed to be sure that it works.


(Ben Bullard) #15

(Ben Bullard) #16

(Ben Bullard) #17