Upgrading from 3.0 to 4.0 (cooker)

omlx-40
Tags: #<Tag:0x00007fb72485a0d8>

(Ben Bullard) #22

Is this maybe a missing libGL or OpenGL package? I checked for and have installed lib64glu1, lib64gl1, and lib64glapi0.

$ glxinfo
Error: unable to open display

I don’t know if that is normal because X isn’t running or something else. I did find missing fcitx (don’t know why I would need that) and importantly when that installed I discovered locale packages were not installed. So some key packages did get missed. A missing package is, to me at least, a possibility.

Another thing is it does not matter if x11-driver-video-vboxvideo is installed or not it does not boot either way.

These are screen shots of some of Xorg.0.log with ‘x11-driver-video-vboxvideo’. I believe we see the vboxvideo driver is not loaded and modesetting is used anyway:

Last screen shot shows that vboxvido is installed even though the log shows it as “does not exist”. There may be some relevant info in xorg-session.log also. I can post via screen-shot if requested.

Post-edit: Opps. Forgot my trademark.

Dadgummit!

:monkey:


(Ben Bullard) #23

Are we (mostly me) are missing something basic and something I probably don’t know about very well. But could a key to the boot issue be the it will not boot if I add multi-user.target to boot parameters? But it will boot is I use 3? And the fact that after:

$ sudo chown username:groupname ~/.Xauthority

I still am getting with startx:

xauth: file /home/ben79/.serverauthxxxx does not exist

just wondering. Maybe reaching now.

Dog :dog2: gone it!

:hear_no_evil::see_no_evil::speak_no_evil:


(rugyada) #24

Thanks @ben79
From your experience is a 20 GB virtual hard disk big enough in your opinion ?
WDYT is better for the testing right now, the Plasma ISO or the LXQt ISO ?


(Ben Bullard) #25

Yes, 20 GB should be plenty. (At this time).

I’ve only tried using the Plasma ISO but in view of the boot issue with that maybe the LXQt ISO is worth a try. I’ll probably try myself.


(rugyada) #26

Thanks @ben79


(Ben Bullard) #27

I forgot something about OM and VBox. I use manual partitioning otherwise it makes giant swap partitions and swap is not even used these days for most of us.

I set my VM’s for install to 4 GB memory (3 GB for running after install) and make a 300 MB /boot/efi 2 GB swap and rest for /. You can also make a home partition if you want but I don’t for VBox.

Post-edit: Specifically I do this in VBox:

300 MB fat32 /boot/efi
18130 MB ext4 /
2048 MB linux-swap

Worth noting both of my daily computers have 520 GB SSD’s and notebook has 12 GB memory, desktop has 16 GB memory.


(rugyada) #28

Same here.
But useful to know tip for all the users.
:+1:


(Ben Bullard) #29

In that vein it is worth mentioning that while we are working on trying to get this to work what I do is a create a Lx 3 VM and update it. Then I clone that VM and run the script on the clone so I can keep cloning a fully updated ready to go system after every failed attempt with the script.


(Ben Bullard) #30

This is OT but I can’t resist:

Holy Crap, in the LXQt desktop the missing icons on the desktop still has not been fixed??? After what a year and half? Two years? (It seems like to me…)

Post-edit: Posted without brain fully engaged. Posted about ISO # 1701 after install and before updating. Updating might include a fix for this. We shall see shortly. This was a well know issue at the time ISO # 1701 was built.


(rugyada) #31

Naaah…
The bug is still there :confused:
ISO 1701 fully updated right now.

Postedit:
I’m looking for an old topic about LXQt where I published the icons. No lucky yet… @ben79 would you help me please if you happen to have some spare time? TY very much.

Post-postedit:
Nevermind, I found it :slight_smile:


(Ben Bullard) #32

Running the script on a VBox LXQt system got same result as it did on a Plasma5 system. Boot stops at “Switch root”. I did not investigate much this time as I believe I’ve been there done that. If @bero wants any more info or tests I’m sure he will ask. And I will happily comply.

Dog :dog2: gone it!

:monkey_face:


(Ben Bullard) #33

For anyone doing this with a LXQt install from ISO 1701 try from Install rather than Live as you will get a bigger, easier to work with Calamares window.


(Ben Bullard) #34