Updates checking and lists changed


OMX LX 3.0.3

KDE plasma

I use to watch at discovery messages for updating the system and then I do

$ urpmi --auto-update

This time, for networking problems, after answering “yes” to update the system, the process stopped abnormally.

After this, the checking for updates says “the system is up to date” although new packages are available. (For example, I have bluez-5.47-1-omv2015.0.x86_64 but bluez-5.49 is available).

Tried removing all repos and adding them again, but it didn’t work.

What is wrong in updating checking?

After removing all repos and adding again four time more, I got the updates back.

I think once the first attempt to update the system failed there’s been some kind of change in the order of actual repos urpmi would look at. In this case, a not up to date repo was set to be the first and then all package updates were no longer seen.

I would have to wait until all repos got up to date to have the updated list of packages again if I did not remove all configured repos and added them again.

Is this right?

It’s not strictly answering to your topic, however as a general tip&trick I’d suggest to always update with --test option before the real update.
One (among other) reason is because this way the system first download the needing packages and after it go forwards with full installation (this is especially recommended in case you see network-related packages).

1 Like

Maybe this can help:


1 Like

Ok! Thanks a lot.