Still no support for broadcom?

i just installed rome kde plasma to give it a spin, and i really like it, but i can never get broadcom to work so i end up going back to fedora or kubuntu as both always work for me…i have all repos enabled, and have “dkms-broadcom-wl” installed…still no luck…i looked through the forum and found nothing to solve it…heres my card and i appreciate the help…

Device-1: Broadcom BCM43142 802.11b/g/n driver: N/A
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
Device-3: Realtek RTL8187B Wireless 802.11g 54Mbps Network Adapter

Welcome to OpenMandriva and our forum.

We are a small group. All the contributors and developers here are unpaid volunteers.

You are welcome to talk to our developers at OpenMandriva Chat.

OpenMandriva wiki and Forum Resources guide.

For serious technical issues and package/feature requests please file a bug report here.

Try run in terminal:

sudo modprobe wl

Also make sure that secure boot is disabled.

Is this not help, please post here output of:



journalctl -b

You can also collect some info by;

inxi -Fxxxzr

This site lists all drivers supported by Linux kernel.For Broadcom BCM43142 it shows not supported. I have not idea if dkms-broadcom-wl and dkms-broadcom-wl-common work. Does user need to sudo modprobe b43?

I asked on OpenMandriva Chat:

We have a package dkms-broadcom-wl and dkms-broadcom-wl-common. Does this work? If so this user needs help making it work: Still no support for broadcom?.

We also seem to have b43-fwcutter and bcm43xx-fwcutter I have no idea it these work, how to use them or if that is what user d4k needs.

Edit: One reply right away:

Here they say Secure Boot should be off when installing the drver
wireless - BCM43142 WiFi adapter doesn't work on Ubuntu 20.04 - Ask Ubuntu

To accelerate the process you can go to OpenMandriva Chat and talk directly to OM devs.

It would help to know what driver Fedora and Kubuntu use? How do they get this particular device to work?

There is a package in Rolling non-free: b43-firmware-install

Description: Package that installs proprietary firmware for Broadcom 43xx chips

Does it work?

Edit: The following is about OMLx being a Community distribution of LInux:

Looks like that package is supposed to install some restricted (license) firmware that is not in Linux kernel. What we need is for some one with the necessary hardware to install it and tell us if it works. No one that I know of in contributor group has this hardware. Or if it does not work what error messages, what do logs say, ect. We can walk someone through how to gather the information if needed.

12 part time, unpaid, volunteers simply don’t have enough hardware to test everything.

Ideally the person who started the topic.

I do not know if it works, as I don’t currently use any WiFi adapters.

I looked in non-free, when I saw the reference to Broadcom.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.