Ssh with small priority

I have two computers in a network. I use to ssh from one computer to the other (wireless). This used to work relatively well but recently it changed. The ssh connection is incredibly slow now although nm velocity statistics registers up to 1.5 MB of data downloaded.

Do anybody else knows what could be wrong? The only change in the system results from regular system updates which I keep up to date.

Thanks

Hi,
there could be multiple causes of this behaviour and it is very hard to give an answer without more details. For example:
– are both computer ssh servers or only one?
– did you try with another client?
– do you use X11 forwarding?
– did you test the ping response time?
– did you do some other tests with traceroute or mtr (to be installed eventually)?
– others …?

1 Like

Hi JCLVanier,

1 - I can ssh from computer 1 to 2 and vice-versa. Does it responds to the question? Don’t know if they are servers …
2 - No, I don’t know any other client …
3 - Yes, I use to open graphical application from computer 1 at computer 2 (Thunderbird). It is during thunderbird sessions that the connection seems to be slower …
4 - Ping seems to work, although sometimes it slow down and then many packages appear at once
5 - No, did not try traceroute or mtr (don’t know what they are and what are they for).

I use to look at thunderbird (e-mail client) since, at least, the last three or four years. Just recently it became so slow.

Thanks a lot for answering

  • here, the server is the host running sshd (the remote host) and the client is the host initiating the connection (the local host). I was asking if you tried to tried to connect to the remote host with another computer in the network.
  • mtr gives some simple stats on the connection. After having installed it (it is in the repos) you can launch:
mtr IP_of_the_remote_host

See here for more infos.
You can get a simple report for 20 pings with:
mtr -c 20 --report

  • which OS is installed on each computer (2014, 3.0)?

  • Could you give those files: /etc/ssh/sshd.config (remote host running thunderbird) and /etc/ssh/ssh.config (local host)

  • you can also test the speed by sending a big file via sftp with filezilla or via scp in command line.

  • is the remote host’s CPU load high or low; what says the command top?

Other suggestions:

  • the options -v or -vv can give some clues when initiating a ssh connection, but it is not always easy to understand

  • are there some lags when connecting, when typing (is there a delay for displaying the letters when using the keyboard) during a session?

Hi,

Both systems are OMV LX 3.0 always with the last updates.

I use to sftp some files using konqueror, never was too slow.

In a ssh’ed session I occasionally experiment long lags during typing.

I will send sshd_config and ssh_config as soon as I figure out how to do it.

Many thanks

it follows sshd_config and ssh_config attached

And?

I guess “And?” means where are the attachments. I don’t know how to attach files in this site. Thus I sent them answering your message directly in my personal e-mail. The attachments are there and the body of the e-mail can be seen here in the forum but the attachments do not appear here in the forum site. Maybe you can see them in your personal e-mail too. Otherwise, either I copy/paste the attachment’s content (but they are a little extense) or, if possible, somebody tell me how to attach files in this forum…

JCLVanier,
Please, let me know if you can see the attachments at your personal e-mail.

I’m afraid that discourse doesn’t allow this kind of handling and I don’t see any attachment inside the mail sent by the forum.
You can paste the content in the body of the email, eventually surrounded by a tag like
[details=some title]
content
[/details]
that folds the “content”
Example:

some title

content

You can also hide a text directly using the forum’s editor via the cog-wheel on the right of the menu.

I’ll do this in the next two posts. First the ssh_config …

The ssh_config:

#	$OpenBSD: ssh_config,v 1.30 2016/02/20 23:06:23 sobrado Exp $

# This is the ssh client system-wide configuration file.  See
# ssh_config(5) for more information.  This file provides defaults for
# users, and the values can be changed in per-user configuration files
# or on the command line.

# Configuration data is parsed as follows:
#  1. command line options
#  2. user-specific file
#  3. system-wide file
# Any configuration value is only changed the first time it is set.
# Thus, host-specific definitions should be at the beginning of the
# configuration file, and defaults at the end.

# Site-wide defaults for some commonly used options.  For a comprehensive
# list of available options, their meanings and defaults, please see the
# ssh_config(5) man page.

# Host *
#   ForwardAgent no
#   ForwardX11 no
#   RhostsRSAAuthentication no
#   RSAAuthentication yes
#   PasswordAuthentication yes
#   HostbasedAuthentication no
#   GSSAPIAuthentication no
#   GSSAPIDelegateCredentials no
#   BatchMode no
#   CheckHostIP yes
#   AddressFamily any
#   ConnectTimeout 0
#   StrictHostKeyChecking ask
#   IdentityFile ~/.ssh/identity
#   IdentityFile ~/.ssh/id_rsa
#   IdentityFile ~/.ssh/id_dsa
#   IdentityFile ~/.ssh/id_ecdsa
#   IdentityFile ~/.ssh/id_ed25519
#   Port 22
#   Protocol 2
#   Cipher 3des
#   Ciphers aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc
#   MACs hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160
#   EscapeChar ~
#   Tunnel no
#   TunnelDevice any:any
#   PermitLocalCommand no
#   VisualHostKey no
#   ProxyCommand ssh -q -W %h:%p gateway.example.com
#   RekeyLimit 1G 1h

Host *
ForwardX11 yes
Protocol 2,1

# If this option is set to yes then remote X11 clients will have full access
# to the original X11 display. As virtually no X11 client supports the untrusted
# mode correctly we set this to yes.
ForwardX11Trusted yes

# Send locale-related environment variables
#SendEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
#SendEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
#SendEnv LC_IDENTIFICATION LC_ALL
StrictHostKeyChecking no

The sshd_config:

#       $OpenBSD: sshd_config,v 1.100 2016/08/15 12:32:04 naddy Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/local/bin:/bin:/usr/bin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options override the
# default value.

#Port 22
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
HostKey /etc/ssh/ssh_host_ed25519_key

# Ciphers and keying
#RekeyLimit default none

# Logging
SyslogFacility AUTHPRIV
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
# Warning!!!
# For better security use PermitRootLogin without-password
# after setting up ssh keys for host and server
#PermitRootLogin prohibit-password
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10

# Warning !!!
# For better security always use PubkeyAuthentication yes
# after setting up ssh keys for host and server
#PubkeyAuthentication yes

# The default is to check both .ssh/authorized_keys and .ssh/authorized_keys2
# but this is overridden so installations will only check .ssh/authorized_keys
AuthorizedKeysFile      .ssh/authorized_keys

#AuthorizedPrincipalsFile none

#AuthorizedKeysCommand none
#AuthorizedKeysCommandUser nobody

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
# Warning !!!
# For better security always use "no" for PasswordAuthentication and PermitEmptyPasswords
# after setting up ssh keys for host and server
PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
# Warning !!!
# For better security always use "no" for ChallengeResponseAuthentication
# after setting up ssh keys for host and server
#ChallengeResponseAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

# Accept locale-related environment variables
AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
AcceptEnv LC_IDENTIFICATION LC_ALL

#AllowAgentForwarding yes
#AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

# Accept locale-related environment variables
AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
AcceptEnv LC_IDENTIFICATION LC_ALL

#AllowAgentForwarding yes
#AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PermitTTY yes
PrintMotd yes
PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation sandbox
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS no
#PidFile /var/run/sshd.pid
#MaxStartups 10:30:100
#PermitTunnel no
#ChrootDirectory none
#VersionAddendum none

# no default banner path
Banner /etc/issue.net

# override default of no subsystems
Subsystem       sftp    /usr/lib64/ssh/sftp-server

# Example of overriding settings on a per-user basis
#Match User anoncvs
#       X11Forwarding no
#       AllowTcpForwarding no
#       PermitTTY no
#       ForceCommand cvs server

The character format seems to have been altered somehow …

JCLVanier,

After updating nm libraries from,

lib64nm0-1.2.6-1-omv2015.0.x86_64
lib64nm-util2-1.2.6-1-omv2015.0.x86_64
lib64nm-gir1.0-1.2.6-1-omv2015.0.x86_64
lib64nm-glib4-1.2.6-1-omv2015.0.x86_64
lib64nm-glib-vpn1-1.2.6-1-omv2015.0.x86_64

to,

lib64nm-util2-1.6.2-1-omv2015.0.x86_64
lib64nm0-1.6.2-1-omv2015.0.x86_64
lib64nm-glib-vpn1-1.6.2-1-omv2015.0.x86_64
lib64nm-glib4-1.6.2-1-omv2015.0.x86_64
lib64nm-gir1.0-1.6.2-1-omv2015.0.x86_64

I have not experimented this “small priority” problem as seriously as before although another “bigger” problem arose. The new problem is described in another post at this forum:

“Networkmanager last updates caused problems”

thanks

Hope it’s OK, I edited posts 10 and 11 to put some giant type in code box (</ >). Hoping to improve look and conserve space.

1 Like

Thanks Ben79

You might try this one by one:
– in sshd_config uncomment #UseDNS no
– if you don’t use ipv6, launch ssh with the option -4 that forces ssh to use only ipv4

Question: how do you start the ssh session?

I start ssh simply with,

$ ssh 192.168.0.100

Then, I give my password in the other computer.

Do you mean the sshd_config in the “other” computer?

I’ve tried the ssh -4 (forcing ipv4). Didn’t notice any change, still a lag between typing and look, and so on.

thanks

Yes, I meant the server’s config file (on the remote host: 192.168.0.100). But, since you directly use IP address I guess this will not give significant changes.

Could you try this:
ssh -vvv 192.168.0.100
and give the output?

We could, with a bit of luck, find a clue.

I’ve took some of ssh -vvv messages in a file. As I got the ssh’ed computer I tried thunderbird and received a lot, a huge amount of messages. I’ve cut most of them and copied some of the last (when I finished thunderbird) messages.

It follows the recorded messages:

OpenSSH_7.5p1, OpenSSL 1.0.2k 26 Jan 2017
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 52: Applying options for *
debug2: resolving “192.168.0.101” port 22
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to 192.168.0.101 [192.168.0.101] port 22.
debug1: Connection established.
debug1: key_load_public: No such file or directory
debug1: identity file /home/adelson/.ssh/id_rsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/adelson/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/adelson/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/adelson/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/adelson/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/adelson/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/adelson/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/adelson/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_7.5
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.5
debug1: match: OpenSSH_7.5 pat OpenSSH* compat 0x04000000
debug2: fd 3 setting O_NONBLOCK
debug1: Authenticating to 192.168.0.101:22 as ‘adelson’
debug3: hostkeys_foreach: reading file “/home/adelson/.ssh/known_hosts”
debug3: record_hostkey: found key type RSA in file /home/adelson/.ssh/known_hosts:10
debug3: load_hostkeys: loaded 1 keys from 192.168.0.101
debug3: order_hostkeyalgs: prefer hostkeyalgs: ssh-rsa-cert-v01@openssh.com,rsa-sha2-512,rsa-sha2-256,ssh-rsa
debug3: send packet: type 20
debug1: SSH2_MSG_KEXINIT sent
debug3: receive packet: type 20
debug1: SSH2_MSG_KEXINIT received
debug2: local client KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha256,diffie-hellman-group14-sha1,ext-info-c
debug2: host key algorithms: ssh-rsa-cert-v01@openssh.com,rsa-sha2-512,rsa-sha2-256,ssh-rsa,ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ssh-ed25519-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-ed25519
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,aes128-cbc,aes192-cbc,aes256-cbc
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,aes128-cbc,aes192-cbc,aes256-cbc
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com,zlib
debug2: compression stoc: none,zlib@openssh.com,zlib
debug2: languages ctos:
debug2: languages stoc:
debug2: first_kex_follows 0
debug2: reserved 0
debug2: peer server KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group14-sha256,diffie-hellman-group14-sha1
debug2: host key algorithms: ssh-rsa,rsa-sha2-512,rsa-sha2-256
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com
debug2: compression stoc: none,zlib@openssh.com
debug2: languages ctos:
debug2: languages stoc:
debug2: first_kex_follows 0
debug2: reserved 0
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: rsa-sha2-512
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: compression: none
debug3: send packet: type 30
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug3: receive packet: type 31
debug1: Server host key: ssh-rsa SHA256:MgOnWF3uOtje6Uj06DwEZciNXC7k0M3feWp1AXq6hnQ
debug3: hostkeys_foreach: reading file “/home/adelson/.ssh/known_hosts”
debug3: record_hostkey: found key type RSA in file /home/adelson/.ssh/known_hosts:10
debug3: load_hostkeys: loaded 1 keys from 192.168.0.101
debug1: Host ‘192.168.0.101’ is known and matches the RSA host key.
debug1: Found key in /home/adelson/.ssh/known_hosts:10
debug3: send packet: type 21
debug2: set_newkeys: mode 1
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug3: receive packet: type 21
debug1: SSH2_MSG_NEWKEYS received
debug2: set_newkeys: mode 0
debug1: rekey after 134217728 blocks
debug2: key: /home/adelson/.ssh/id_rsa ((nil))
debug2: key: /home/adelson/.ssh/id_dsa ((nil))
debug2: key: /home/adelson/.ssh/id_ecdsa ((nil))
debug2: key: /home/adelson/.ssh/id_ed25519 ((nil))
debug3: send packet: type 5
debug3: receive packet: type 7
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521>
debug3: receive packet: type 6
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug3: send packet: type 50
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug3: start over, passed a different list publickey,password,keyboard-interactive
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/adelson/.ssh/id_rsa
debug3: no such identity: /home/adelson/.ssh/id_rsa: No such file or directory
debug1: Trying private key: /home/adelson/.ssh/id_dsa
debug3: no such identity: /home/adelson/.ssh/id_dsa: No such file or directory
debug1: Trying private key: /home/adelson/.ssh/id_ecdsa
debug3: no such identity: /home/adelson/.ssh/id_ecdsa: No such file or directory
debug1: Trying private key: /home/adelson/.ssh/id_ed25519
debug3: no such identity: /home/adelson/.ssh/id_ed25519: No such file or directory
debug2: we did not send a packet, disable method
debug3: authmethod_lookup keyboard-interactive
debug3: remaining preferred: password
debug3: authmethod_is_enabled keyboard-interactive
debug1: Next authentication method: keyboard-interactive
debug2: userauth_kbdint
debug3: send packet: type 50
debug2: we sent a keyboard-interactive packet, wait for reply
debug3: receive packet: type 60
debug2: input_userauth_info_req
debug2: input_userauth_info_req: num_prompts 1
Password:

debug3: send packet: type 61
debug3: receive packet: type 60
debug2: input_userauth_info_req
debug2: input_userauth_info_req: num_prompts 0
debug3: send packet: type 61
debug3: receive packet: type 52
debug1: Authentication succeeded (keyboard-interactive).
Authenticated to 192.168.0.101 ([192.168.0.101]:22).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug3: send packet: type 90
debug1: Requesting no-more-sessions@openssh.com
debug3: send packet: type 80
debug1: Entering interactive session.
debug1: pledge: exec
debug3: receive packet: type 80
debug1: client_input_global_request: rtype hostkeys-00@openssh.com want_reply 0
debug3: receive packet: type 91
debug2: callback start
debug2: x11_get_proto: /usr/bin/xauth list :0 2>/dev/null
debug1: Requesting X11 forwarding with authentication spoofing.
debug2: channel 0: request x11-req confirm 1
debug3: send packet: type 98
debug2: fd 3 setting TCP_NODELAY
debug3: ssh_packet_set_tos: set IP_TOS 0x10
debug2: client_session2_setup: id 0
debug2: channel 0: request pty-req confirm 1
debug3: send packet: type 98
debug2: channel 0: request shell confirm 1
debug3: send packet: type 98
debug2: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768
debug3: receive packet: type 99
debug2: channel_input_status_confirm: type 99 id 0
debug2: X11 forwarding request accepted on channel 0
debug3: receive packet: type 99
debug2: channel_input_status_confirm: type 99 id 0
debug2: PTY allocation request accepted on channel 0
debug2: channel 0: rcvd adjust 2097152
debug3: receive packet: type 99
debug2: channel_input_status_confirm: type 99 id 0
debug2: shell request accepted on channel 0
Last login: Thu May 4 22:27:23 2017 from 192.168.0.106

Comments****
Now it begins a thunderbird session …




debug2: channel 1: window 2040944 sent adjust 56208
debug2: channel 1: window 2031616 sent adjust 65536
debug2: channel 1: window 2040944 sent adjust 56208
debug2: channel 1: window 2031616 sent adjust 65536
debug2: channel 1: window 2031616 sent adjust 65536
debug2: channel 1: window 2040944 sent adjust 56208
debug2: channel 1: window 2031616 sent adjust 65536
debug3: receive packet: type 96
debug2: channel 2: rcvd eof
debug2: channel 2: output open -> drain
debug2: channel 2: obuf empty
debug2: channel 2: close_write
debug2: channel 2: output drain -> closed
debug1: channel 2: FORCE input drain
debug2: channel 2: ibuf empty
debug2: channel 2: send eof
debug3: send packet: type 96
debug2: channel 2: input drain -> closed
debug2: channel 2: send close
debug3: send packet: type 97
debug3: channel 2: will not send data after close
debug3: receive packet: type 97
debug2: channel 2: rcvd close
debug3: channel 2: will not send data after close
debug2: channel 2: is dead
debug2: channel 2: garbage collecting
debug1: channel 2: free: x11, nchannels 3
debug3: channel 2: status: The following connections are open:
#0 client-session (t4 r0 i0/0 o0/0 fd 4/5 cc -1)
#1 x11 (t4 r3 i0/0 o0/0 fd 7/7 cc -1)
#2 x11 (t4 r4 i3/0 o3/0 fd 8/8 cc -1)

debug3: receive packet: type 96
debug2: channel 1: rcvd eof
debug2: channel 1: output open -> drain
debug2: channel 1: obuf empty
debug2: channel 1: close_write
debug2: channel 1: output drain -> closed
debug1: channel 1: FORCE input drain
debug2: channel 1: ibuf empty
debug2: channel 1: send eof
debug3: send packet: type 96
debug2: channel 1: input drain -> closed
debug2: channel 1: send close
debug3: send packet: type 97
debug3: channel 1: will not send data after close
debug3: channel 1: will not send data after close
[adelson@pc-central ~]$ debug3: channel 1: will not send data after close
debug3: receive packet: type 97
debug2: channel 1: rcvd close
debug3: channel 1: will not send data after close
debug2: channel 1: is dead
debug2: channel 1: garbage collecting
debug1: channel 1: free: x11, nchannels 2
debug3: channel 1: status: The following connections are open:
#0 client-session (t4 r0 i0/0 o0/0 fd 4/5 cc -1)
#1 x11 (t4 r3 i3/0 o3/0 fd 7/7 cc -1)