Solved: LibreOffice-5.4.3-2 with fix for "Save" issue in Main-testing repo

Tags: #<Tag:0x00007fe47113edb0> #<Tag:0x00007fe47113ece8>

Hello,

  • OpenMandriva Lx version: Lx 3

  • Desktop environment (KDE, LXQT…): Any. At least as far as I know.

  • Description of the issue (screenshots if relevant):
    New LibreOffice packages somehow got moved from main-testing to main-updates repo even though there are people working on a serious problem.

Some users are reporting a problem with saving odt and docxx files.
Screen shot maybe later.

  • Relevant informations (hardware involved, software version, logs or output…):

libreoffice-5.4.3 is the version that may have this issue. Users are advised to stay with libreoffice-5.3.3 for now.

Bug report here.

To keep current version of libreoffice edit the file (as root or su) ‘/etc/urpmi/skip.list’ and add /^libreoffice/ and save file. Then pay attention when installing any updates and be sure libreoffice-5.4.3 is not called.

Of course anyone may be brave and update at their own risk. But you have been warned.

Screen shot. I make a change to an .odt document and attempt to save and this happens:

And then when a wait 180 seconds and then terminate file and attempt to open it again I see this:

and after I let it recover the document I see that my change was not in fact saved. Ergo this version (5.4.3) of LibreOffice is broken for me and at least some other users.

This screen shot simply shows the version of LibreOffice with this issue.

The same version from libreoffice.org works well.

Try the 6.0 beta from cooker – at least for me it works much better than any released 5.4.x.

Thanks for the tip but there are too much dependencies for 3.03 to test it from cooker.
The dev release from libreoffice.org works well.

We, well not me, but crazy on IRC and @Colin have come up with a couple of possible workarounds.

One is to create the file /etc/profile.d/lo.sh with:

#!/bin/sh

export VCL_NO_THREAD_SCALE=1

and reboot. The other is to simply run as user in Konsole or other terminal:

$ export VCL_NO_THREAD_SCALE=1

that one should work immediately if not sooner.

Edit: @ben79 screws up again. Correction someone going by the handle vmiklos at upstream is responsible for this workaround.

I have this issue too but only on LibreOffice from OpenMandriva repository. When I use Appimage LO 5.4.3 from here Stable – LibreOffice AppImage Package I have no issue.

Also prebuild binary (with auto-updater) from LO 6.0 alpha work fine. Here link http://dev-builds.libreoffice.org/daily/master/Linux-archive-x86_64@80-updater/current/

@bero has been so kind as to make new packages for LibreOffice-5.4.3 (release-2) that contain a fix for the issue some users reported with saving .odt, .doc, and .docx files. The packages are in main-testing repository.

After a quick test (in VBox), it seems to works. I don’t recommend to install it from main-testing however because other packages will be installed also (especially systemd-235-7).

These packages are in main-updates repo thus available to all. Closing topic.