ROME 23.03 (Plasma zvner1) GUI and controls setup

Hello everyone, have a nice day.
First, thank you a million times for your great Linux distribution! I am deeply grateful for your accomplishments.

I am new to OpenMandriva Lx. Before, I was a longtime user and victim/prey of MS Windows XP to 8.1 trying some dives into Linux over years. With the last somewhat usable MS Windows OS sinking into Hades, I am seeking refuge for family members, friends, pals and colleges. OpenMandriva Lx seems to be the way to go forward.

But for that, I need some start-up aid. I hope, at some point you can lend me your hand over the course of some weeks. Most of the basics are already working on the 2 different private PCs I put ROME on.

systems specs:

  • ROME 23.03 znver1
  • Plasma on PC 1; LXQt given up, then supplemented with Plasma on PC 2
  • software versions according to dnfdragora and Discover: everything in its current version
  • “About System” (information) screen output:

Operating System: OpenMandriva ROME 23.03
KDE Plasma Version: 5.27.3
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 6.2.6-desktop-1omv2390 (64-bit)
Graphics Platform: Wayland [for now; suggestions welcome]
Processors: [last few years’ mainstream ones]
Memory: [plenty]
Graphics Processor: [a tap older than CPUs; still running fine]

obstacles/problems so far:

  1. My folks including me are used to use a all-in-one taskbar/Quick Launch bar, which means a column without gaps of some of the most-used programs/shortcuts. The program icon’s position on taskbar shall neither change nor duplicate when being opened, it shall simply stay the same. Currently, some icons place themselves elsewhere upon start, some even create a (slightly larger) copy of them on the bar’s right end. It is confusing and silly for us.
    ** On a side note, what can be the reason for not being allowed to pin a program to taskbar via right click context menu (grayed out option)?
  2. Oftentimes, program windows forget/scrap their last position and/or size. They just reposition… wherever. I thought that is a strange phenomenon exclusive to newer MS Windows OSs.
  3. Only on root account of both OMLx installations, audio icon on info bar (left next to time & date display) always states [translation]: “no audio input or output devices found”, though PC speakers and sound output running fine. Switching from Pipewire to PulseAudio or ALSA does not help (or work at all). User accounts are fine.
  4. One PC’s keyboard features a special key for instantly entering sleep/energy-saving mode. I never use that with intent, but press it sometimes by accident. MS Windows 8.1 allows disabling its function. How can I disable the key inside OMLx?
  5. We like to assign some F[n] keys to play/pause music, forward to next music track, return to previous music track, ideally forward/wind back some seconds. At least 2 MS Windows software music players allow that and more. I could not find a way to replicate those functions within Audacious player.
    ** On a side note: Audacious bemoans about every single music file. Its evergreen is: “could not update timestamps for skipped samples”. There are several different complaints, e. g. “could not convert locale […]”. Yet, playback of most to all files is fine.
  6. How can we easily run program/window instances without root privileges inside root account? Some programs do not start with root privileges, others bemoan it as unnecessary.
  7. Most settings/changes I do on root account are not reflected to the corresponding user account(s). How can I apply configuration and GUI changes to all accounts?
  8. In general, the Plasma-only OMLx installation on PC 1 works better than the LXQt-based mis-choice I tried to remedy. I consider creating an image of the OMLx partition (plus auxiliary partition(s), if necessary). How can I do that best/most easily?

Hoping for help and assistance
Kind regards

Welcome to OpenMandriva and our forum.

We are a small group. All the contributors and developers here are unpaid volunteers.

You are welcome to talk to our developers at OpenMandriva Chat.

OpenMandriva wiki and Forum Resources guide.

For serious technical issues and package/feature requests please file a bug report here.

Thanks for posting these issues. This is a fantastic opportunity for OM contributor group to solve some issues a Windows user new to Linux and OMLx encounters. OMLx refers to any version of OpenMandriva operating system including ROME, Rock, and Cooker (development platform).

@Tachyonenstrahl you are asking a lot of questions in one thread. As we resolve these issues other users won’t be able to find the thread with that issue. Because of this we prefer users to post one issue per thread.

Let me attempt to help with one point:

Regarding # 3 if you are logging in to desktop as root why? That is not normal or recommended because it is dangerous, especially for an inexperienced user. Developers only allow logging in as root for the rare occasion when a user can’t login as user, then you can login as root to correct that problem. You can do anything that requires root privilages when logged in as user. Some applications like KUser or KDE Partition Manager will first open a dialog window prompting user for root password. If you use a text editor (Kate or Kwrite) to edit a configuration file that requires root privilages when you select to “save” the file a dialog window prompting user for root password opens. Additionally you can do almost everything requiring root privilages from Konsole (terminal) with the sudo command. If you type a command in Konsole that requires sudo you will be prompted to add sudo to your command.

You can also open Konsole and type su (super user or root) and it prompts you for your root passwd. Be careful with this and using sudo as you can break your system if you do not know what you are doing. For inexperienced user the sudo command is safer than logging in as su.

The first user created when you install OMLx has sudo privileges by default. You can add other users to sudo with the command visudo in Konsole. Again be careful with this because someone inexperienced can do damage with sudo.

I recommend you select the 2 or 3 most important issues and create seperate threads for each and we work on those and get these issues resolved one by one. You may find some answers in the OpenMandriva wiki and Forum Resources guide.

I hope my post proves to be helpful.

Also remember that internet search or googling is your friend in solving issues. A lot of commands are used across all Linux distros. Things like package management are more distro specific.

OMLx uses dnf for package management as does Fedora, RedHat, and CentOS and a few others. How to use dnf.

If you are in doubt you can always ask here or on OpenMandriva Chat. Chat is likely to provide a faster answer but remember folks may not be in your time zone or even close so you do need patience and wait for a response/answer.

Have a nice day again.
First: Of course, I tried online search first for the problems I could translate into search terms. Most of my problems got solved that way. What you can read here are the remnants.

I will try sorting my problems out and put them into separate support threads. I am afraid it will take some months’s time.

Only one problem I would like to solve inside here: What can I do if OMLx/Plasma does not allow pinning a program to taskbar? What to do if the right-click context menu option “pin to window bar” (or similar) is grayed out?

taskbar as it should be: Audacious, Vivaldi browser and Dolphin windows open, other icons left and right inactive:
taskbar as it should be - Audacious, Vivaldi browser and Dolphin windows open…But other programs are not allowed to join.


I wanted to configure everything once for all subsequent user accounts. In the Windows OSs world, that works to some degree. I suppose on OMLx, the same configuration steps have to be done manually for every single user account?

Common procedure:


What applications you can’t pin?

1 Like

Hi @Tachyonenstrahl, that is not how linux works. root profile can’t influence user one in any way. In order to configure a program for all the system you can:

  • modify the corresponding configuration file in /etc directory. Usually this is the way to change the behavior of a single program;
  • if you need to configure something you cannot do as before (eg. a plasma configuration) you may do this in a user profile (not necessary root’s one) so it will be create a configuration file inside it, usually in ~/.config directory (but mostly depends on what are you doing) then copy it into ~/ect/skel~ direcotry.

Here is an idea about how custom shortcut works on Plasma.

Thanks, rugyada!
Your first suggestion helped me figuring out I first have to add the program to “Task Manager” start menu. Only after that I am allowed to pin the program to taskbar/window bar.

Unfortunately, both starting the program via the new “Task Manager” start menu entry and starting it by the taskbar/window bar item results in a Plasma pop-up message saying the program could not be found. It is in the same place as before and can be started manually. I am just not allowed to pin the working program anywhere. I tried changing back and forth between the start menu “alternatives”, but it does not help.

Well, obviously I have to give up on this OMLx partition. The other one or a new one has to win the game.

Thank you, mandian!
I will try your tips about config files on the sane partition as soon as I can.

The How-to’s way of customizing shortcuts does not work here on the corrupt/rotten partition. At least Audacious totally ignores my hotkeys/shortcuts even after closing and re-opening it several times. I am curious about it on the sane partition, but suppose they will refuse to work there, too. Because the “pause” key was set as a media playback shortcut already by default under the alias “Media Play”. However, it did never do its job.

You want to check the files permissions too.

Again, what applications you can’t pin? Please provide an example we can reproduce.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.