Problem with Konsole

Dear OpenMandriva gurus,

these days I have installed and looked around in the new version 4.3 in order tot be able to help my brother when he installs it instead of his old Rosalinux installation. A real difficulty for me is using konsole: the cursor is placed a number of spaces fa(about 10) rther to the right than the insertion point of typed characters. This makes copying texts within konsole and correcting typed text difficult. In my opinion this must be a programming error. In kate this happens too. Is this a problem in my installation only, or is it a real error? If not, how do I correct it.

Thank you in advance for your help.

Erik, a grateful user.

That is odd. I do not have that. If other users did I am sure we would hear about it.

In both instances cursor is where it should be.

@Erik are you sharing a /home partition with another operating system?

Dear Ben79,

no, I do not share one /home partition with two linux systems, in order tot avoid problems.

I spent a lot of time, two days, and two hard drives to learn and solve the problem on the drive where it matters.
On the second drive I installed a dummy user called “dummy” with UID:GID 1001:1006. I removed the phantom user groups between GID 1000 through 1005. Then I added the user it is all about with GID:UID 1000:1000 with th already existing home directory. It all worked, except that now I get this error:

As you see it is not konsole that opens, but bin/sh.
The Dutch test translates as: “Warning: Could not find I-do-not-know-what (’ '). ‘/bin/sh’ has been opened instead. check your profile settings.”

As you see the cursor stand at the correct place, just after the character I just typed. This is the most important thing for me. I tried to find the “profile settings”, but I have no idea where to find them. The dummy screen of konsole is correct. So the problem is not one of the system. As an experiment I renamed the .donfi and .local files from the dummy user. and logged in again. this die not make a difference. So the "profile settings are not in these directories. After this I installed Openmandriva on a second hard drive in the same way. On the second drive this problem does not occur. The difference between te two is, that on the first drive the home directory is old and the dummy new, and on the second both are new.

I seriously doubt to recommend to install OMa on his computer. He too has an old home directory. He lives in Italy, and I live in Holland. So it will be very difficult to fight the system from the beginning until it gives up and letts us have our way. And all this misery because of a few phantom groups that ought to be empty and easily used for the users.

It will be much and much easier to install Linux Mint. Mint does not fight the user, and does not try to prevent the user form easily making changes in system files if necessary.

If you, or anyone else readin g this, knows how to get konsole working again, I shall be most thankful. The simple fact is: the community made a beautiful system! The only problem is the presence of the phantom groups that make life difficult for simple users like me.

Thank you very much for the trouble you have taken to help me.


Let’s stick to Konsole issue in this thread otherwise the other issues will be to difficult for someone else to follow.

Konsole has a setting for “Command” under Settings>Edit current profile>General (in English). It is set by default to /bin/bash. Yours is set to /bin/sh. Different shell types are described here.

Or some how bash got removed, if so re-install bash. You can check this with rpm -qa command:

$ rpm -qa | grep bash

Ben79, you are a genius!!!
I made a new profile with the change you recommended, and now all seems to be normal and as expected again.

I am very pleased with this forum. real help for simple users as I am.

Thank you very much!


2 posts were merged into an existing topic: Some questions about UIDs, GIDs, urpmi and auto-update after installation of OMa 4.3

A post was merged into an existing topic: Some questions about UIDs, GIDs, urpmi and auto-update after installation of OMa 4.3

Moderator: I moved posts about UID and GID stuff to that thread. I hoped to make it easier for other people to follow the discussion.

Please try to keep threads to the topic in the title. Otherwise users can not find existing posts about some problem they may have.