OpenMandriva LX3.0 problems


yesterday I tried to install new OpenMandriva LX3.0 64bit and I faced to following problems:

  • During installation after I entered user name and password and pressed Next button, I saw internet connection error and after a while whole install window disappeared (probably crashed) and PC was rebooted. I have only WiFi connectivity (with password protection - WPA2), that’s probably why installer couldn’t connect to internet. I found clue: to press Next button immediately when I see connectivity error. Then it doesn’t crash and I continue with next page.

  • When first time booted from SSD after installation, I saw welcome window, where I should be able to click some tabs or Next button, nothing was working, window was frozen and I had to kill the application.

  • Then I wanted to connect to WiFi, so I entered password and immediately some dialog about KDE wallet was shown asking with 2 radio buttons what encryption method to use. I don’t want to store my passwords in KDE wallet, so I clicked Cancel, but password wasn’t stored and asked me again and again. So it seems without using of KDE wallet it isn’t possible to store password for WiFi and connect to net.

  • With live mode booted from CD as well as after installation, I have big problem with graphics. I have NVIDIA GTX 950. Many times I see corrupted graphics around mouse cursor, there remains some small squares on screen without refreshing (I can provide screenshot later, I am not at my home PC right now). It can be for example seen when entering password and deleting some chars back, then it is completely broken. By default there is nouveau driver running, so I plan to use NVIDIA installer from NVIDIA website (that’s is how I always used to do in 2014.2) and hopefully it will fix my issue. But I fear there will be problem with NVIDIA installer according to this thread But I will try and let you know. Without this issue fix, I can’t use LX3.0, it is unusable.


Note: I don’t have nVidia hardware so can’t test any of this. Some people don’t have good results with driver from nVidia website. Have you tried (from Release Notes):

To access XFDrake, the DrakX video configuration tool go to Om-Welcome>Configure>Configure video drivers or go to Configure your Computer>Hardware>Set up the graphical server.

Latest proprietary nVidia drivers were published yesterday and Non-free-updates repository.
If you do get driver from nVidia website working you might post steps to do so here for other users.

This is cheating but it works and is less of a pain in the buttocolous. When I boot ‘Live’ .iso or 1st boot into a new installed system and go to set up wi-fi when the Wallet Manager opens I select to use ‘Classic’ and when the window opens to set KDE Wallet password I enter nothing and select OK. This way every time I login or reboot wi-fi ‘just works’ and there is no password to enter.

I’m not smart enough to understand why it’s OK to auto login to a system but then have to issue a password for internet access.

Same problem. But I could have my wifi password set after all. This way: after first attempt to connect (and KDE wallet problems…) my network is no longer in the current list of available ones but, if I click on the setting button of the “networkmanager” a new window is seen where my wifi is listed. Then, I select it, click on Edit and give password and click on the saving button. It is now saved and KDE wallet did not disturbed me again.

At this point it is interesting to add that for saving password one is asked if the password is going to be available only for one user or all of them. It seems to work only if this is available to everyone (not encrypted saving).

Maybe better solution than what I wrote.

Thanks for hints. Regarding KDE Wallet I disabled it and stored WiFi password via Edit in Network configuration. So no problem now.

Much bigger problem is with NVIDIA driver. I tried the installer from their web site and I came to same error as the guy in the mentioned thread: “could not start kdeinit5”. So as you recommended I tried the nvidia rpm in non-free repository and again same result as in the mentioned thread: missing

Dialog asked me if to continue anyway or Cancel, I chose Cancel and whole PC was frozen, even mouse or keyboard didn’t react. Something similar happened me yesterday once before. Also now I did hard reboot, but then I wasn’t able to start KDE anymore. In that session I installed also some update packages offered by update manager. So now I don’t know what is the problem root cause (if packages update or OS hard reboot). I have only console available and “systemctl status sddm.service” shows:

sddm.service - Simple Desktop Display Manager
Loaded: loaded (/lib/systemd/system/sddm.service; enabled; vendor preset: enabled)
Active: failed (Result: start-limit-hit) since Mon 2016-08-22 05:18:48 CEST; 2min 34s ago
Docs: man:sddm(1)

Process: 4436 ExecStart=/usr/bin/sddm (code=dumped, signal=SEGV)
Process: 4434 ExecStartPre=/bin/plymouth quit --retain-splash (code=exited, status=1/FAILURE)
Main PID: 4436 (code=dumped, signal=SEGV)

Aug 22 05:18:48 localhost systemd[1]: Failed to start Simple Desktop Display Manager.

How to make KDE working?

Btw.: I found new ROSA Desktop Fresh R8 is released. Is it more stable as LX3.0? Does it make sense to reinstall OpenMandriva 2014.2 to ROSA R8? Do I get newer OS version (I mean newer components like KDE, etc.)? It seems for now I am not able to make LX3.0 working properly.

For info, related bugzilla ticket.

From Crispin Boylan on OM Cooker ML:

GLdispatch is in:


so the file is not missing it was just an autodep failure of rpm.

fixed now in 367.44-1

hello, i read all that problems here, but i have a different one. I installed open mandriva 2014 and all was good, but 2 weeks ago i installed openmandriva lx3 and now i connect my modem huawei E3531 4G but nothing happen. I cant to install my modem USB. Ports are good cuz i can use my memory usb in all ports. Anyone knows what to do to install it manually? and how? i am a new user with a based OS of linux and dont know why this lx3 dont detect my modem anyway. I am like a kid with this OS, dont know it. Ty!!

Welcome to OpenMandriva. Hope we can help with this. First could you open a new thread on this specific issue after reading the helpful advice here.

If no one in the forum can help then next step is to file a bug report to get the attention of our developers. More about fileing bug reports is here.

Don’t let the links and little bit of readying bother you. It doesn’t take that long and helps us to help you (helps a lot!). Anything you don’t know how to or don’t understand just ask and someone will try to help.