OpenMandriva 3.01 freezes

Hello! After unsuccessful running or installation of OpenMandriva 3.01 on my Toshiba laptop, i tried to run the distro on another laptop: Asus X52DE. It runs normal but during normal operation (browsing the net, doing some usual things) the whole desktop hangs. I can switch through virtual terminals with ALT+F?, but KDE just hangs. I rebooted the live cd again, but after some time it hanged again. I’m a big fan of Mandriva since Mandrake and I really want to see this distro one of the top like it was before. I offer the team to unite their force with Mageia and to come up with one of the top distros and to give joy to their fans. I wish you a lot of luck and smart moves in the new year. All the best! :wink:

Yes we are aware of this Plasma hangs. And we are not only one distribution affected by this issue.

There are no known fix for this yet, but workarounds does exist:

  1. Switch VT (press alt+ctrl+F2, and press alt+ctrl+F1)
  2. Enable DRI3 in your xorg.conf.d

List of bugreports:
https://bugs.kde.org/show_bug.cgi?id=373131
https://bugzilla.redhat.com/show_bug.cgi?id=1384843
https://bugzilla.redhat.com/show_bug.cgi?id=1399396
https://bugs.mageia.org/show_bug.cgi?id=19869
https://bugs.kde.org/show_bug.cgi?id=373427

I have had the same problem with OpenMandriva Lx 3.0.
uname -a
Linux localhost.localdomain 4.9.1-desktop-4omv #1 SMP PREEMPT Sun Jan 8 22:53:01 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Dell laptop E6520

I have added the http://ftp-stud.hs-esslingen.de/pub/Mirrors/openmandriva/3.0/repository/x86_64/media/main/testing repository.
And I have installed these packages:
http://ftp-stud.hs-esslingen.de/pub/Mirrors/openmandriva/3.0/repository/x86_64/main/testing/x11-server-xorg-1.19.1-1-omv2015.0.x86_64.rpm
http://ftp-stud.hs-esslingen.de/pub/Mirrors/openmandriva/3.0/repository/x86_64/main/testing/x11-server-xwayland-1.19.1-1-omv2015.0.x86_64.rpm
http://ftp-stud.hs-esslingen.de/pub/Mirrors/openmandriva/3.0/repository/x86_64/main/testing/x11-server-common-1.19.1-1-omv2015.0.x86_64.rpm

I have rebooted but the system has frozen.
I have booted into the recovery mode and started startx.
I have started drakx11 and installed the nouveau driver again.

After reboot I have started KDE plasma successfully but it has started to flicker.
I have had to add the Option “DRI” “3” into the /etc/X11/xorg.conf file.

Now the KDE plasma works OK with KDE Compositor set to OpenGL 3.1.