OM Lx 4.0 LXQt ISO available

Tags: #<Tag:0x00007f2e21304098> #<Tag:0x00007f2e2130fec0>

Hello,

There is a new OM Lx 4.0 LXQt ISO (x86_64):

https://abf.openmandriva.org/platforms/4.0/products/58/product_build_lists/2820

I have booted and installed this one in VirtualBox. Don’t know how well the LXQt desktop works. But wanted to let users know of availability if anyone is interested.

1 Like
  • OpenMandriva Lx version:

OMV Lx 4.0

  • Desktop environment (KDE, LXQT…):

LXQT

  • Description of the issue (screenshots if relevant):
    I installed from the ISO on real system I am unable to run web browser falkon or any other browser firefox,otter-browser, chromium, in terminal its gives error
Nouveau openGL driver detected. Qt WebEngine will disable usage of the GPU.
Please consider getting hardware not made by NVIDIA.

Alternatively, you can set the QT_WEBENGINE_DISABLE_NOUVEAU_WORKAROUND
environment variable before running this application, but this is 
not recommended since this usually causes applications to crash as
Nouveau openGL drivers dont support multithreaded rendering

DevTools listening on ws://127.0.0.1:52017/devtools/browser/de501ec8-64c3-418a-b332-5c5ec90e1555
QWebEngineUrlScheme::registerScheme: Too late to register scheme "falkon"
QWebEngineUrlScheme::registerScheme: Too late to register scheme "extension"
Please register the custom scheme 'falkon' via QWebEngineUrlScheme::registerScheme() before installing the custom scheme handler.
Please register the custom scheme 'extension' via QWebEngineUrlScheme::registerScheme() before installing the custom scheme handler.
Falkon: 1 extensions loaded
[8587:8603:1110/052040.990387:ERROR:nss_util.cc(674)] Error initializing NSS with a persistent database (sql:/home/sacviper/.pki/nssdb): libsoftokn3.so: cannot open shared object file: No such file or directory
[8587:8603:1110/052040.990611:ERROR:nss_util.cc(154)] Error initializing NSS without a persistent database: NSS error code: -5925
[8587:8603:1110/052040.990652:FATAL:nss_util.cc(156)] nss_error=-5925, os_error=0
Trace/breakpoint trap (core dumped)
1 Like

If anyone ran into this problem I solved it by installing

sudo dnf install lib64nss-devel geoip

2 Likes

That is a really good catch @SACViper and should be helpful to those with nvidia hardware.

A heads UP:

In 4.0/Rock there was some issue where some things would not work in Falkon and other browsers if these packages got removed:

nss-shlibsign
lib64freebl3

sometimes those packages somehow did not get installed or were removed with ‘dnf autoremove’ and it would royally mess up the browser performance. I’m fairly certain this has since been fixed. But if this still affects anyone the solution is simply to install the packages.

1 Like