OM 4 Beta WIPED my Grub

grub2
omlx-4
boot
Tags: #<Tag:0x00007fabdb8b7ca0> #<Tag:0x00007fabdb8b7908> #<Tag:0x00007fabdb8b74a8>

(Moss Bliss) #1

Hello,

  • OpenMandriva Lx version:
    OpenMandriva 4 Beta

  • Desktop environment (KDE, LXQT…):
    KDE

  • Description of the issue (screenshots if relevant):
    I just installed OM4. OM3 played so nicely with my other distros (4 partitions) that I didn’t think there would be an issue. But there is. OM4’s Grub fails to see my other three distros entirely. I have real work to do on some of them.

  • Relevant informations (hardware involved, software version, logs or output…):

Lenovo ThinkPad T430


#2

Try run in console as root (su or sudo):
update-grub2


(Moss Bliss) #3

Thank you. It looks like that should work, it found all my partitions. Now to reboot and see how things go…


(Ben Bullard) #4

Post-edit: Sometimes @ben79 forgets his manners. Thanks for reporting.

Please tell us exactly which ISO was used. We identify them by the ISO Build ID number. See the first line in grub2 menu:

That word Beta, it means there are things still being worked on. And just so happens grub2 is one of those things right now being worked on. So a developer might want to know if the changes they made on a certain ISO do or do not work.


(Moss Bliss) #5

I will do that soon as I reboot again. As expected, the fix above did work, and I am currently in my LM 19.1 partition.


(Moss Bliss) #6

I do not see any such information on my bootloader screen. I did go into the Advanced menu, and got something about 42010omv4000 but that’s the best I can do. I rebooted twice to make sure, but there is no such data. I can’t take a screenshot of the GRUB menu unless I use my phone, which I attempt to keep less-connected for security reasons…but it can be done…


(Ben Bullard) #7

You have to boot the ISO not the installed system to get the ISO ID number.

Post-edit: And good to know that your issue was so easily resolved. (We all love it when that happens. :grin: )


(Ben Bullard) #8

Changing to Development/Testing forum. (Because it’s against OM Lx 4.0 Beta.)