Nvidia "No Go" except in recovery mode

inxi -b
System: Host: dave-pc Kernel: 4.9.0-desktop-1omv x86_64 (64 bit) Desktop: KDE Plasma 5.8.4
Distro: OpenMandrivaLinux 3.0 Einsteinium
Machine: Mobo: ASRock model: H87 Performance Bios: American Megatrends v: P2.60 date: 01/14/2016
CPU: Quad core Intel Core i7-4770 (-HT-MCP-) speed/max: 3873/3900 MHz
Graphics: Card: NVIDIA GK104 [GeForce GTX 760]
Display Server: OpenMandriva X.org 119 driver: nvidia Resolution: 1920x1080@60.00hz
GLX Renderer: GeForce GTX 760/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 375.26
Network: Card: Intel Ethernet Connection I217-V driver: e1000e
Drives: HDD Total Size: 6441.3GB (14.5% used)
Info: Processes: 267 Uptime: 6 min Memory: 1410.4/7903.8MB Client: Shell (bash) inxi: 2.2.27

I am stumped on this one, have been going around circles. Installed, Uninstalled…?x!&
OK can get get to the desktop through recovery mode. but normal boot is not a go.
Sure someone has had previous trouble with this, but I can’t find anything of help in other posts.
New to openmandriva, but determined to get past this problem. Help! plz.

Hi,

can you please boot in normal mode, then if system finishes booting switch to VT2 (press ctrl+alt+F2)
login as root and type this:
omv-bug-report.sh

attach generated file here omv-bug-report.log.xz (prolly you need to boot in safe mode)

Without this file it will be very hard for me to help you.

PS.
If you are not using autlogin.
You can try to ling in into LXQt desktop from your login screen (SDDM), by choosing LXQt in your left bottom corner of the screen

Thanx for your reply’
Can’t boot past “starting kernel” with a blinking cursor.
I ran omv-bug-report.sh,

How do I attach .xz file?
I am not set to autologin!.
Does this mean anything from Xorg.0.log
“(WW) warning, (EE) error, (NI) not implemented, (??) unknown
11.725] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[ 11.725] (EE) NVIDIA: system’s kernel log for additional error messages and
[ 11.725] (EE) NVIDIA: consult the NVIDIA README for details.
[ 11.725] (EE) No devices detected.
[ 11.725] (EE)
Fatal server error:
[ 11.725] (EE) no screens found(EE)
[ 11.725] (EE)
Please consult the OpenMandriva support
at https://issues.openmandriva.org
for help.
[ 11.726] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 11.726] (EE)
[ 11.868] (EE) Server terminated with error (1). Closing log file”
Booting in text mode gets me to “switch root” but goes nowhere after that.

“driver: e1000e” What is this driver, not familiar with? FWIW: I don’t have nvidia hardware.

Also is correct user name set in ‘/etc/sddm.conf’?

[Autologin]
Relogin=false
Session=plasma
User=<username>

Hi Ben.

I don’t use “auto login”. And I also have a nVidia graphic card. In my system, after “User=” in [Autologin] says “live” (without quotes)

I cannot boot in graphic mode in any way. I tried to disable the nvidia driver (now using nouveau), and I also already tried “nokmsboot” and “nokmsmode” editing grub menu at boot time. Configuring with drakconf and using MCC, I disabled the “boot in graphic mode” option.

The system boots up (OpenMandriva 3.01, 64-bits), but screen remains black, with no text cursor nor mouse arrow. The only workaround I found by chance is to change to another terminal, using Ctrl+Alt+F2, login as root, kill (using kill -9) the Xorg process, and only then, coming back to Ctrl+Alt+F1, I get the login option.

After that, the graphic mode starts (I’m writing from 3.01 in this moment), but now and then screen goes totally black. To recover the graphic screen I must change to Ctrl+Alt+F2 and/or Ctrl+Alt+F3 and then back to Ctrl+Alt+F1 and wait for a few seconds.

It’s really annoying.

As my system includes an integrated Intel graphic card (supposedly disabled in BIOS), I don’t know if the origin of the problem can be there.

Now updating some things (but other updates just didn’t worked out !!). I hope that, with more time, I can give you more info.


# inxi -F
System:    Host: Sirius2 Kernel: 4.9.0-desktop-1omv x86_64 (64 bit) Desktop: KDE Plasma 5.8.4
           Distro: OpenMandrivaLinux 3.0 Einsteinium
Machine:   System: Gigabyte product: N/A
           Mobo: Gigabyte model: B75M-D3H v: x.x Bios: American Megatrends v: F14 date: 04/17/2013
CPU:       Quad core Intel Core i5-3340 (-MCP-) cache: 6144 KB 
           clock speeds: max: 3300 MHz 1: 2736 MHz 2: 3029 MHz 3: 2893 MHz 4: 3231 MHz
Graphics:  Card: NVIDIA GK107 [GeForce GTX 650]
           Display Server: X.org 1.19.0 driver: nouveau tty size: 152x38 Advanced Data: N/A for root
Audio:     Card-1 NVIDIA GK107 HDMI Audio Controller driver: snd_hda_intel Sound: ALSA v: k4.9.0-desktop-1omv
           Card-2 Intel 7 Series/C216 Family High Definition Audio Controller driver: snd_hda_intel
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: 74:d4:35:16:ce:06
Drives:    HDD Total Size: 1000.2GB (89.2% used) ID-1: /dev/sda model: WDC_WD10EZEX size: 1000.2GB
Partition: ID-1: / size: 9.8G used: 6.3G (68%) fs: ext3 dev: /dev/sda7
           ID-2: swap-1 size: 4.19GB used: 0.00GB (0%) fs: swap dev: /dev/sda4
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 47.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 234 Uptime: 1:19 Memory: 1641.3/3899.2MB Client: Shell (bash) inxi: 2.2.27 

I attach the bug report.

Greetings.

Sirius

omv-bug-report.log.xz (82,1 KB)

1 Like

:rage:
Try ctrl + alt + backspace (guess backspace twice)
It should lead you to sddm screen, providing it’s my same issue.

If it works, I’ll tell you more.

1 Like

Hi rugyada !

No luck here.

But now I have a new problem. Last session I uninstalled all the packages that included “nvidia” in its name (it were about 4 or 5 packages). I setup (again) to do not start in graphic mode. Graphic driver I set up to nouveau.

At the reboot, I got all the same symptoms. Ctrl+Alt+Backspace didn’t work out. So I changed to Ctrl+Alt+F2, log as root, but “ps ax” didn’t show any Xorg package !!!. So my last workaround don’t work anymore !!!

In root prompt, if I write “X” to start the graphic mode, it didn’t work, with the “classic” warning saying (EE) and (II) and warning that screen mode cannot start (something like “(EE) Screen(s) found, but none have a usable configuration”).

A note: I didn’t install “bumblebee” and I don¡'t know if it was installed during OMV Lx3 installation.

Second note: I’m writing this from OMV 2014.2, because now I cannot start OMV Lx3 graphic mode.

Sirius

1 Like

Sirius which .iso are you testing? The latest is a 3.02 test .iso build 760 from here. It’s main purpose is to test not using nouveau, intel, or nvidia drivers and I believe using Xorg modesetting driver instead. Many users have found this an improvement. It works here with Intel HD 4600 Graphics but I’m not sure it’s ‘better’. It should work even with 3D games I’m told.

In VT login as user, then
startx /usr/bin/startkde
or
startx /usr/bin/startlxqt

Anyway I’d strongly suggest you to install the latest build 760

Postedit:
Ah, I see now Ben replied at the same time :slight_smile:

2 Likes

I use the latest stable ISO (or at least I thought it was). Downloaded from SourceForge. It says version 3.01, not 3.02.

I’ll try what rugyada says.

1 Like

It’s rather stable for some people, but it’s carrying a calamares bug solved only the last few days.

I’ll try what rugyada says.

Just an attempt… :slight_smile:

1 Like

3.01 is latest ‘official’ and is as stable as anything OM Lx 3. 3.02 (Build 760) is similar except for how it handles graphics as said in earlier post. It is being tested at the moment and your input would be valuable and appreciated.

2 Likes

Sorry you’re having troubles. Could you try this .iso here. As described in other posts it’s doing something different with graphics.

Rugyada:
It didn’t work. Same (EE) and screen not usable. As user and as root.
I’ll download the 760 version now. Thanks.

I’m sorry.
Maybe your system has gone without remedy :grin:
Hope you will find 760 much better, like the feeling we have had.

Thank you for all your input.
ben79…Sorry you’re having troubles. Could you try this .iso here. As described in other posts it’s doing something different with graphics.

The following packages can’t be installed because they depend on packages
that are older than the installed ones:
glibc-devel-2.23-4
gcc-5.4.1_2016.06-2
dkms-2.2.0.3.1-3.20130827.13
gcc-cpp-5.4.1_2016.06-2
dkms-nvidia-current-375.26-1
x11-driver-video-nvidia-current-375.26-1
Continue installation anyway? (Y/n)
Well I downloaded the .iso and had no trouble installing…but as you can see I’ve been confronted with another hiccup.
Can someone guide as what to do next?

I have the feeling that one should add /testing repo.
I did it, but testing system in virtual machine so I can risk without worrying :slight_smile:

First I think rugyada is correct about enabling testing repos at least main-testing and non-free-testing. build 760 is a test .iso so probably has packages still in testing repos.

Second the whole purpose of the build 760 is to test not using nouveau or nvidia drivers (or intel) to see if some things in Plasma5 desktop don’t work better.

Where I can find the testing repos?

Also, I have downloaded and installed 3.02 build 760. See here.