I installed Notepadqq using the terminal: sudo dnf install notepadqq
Upon running it for the first time I am presented with a warning message:
You are using an old version of Qt (5.14.1)
Notepadqq will try to do its best, but some things will not work properly.
Install a newer Qt version (≥ 5.3) from the official repositories of your distribution.
If it’s not available, download Qt (≥ 5.3) from http://qt-project.org/ and install it to “/home/-----/Qt” or to “/opt/Qt”.
I am given the option to not show the warning message again. Is this a bug? I’m using OM Lx 4.1 Rock Zen KDE. Is it recommended to install a newer version of Qt as instructed? Why would I need to?
Duh. Rock has Qt 5.14. The error wants you to install Qt 5.3 which in not just older, it is many versions older that 5.14. You do not want or need to do that.
So the error is something just plain dumb that needs to be fixed in notepadqq code. But if notepadqq works then nothing for you to worry about.
Will see if we can get notepadqq updated to a more recent version.
Note: I hate admitting this but someone else (@bero) had to point out to me the flaw in that error message.
'nuther Note: This is a classic case of what we call an upstream bug.
But the package that exists in Rock/4.1 should be OK for users to use.
@ben79, thanks for the help. Notepadqq does work fine as far as I can tell. I was curious to see how it compares to Kate as a basic text and code editor. It’s … OK. I think I’ll get Atom from flathub while I’m at it.
Thanks for reporting the issue. We may get a new more up to date version of this for OM Lx 4.2.