Not working: Backlight screen brightness adjustement

I am using OM ROME GNOME spin; on a Lenovo Thinkpad L430.
I am unable to adjust screen brightness (set at maximum).
Ayone ever encountered that issue?

@yusssufff Hello,

Please see
Possible solutions for laptop/notebook brightness control issues
Display brightness does not change. · Issue #2812 · OpenMandrivaAssociation/distribution · GitHub
Feel free to reopen the bug report and add comment to the suggested workaround/s.

I added to that “Resources” article how to set screen brightness from terminal (Konsole). The solutions in that article are used over most Linux distros, this is by no means an OM only problem.

Possible solutions for laptop/notebook brightness control issues

Thanks for the help but those tricks didnt help unfortunately…

1 Like

@yusssufff Thank you. Even a “It did not work” is a feedback.
Can you please confirm that you tried all the workarounds? So to be sure we’ll have to look for further solutions (hopefully)

thank you for reply!
Yes i did try all the processes. Well the second one isn’t actually aimed at solving the brightness gui control, but more a command line workaround…

1 Like

It would be unusual if xrandr does not work. Edit: However is xrandr does not work there would have to be something from command line that does work.

  1. Set brightness from terminal (Konsole) using xrandr command.

To find the name of your screen display, run:

$ xrandr -q

On this notebook it is “LVDS-1” other possible valures could be VGA-1, HDMI-1, or DP-1 or something similar to those. There may be other possible values.

Next the brightness value must be between 0.0 to 1.0 where 0.0 refers the dimmest (full black) and 1.0 refers the brightest value. For example, to set screen brightness value as 0.6, run:

$ xrandr --output LVDS-1 --brightness 0.6

To go back to normal brightness, run:

$ xrandr --output LVDS-1 --brightness 1.0

  1. One can do one’s own internet search and find other ways to set laptop screen brightness from terminal (Konsole). One may possibly find other permanent solutions I have missed, if so please let me know.

Hi and thanks for the hints!
Well here is the output i get:

xrandr -q
Screen 0: minimum 16 x 16, current 1600 x 900, maximum 32767 x 32767
XWAYLAND0 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 310mm x 170mm
   1600x900      59.95*+
   1152x864      59.96  
   1024x768      59.92  
   800x600       59.86  
   640x480       59.38  
   320x240       59.52  
   1440x900      59.89  
   1280x800      59.81  
   720x480       59.71  
   640x400       59.95  
   320x200       58.96  
   1368x768      59.88  
   1280x720      59.86  
   1024x576      59.90  
   864x486       59.92  
   720x400       59.55  
   640x350       59.77

I guess its because of wayland?
Obviously xrandr --output XWAYLAND0 --brightness 0.6 doesnt work…

Try X11 instead.

Also please read this.

Okay i tested in x11, there yes this command works for adjusting brightness from command line.

There probably is some command that works in plasma-wayland I just do not know what that may be. So I have asked OM devs about this at OpenMandriva matrix channel. You and all users are welcome there as well.

This page shows graphics for ThinkPad L430 as “Intel® HD graphics 4000 (integrated)”.

An article relating to laptop screen brightness.

An article about Wayland protocol.

So where Fedora has Gnome/Wayland as default OpenMandriva has KDE Plasma/X11 as default. Big difference.

History: This goes all the way back to creation of Mandrake Linux by Gaël Duval. Original Mandrake was based on Red Hat Linux (version 5.1) and K Desktop Environment 1 in July 1998.

What I have found searching on my own so far is that OM may need to add wlr-randr. But it is up to OM devs to decide such things.

Interesting… well i never had a display problem with any linux distribution on this machine so far… So yes it seems OM specific…
Thanks a lot for the links and the research!

@AngryPenguin added the wlr-randr package to repositories. For ROME (rolling repositories) it is in main/testing repo. To install for x86_64 ROME system:

$ sudo dnf --refresh in wlr-randr --enablerepo rolling-testing-x86_64

For znver1 system replase x86_64 with znver1.

Let us know your results.

1 Like

So i followed the command and rebooted.
Still same issue: display stuck on max brightness unfortunately…

That command only installs the package wlr-randr. You use it in terminal (Konsole in KDE Plasma). Start with running wlr-randr --help. I’ll look at this on my old ASUS notebooks (in Plasma desktop) when I get some time. I don’t know much about this package except that I think it is a substitute for xrandr. Whether it works in OMLx is unknown until people test it.

Edit: See this. At this point we should hope for help from @AngryPenguin and/or @TPG.

I have not watched this video yet but I believe Hans de Goede is the person at Red Hat working on this. I will watch when I get some time. Found that here.

Here is the output i get:

 wlr-randr --help
compositor doesn't support wlr-output-management-unstable-v1

Bytheway i also tried to switch on “night mode” which usually makes the display a bit yellowish.
But zero response.
So night mode isnt working either…
Its about the whole control of the display i guess?

On my Thinkbook I had to set


in the kernel command line to have brightness control working. I hope this help.

1 Like