No SDDM in OM LX 4.0 alpha1

omlx-4
Tags: #<Tag:0x00007f0e466b8180>

#1

Now reporting from OM LX 4.0 live mode.
Yesterday, some regular saving energy black screen started to take long for returning upon mouse or keyboard use.
Today, boot goes on but does not go to the sddm login screen. Instead of the login screen I got a black screen.
CTRL+ALT+F2 works and I was able to copy journalctl and Xorg.0.log to a pendrive. They are attached.journalctl.log2.txt (3,2 MB)
Xorg.0.log.txt (43,2 KB)


(Ben Bullard) #2

Thanks for reporting @adelson.oliveira. We appreciate users reporting issues.

Is it this?

Cooker boots to black after updates 2019-01-16
https://issues.openmandriva.org/show_bug.cgi?id=2413

May not be >>> for me CTRL+ALT+F2 did not work neither did ‘systemctl restart sddm’ so yours may or may not be same issue. As you can see in bug report mine was fixed by ‘dnf --refresh update’. Hope yours is as easy to correct! :grin:

:monkey:


#3

Ben,
Thanks, updating solved the problem.

If you had a black screen like me, how did you manage to get updates without CTRL+ALT+F#?

In my case, I couldn’t update because network wasn’t up. In the F2, I used nmtui-connect to make the connection and then finally do the update of the system.

And, another question, why discover didn’t pointed to available updates yesterday and before?

Thanks again


(Ben Bullard) #4

What I thought you said was that you used CTRL+ALT+F# and got screen to work. That’s a common trick, first thing people try. Switch to a VT and then back to CTRL+ALT+F1 and sometimes you have a screen. Sometimes it works but sometimes not.

If you read the bug report I did say that I had virtual terminals (VT’s).

Did that change anything?

Discover is um, not popular for a reason, as I understand it OMA is going to remove Discover from default packages and replace it with dnfdragora. That is not an official statement. But I think that is what devs are going towards.


(Christopher Tanner) #5

I boot to maintenance mode, enter the root password, then “init 2”. Then I can login as root and run dnf --refresh upgrade (or anything else). The “init 2” command starts the network (amongst other things).


(Ben Bullard) #6

My guess is @adelson.oliveira lost internet because of a wifi connection. If one has ethernet connection then internet worked form Virtual Terminal. With wifi then intervention was necessary and I don’t know why that would be the case.


#7

Is maintenance mode = recovery mode? Here, due to the hybrid graphics, recovery mode does not goes. For regular mode, I’ve blacklisted nouveau and I can boot.


#8

Sorry for my poor english …


(Ben Bullard) #9

No worries. Your English beats my Portuguese like a drum.


(Ben Bullard) #10

Apologies for getting sidetracked.

So anyway now I think you did have same issue I did and if so I hope updating corrected?


(Tomasz Paweł Gajc) #11

This issue is fixed.

Please update you system.


#12

Yes, it is Ok now.


(Tomasz Paweł Gajc) closed #13