No screen brightness controls

hi everyone,
i installed on my notebook, rome platinum edition
Operating System: OpenMandriva ROME 22.12

system details

KDE Plasma Version: 5.26.4
KDE Frameworks Version: 5.100.0
Qt Version: 5.15.7
Kernel Version: 6.0.10-desktop-2omv22090 (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i3-3120M CPU @ 2.50GHz
Memory: 5,7 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 4000
Manufacturer: Wortmann_AG
Product Name: TERRA_MOBILE_1528P/1748P
System Version: Not Applicable

but have no screen brightness controls
I already tried the solutions from the forum
none of these worked.
Any help is very appreciated.

Beyond this I am not sure what anyone could suggest. If using xrandr from Konsole does not work start looking for other command line solutions. If you find a way to do this then you could write a script to do it. Perhaps an internet search of “Linux command line how to set laptop screen brightness?”

Possibly updating the BIOS firmware on the notebook might help if there is such an update.

many thanks @rugyada and many thanks @ben79
indeed in my case


then save the file and run
sudo update-grub2

solved the problem.

That is great. I do wish we had better answers for this laptop screen brightness control issue but we don’t. The search continues for a solution or some code that would resolve this favorably for all Linux users. IMO the real culprit is either the BIOS firmware or the hardware manufacturers.