New Cooker ISOs (2021-08-25)

As mentioned for sound to work one needs to install a sound server when you first boot into installed system. I have been doing this:

# dnf install pipewire-pulse pavucontrol-qt

pipwire-pulse alone will not provide a volume control. If you want to use pulseaudio instead you only need to install pulseaudio server and there will be volume control. pavucontrol-qt may provide more functionality but is optional in this scenario.

@rugyada has reported that the ISO’s don’t boot in VBox. I suspect some users will have this issue. I have been able to get them to work (EFI or Legacy boot) in OM’s virtualbox-6.1.16-4 on a Lx 4.2 host machine. So I do have the x86_64 and znver1 ISOs installed in VBox now.

In the Oracle VBox v. 6.1.26 on Cooker host I can only boot the ISOs Legacy boot, EFI boot does not work.

Also I checked booting on UEFI hardware computer and that works and Calamares installer is working so booting and installation should work on most hardware.

The ISOs in the first post were made with clang compiled kernel. (Package name kernel-release-desktop-clang.)

By request we now have ISOs made with gcc compiled kernel. (Package name kernel-release-desktop.)









1 Like

Links work.

This iso does boot and work in live mode in my virtualbox.

1 Like

The issue with sound has been fixed. Web Browsers are still a work in progress.

Closing this thread.

Updated 2020-06-20

Note: Both ISO’s worked on hardware, znver1 works in VBox. To install x86_64 in VBox I had to keep restarting sddm.service until desktop worked. x86_64 installed system in VBox requires downgrade of virtualbox-guest-additions to version 6.1.6. YMMV. See bug reports in next post.

The most recent Cooker ISO’s are:

Cooker ISO x86_64 3304

Cooker ISO znver1 3303

Cooker is OpenMandriva development platform. As such it is where developers do some of their work. This work can and does lead to things being broken sometimes. If you can’t handle this Cooker is not for you. If you don’t like problem solving and are not comfortable with the command line don’t use Cooker.

Cooker users: Always maintain another stable operating system on another partition or elsewhere for production work.

1 Like

Updated 2020-06-21

Known Bugs:

Cooker VBox VM’s start only sometimes

Intermittent plasma desktop crash VBox x86_64

Login sound not played (or not correctly) Plasma 5.18.90 (Cooker)

Change to mount point in KDE Partition Manager are not written to /etc/fstab (ALL OM Lx versions)

OM-Control-Center does not work with Wayland (Cooker)

After cp cooker to rolling distro-sync does not create initrd or boot entry for latest kernel (Rolling)

grub2-editor (kcm_grub2) “Failed to save GRUB settings.” DBus backend error. (ALL OM Lx versions)

Issues when creating issues in bugzilla

Samba works not

If you know of any other bugs please let me know in a PM. With your help we will try to keep the known bugs list mostly up to date.

If you encounter an issue with Cooker and need help:

Look for answer to your problem here or here first. The wiki is a work in progress and will get more complete over time. Also search forum and internet. Then if you don’t find anwer go to the following.

Post in Development Testing with a descriptive title. Forum help is users helping other users.

For more serious or technical issues post a bug report in OpenMandriva issue tracker. Any issue that needs help from developers needs to go here.

Thank you for sharing the links and taking time to always answer my questions
Yepp. i noticed the black screen too. The system booted up but it ended up in a black screen ;-(
So i ll have to wait or maybe ill try the rolling version

1 Like

Today the workaround is working again. Downgrade ‘lib64qt5network5’ to ‘lib64qt5network5-5.15.0-0.beta1.1’. And desktop mostly is working.

Developers obviously are working on this but the “real” problem is elusive at present. It is thought to be related to sqlite. But also apparently has something to do with qt5 or relationship between splite and qt5.

As of the latest ISO’s on 2020-03-10 (# 3198 and 3199) most of the plasmashell and desktop issues are resolved. The only issue I am aware of at present is that you still can not edit the menu panel. You can edit Application menu just not the menu panel at the bottom of your desktop.

Post-edit: Graphic rendering for OM-Welcome and OM-Control-Center is still borked. There is supposed to be a fix in upcoming QT WebEngine packages.

1 Like

Fixed \o/

1 Like

Updated 2020-03-12 10:15 UTC

Updated 2020-04-29

First three posts updated today 2020-04-29.

First 2 posts updated 2020-06-20.

Post-edit: Second post with bug list edited 2020-06-21 to remove:

Dolphin crash at launch (Cooker)

The bug report is now RESOLVED/FIXED.

Progress continues on development for OM Lx 4.1 Alpha release. These ISO’s will give anyone interested a very good snapshot of where development stands at this time.

For the short term problems persist for most everyone trying to use Cooker as a VBox host system. There are also problems with latest versions of virtualbox-guest-additions for guest machines. Developers are of both issues and are working on this and hope to resolve this soon.

There are 2 new ISO’s built without VirtualBox packages virtualbox-guest-additions and x11-driver-video-vbox. User would likely want to add to VBox guests the 6.1.6 versions of these package from the link here.

These are the most recent Cooker ISO’s as of 2020-07-11:

Cooker x86_64 ISO 3341

Cooker znver1 ISO 3346

Post-edit: I forgot to state that I did test both ISO’s in VirtualBox and on hardware. My current Cooker hardware systems are installed from these ISO’s on 2 computers. Tested to boot, install, and reboot in to installed operating system.

Updated 2020-11-29

After 3 rounds of mass building of Cooker main/release repository we made some new Cooker ISO’s. These ISO’s are thought to be an accurate preview of OM Lx 4.2 Beta release.

Cooker x86_64 ISO

Cooker zenver1 ISO

The following is my report of what I have found so far in testing these:

  1. Both ISO’s booted with EFI enabled, and installed in VirtualBox.

  2. This is a catch all bug report that is designed to have a list of all known issues that need to be fixed for OM Lx 4.2.

After a mass rebuild of an entire repository there is always some package fixing so there will be more issues. I suspect especially there may be issues with packages with various python dependencies.

If you find any problem it is best to file a bug report. Alternatively you could open a new thread in Development Testing forum. :thinking:

As of new ISO’s from # 3610 and after this issue has been corrected. (The ISO’s linked in 1st post above do not have this issue.)

There was a bug user might needs to know about to install from older ISO’s. ISO’s from # 3598 to 3609 were affected by this.

If you try to open Calamares you will see:

You will need to edit /etc/calamares/modules/users.conf. You want to change the 3rd line from:

- users


- name: users

So it looks like this:

And now you should see this when you open Calamares:

The problem with EFI boot in VirtualBox discussed in post #1 Problem #1 is now fixed.

If you find any problem it is best to file a bug report . Alternatively you could open a new thread in Development Testing forum. :thinking:

First post updated with new ISO’s 2020-11-26, also the post was edited to remove some issues that have since been corrected. Yeah, we keep fixing things when we can where we can. :wink: We are sure there will be more things that come up before final release of OM Lx 4.2. We will do our best to correct anything reported.

If you find any problem it is best to file a bug report . Alternatively you could open a new thread in Development Testing forum. :thinking:

First post update with new ISO’s today 2020-11-29.