Missing icons

(Ben Bullard) #1

Hello,

  • OpenMandriva Lx version:
    3

  • Desktop environment (KDE, LXQT…):
    All but pertains to LXQt mostly.

  • Description of the issue (screenshots if relevant):
    Missing icons.

Screenshot_20180331_153155

  • Relevant informations (hardware involved, software version, logs or output…):

The missing icons are for “Donate” and “Join”. The system is looking for them in ‘/usr/share/icons’ as ‘/usr/share/icons/omv-donate.png’ and ‘/usr/share/icons/omv-join-now.png’. They are not there. I can’t find them anywhere. Anyone know where they are either on the LXQt .iso or on any installed system whether LXQt only or default/Plasma5? Are the icon names incorrect? Path incorrect?

0 Likes

(Ben Bullard) #2

On an installed Plasma5 system the icons do exist, I can see them. The files for them show:

[Desktop Entry]
Encoding=UTF-8
Name=Donate
Name[pl]=Donacja
Comment=Donate to OpenMandriva Community
Comment[pl]=Wspomóż finansowo społeczność OpenMandriva
Type=Link
URL=https://www.openmandriva.org/Donate
Icon=omv-donate

and:

[Desktop Entry]
Encoding=UTF-8
Name=Join
Name[pl]=Dołącz
Comment=Join OpenMandriva Community
Comment[pl]=Dołącz do społeczności OpenMandriva
Type=Link
URL=https://www.openmandriva.org/Join-contribute
Icon=omv-join-now

but there are no such icons in ‘/usr/share/icons’. So where are they?

and more importantly why do they never show up on LXQt ISO’s?

Edit: KFind finds no files with those names or ‘omv-join-now.png’ and ‘omv-donate.png’.

1 Like

(Ben Bullard) #3

You gotta be kidding me. They are not .png icons (why not?) they are .svg icons. And they are in the directory ‘/usr/share/icons/hicolor/scalable/apps/’.

Now me feel stoopid. Why didn’t I look there 6 months ago… :sob:

OK, now that I have found where they live there should never be this error on an ISO again. Right? :rofl:

Edit: FWIW: The icons are in that directory on the LXQt ISO shown (build 1701). So the path is wrong somewhere.

1 Like

(rugyada) #4

Long time issue :slight_smile: Please see also here

Build 1915 Plasma:

Screenshot_20180331_231343

Screenshot_20180331_231623

2 Likes

(Ben Bullard) #5

Thanks, was looking for that before I made my post. Guess I did not find because I did not look in Italiano.

0 Likes

(rugyada) #6

:slight_smile:
But it’s not the first time that we reported about the missing icons in LXQt iso :wink:

Originally we had the .png copy of .svg icons for donate and join in /usr/share/icons/ IIRC. Now looks like they have been moved (or better, one moved and one missed).

1 Like

(Ben Bullard) #7

Yes, that’s part of our history of not being able to fix some things and keep them fixed. Not only has this been reported multiple times I believe it has been fixed before also.

Wouldn’t it be great if we had an LXQt ISO newer than January 5? Instead we get new i586 ISO’s every week.

0 Likes

(rugyada) #8

I could not say it better… :-/

Well, here are the png images if you ever want to make some tests

omv-donate omv-join-now
(Please note: the icons size is the same, they just look different here because of white background)

2 Likes

Upgrading from 3.0 to 4.0 (cooker)
(rugyada) #9

By the way 1901 build worked for me.

The funny is that here we can see a lot of “Build failed” and “Build is canceling” (I wonder how much it takes to cancel those files) whilst the useful working ISOs got really deleted seemingly without any reason.
Product list needs a bit of season cleaning once for all.

-
Postedit:
Damn… I should have replied you in private message, now all the world knows that 1901 is working.
Be quick to grab it if you wish, because -as a working ISO- it will be soon deleted :rofl:

1 Like

(rugyada) #10

Long story short, here build 1901 in live mode session, if you copy the 2 png icons in /usr/share/icons/ they will be correctly displayed.

Snap_049

1 Like

(Ben Bullard) closed #11
0 Likes