Just a doubt on Firefox

Firefox in the job shows Openmandriva site with my own native language. There I work with RHEL 6.
At home, with OMV LX 3.0 + all updates, Firefox opens Openmandriva site in english. The great majority of sites are exhibit in my language. Openmandriva is a rare exception. I already checked for Firefox configurations (language, etc) and could not find why this happen.

At home, Chromium does everything in my language, as Firefox at my job.

Check you installed the locales for firefox. If done, check the content of the variable intl.accept_langguges in about:config.

Thanks for the answer,

I have the locale. Firefox intl.accept_language is configured exactly as Chromium: first my language then en_US and en.

I forgot to say that in my job I use a mozilla downloaded binary for firefox. But anyway, firefox version is the same as OMV LX 3.0.

could you specify the url, please?

Not sure what you mean. At home, Chromium does show everything in my language (portuguese) with the same url as FF (and where can I see it …). Which url you want me to specify?

I asked because some sites are only available in English. For example: blog.openmandriva.org
The forum can be displayed in your native language:
– if you are logged out, set the FF preferences here: about:preferences#content
– if you are logged in, set the forum preference here: https://forum3.openmandriva.org/users/adelson.oliveira/preferences
Currently your setting is “use the default language”.
Please, test and let us know.

Yes. After changing my default language at Openmandriva profile it changed many things after I login.

This is just a doubt but any way I have to say that, even before changing my profile, Chromium at home and Firefox at work used to show things like login in, etc in my language …

Thanks a lot

For some reason, now, before login in, things changed to french ?!?!

And came back to english again …


we have set this parameter:

set locale from accept language header

It is said:

(EXPERIMENTAL, does not work with anonymous cache)

As we use cloudflare, this might explain the behaviour you found.


I don’t think I know what is this all about but, is there a way to have OMV site in my language in FF before I login as it happens with chromium?


Well, I’ll try to explain the problem we face.

  • Cloudflare is a web cache that has two main advantages: it saves a lot of bandwidth on our server side and gives a shorter response time to the user
  • Our forum is powered by discourse
  • The forum settings let us choose the default language: English in our case.
  • We have also the possibility to let discourse guess the user’s tongue given by his browser’s settings.

==> Either the default language is English or it is the one kept in the cache. It seems that we have no other choice.

Btw, could you check the “Accept-Language” setting here?


accept-language differ if I use FF or Chromium

FF => accept-language = en-US, en; q=0.5
Chromium => accept-language = pt_BR, pt; q=0.8, en-US;q=0.6, en;q=0.4

since only chromium shows up in my language, I guess there is something to be changed in FF …


I’ve typed in FF,


search for accepted language and changed from en_US, en to pt_BR, pt, en_US, en. Now it behaves like FF in my job and as chromium.

since FF in my job is a binary downloaded from mozilla.org, I wonder if OMV FF rpm could be set so as to verify the language of the OMV installation and apply proper changes to accept_languages …

Hum, could be tricky to realize. I don’t know.
The preferred language can also be set via preferences/content/languages

I think preferences/content/language is different from
intl.accept_languages in about config. I have already tried the former with
no help. The latter worked fine.