Issues with installed Rolling - Firefox - Audio - USB - Bluetooth

Xfce desktop, installed on HDD, no VirtualBox:

Today, I attempted to participate in an online meeting with Firefox, to see my very first ever, Firefox tab, crash. It was after logging into the meeting and on the Jitsi screen. I also installed Chromium, to find the Jitsi interface completely unusable, it was too slow.

I also had audio issues. First, there was no audio, then the audio began by coming out of the PC speakers, even though Firefox had permissions to access the mic on the USB headphones that were plugged in, yet the audio continued to come out of the PC speakers. Eventually, the audio started coming out of the USB headphones, yet the mic still didn’t work.

Also attempted to pair Bluetooth headphones, however blueman would not install:

 Problem: conflicting requests
  - nothing provides python2-dbus needed by blueman-1.23-4.x86_64
  - nothing provides python2-gobject3 needed by blueman-1.23-4.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

bluedevil is for KDE (Qt) and although that installed under the Xfce desktop, it didn’t work either, so it was removed.

Is it possible that some packages (aside from the blueman dependencies) are missing??

Thanks in advance.

1 Like

Maybe that is why this:

This package is obsolete and the upstream project has been abandoned. Use bluedevil.

I know nothing about trying to use bluetooth in VBox guest. It would seem to make more sense to see if bluedevil will work with KDE Plasma5 desktop first. Or maybe blueberry orgnome-bluetooth would work better in XFCE?

Edit: Dagnabit! I was an idiot. @epp is talking about installation on hardware not VBox. :face_with_hand_over_mouth:

bluedevil doesn’t work with non-Plasma desktops. Please see above.

I also installed Chromium, in which the Jitsi interface became extremely slow, still had no mic with the USB headphones.

EDIT: Launched Plasma VirtualBox, BT headphones detected and paired, but no audio. Launched Firefox to join the same Jitsi meeting, tab continued to crash.

If anything, the USB headphones should have worked as soon as they were plugged in.

Ask the XFCE folks what to use for this. Or ask on the VirtualBox forum. Is there anything in VirtualBox User Manual about using bluetooth? So far I have not found anything.

@epp looks like maybe @AngryPenguin might be able to resurrect blueman and build it for python3 and other up to date dependencies. Raised from the dead as it were.

Playing with Bluetooth in VBox, technically works. But the resulting audio sounds like it’s vibrating. That could be due to the host CPU not being as strong enough as a more modern CPU.

Some good news to report, though: After playing with the PulseAudio Volume Control pavucontrol, in which I may have found a bug in the Xfce PulseAudio plugin (applet), I was able to get the audio and mic working thorugh the Logitech USB headphones. I then went into the same Jitsi meeting room as the earlier meeting and even though I was now the only one in the room, the Jitsi interface was responsive and the Firefox tab for it, did not crash. With more users in the room (there were over 10, including me), that’s when Jitsi became non-responsive and the tab crashes.

I just installed blueberry, which also installed other dependencies:

 Package                     Arch   Version    Repository                  Size
 blueberry                   noarch 1.4.8-1    rolling-x86_64-unsupported 1.2 M
Installing dependencies:
 bluez                       x86_64 5.65-1     rolling-x86_64             1.3 M
 bluez-tools                 x86_64 0.1.38-0.662e.3
                                               rolling-x86_64-unsupported 162 k
 fpaste                      noarch  rolling-x86_64-unsupported  21 k
 gnome-bluetooth             x86_64 1:42.3-1   rolling-x86_64             188 k
 lib64adwaita1_0             x86_64 1.1.3-0.20220617.1
                                               rolling-x86_64             240 k
 lib64ell0                   x86_64 0.52-1     rolling-x86_64             203 k
                             x86_64 3.34.5-6   rolling-x86_64              11 k
 lib64gnome-bluetooth3.34_13 x86_64 3.34.5-6   rolling-x86_64              75 k
 lib64gnome-bluetooth3_13    x86_64 1:42.3-1   rolling-x86_64              81 k
 lib64gnomekbd8              x86_64 3.26.1-1   rolling-x86_64              17 k
 lib64gnomekbdui8            x86_64 3.26.1-1   rolling-x86_64              40 k
 lib64gsound0                x86_64 1.0.3-2    rolling-x86_64              13 k
 lib64icalvcal3              x86_64 3.0.14-2   rolling-x86_64              32 k
 lib64mate-panel-applet4_1   x86_64 1.26.2-3   rolling-x86_64-unsupported  28 k
 lib64matepanelapplet-gir4.0 x86_64 1.26.2-3   rolling-x86_64-unsupported 8.9 k
 lib64xapp-gir2.2            x86_64 2.2.14-2   rolling-x86_64-unsupported  14 k
 lib64xapp1                  x86_64 2.2.14-2   rolling-x86_64-unsupported  77 k
 libadwaita-common           x86_64 1.1.3-0.20220617.1
                                               rolling-x86_64              28 k
 obexd                       x86_64 0.48-14    rolling-x86_64              63 k
 python-setproctitle         x86_64 1.1.10-4   rolling-x86_64-unsupported  17 k
 xapp                        x86_64 2.2.14-2   rolling-x86_64-unsupported 5.2 M
Installing weak dependencies:
 wmctrl                      x86_64 1.07-8     rolling-x86_64-unsupported  34 k

Transaction Summary
Install  23 Packages

Total download size: 9.0 M
Installed size: 16 M

and I now have Bluetooth headphones working,Bluetooth was added to the Xfce Settings menu. I ran ps -e and it is using blueberry.

If @AngryPenguin wants to resurrect blueman, one benefit is that blueman offers the option to switch the headphone profiles. A2DP is the default (with stereo audio), the other profile is HSP/HFP and in one later version of blueman, I noticed HSP and HFP were separate. Past experience is that with the ofono package installed and the HSP/HFP profile selected in blueman, I was able to use the Bluetooth headphone’s built-in microphone for meetings, but the audio was monaural.

The only remaining issue is why the Jitsi Firefox tab is crashing. I just noticed on Matrix that it also crashed with Plasma. I tried it on the host OS which has an earlier Firefox version, I believe it is 102.1esr. Since Rolling’s Firefox is 104.0.1, could it be a bug in Firefox?

Bug report filed for the Firefox tab issue:

Firefox just froze on the OpenMandriva Forum main page. Clicked another tab (YouTube) to close it, to see if it freed up resources, to no avail. You can see the placeholder in the upper left where it was.

Filed bug report: Firefox 104.0.1 froze on OpenMandriva Forum home page · Issue #2843 · OpenMandrivaAssociation/distribution · GitHub

Last week, I still had issues with Firefox and an online meeting with Jitsi, installed on Rolling to hardware (my other desktop).

I ended up installing Chromium and was able to then attend the meeting, but it was on the slow side. If one of the participants was sharing their screen, Chromium would slow right down. Once the sharing stopped, Chromium became a little faster. That could be due to the slower CPU on that hardware.