Is there a problem with packages with + in their name? (4.1 to 4.2 upgrade)

have 4.1 Plasma

when I tried to upgrade to 4.2, it could not find gcc-g++ 10.2 in directory starting with
So I tried dnf upgrade --exclude=gcc
but then it cannot find gtk+2.0 rpm

You do not upgrade to 4.2 with dnf upgrade it requires dnf distro-sync plus the specific conversion from 4.1 to 4.2 has other issues that need to be accounted for.

First you have to be sure, like really, seriously, sure you have Rock repos and only Rock repos. Any repos that does not say Rock should be disabled or removed. Never ever mix Rock repos with Cooker or Rolling repos.

There are instructions post for this here.

We generally always publish instructions for upgrading to the next version of Rock somewhere in this forum.

3 posts were split to a new topic: Is there a problem with packages with + in package name?

I found out what was going on. The problem is any rpm with a + in the filename. So when I did dnf distro sync, it fetched the rpms into cache, but any β€œ+” is escaped to β€œ%2b”. Then when dnf later looks in cache for filename with β€œ+”, it can’t find it. Weird problem - I have never encountered this before, having installed at least a dozen different distros.

Glad you got this sorted. I do not know the technical reasons for what you explain but this may be why we always do sudo dnf clean all before sudo dnf distro-sync.

clean all removes everything from cache and also does what the refresh command does and downloads the very latest metadata in the repos to ensure that user gets the most recent packages.

The gcc packages with + in their name would be gcc-c++ or gcc-objc++. I do not think most users would have these installed. As I recall in a default install most users would only get a gcc library package like lib64gcc1-10.2 in Lx 4.2. However a lot of users and especially developers would have more of the gcc packages.

Since OM switched to dnf package manager there have been numerous gcc upgrades. There has never, other than this report, been any issue reported with packages with a + in the package name. I do not know enough to state that there is or is not a problem.

Also I do not know what β€œ%2b” is? Unless that is supposed to represent the name of a folder in /var/cache/dnf?

I will try to find out more as time allows.

Edit: as @jeepster reports in original post there are gtk packages with a + in the name and up to now there have been no issues reported with those either.

Moderator: I spit this topic but then changed my mind and decide to change the thread title instead. Did this because I thought some of the content would not be understood with out the entire thread. Apologies for the confusion.

1 Like

The ASCII plus sign is 2b in hexadecimal. You may see this for example with web servers changing non-alphanumeric characters to the hex equivalent with a % sign. I don’t know why this happened to me; I expect it would have been reported before if others hit the same problem.
So anyway I renamed all the %2b to + so then dnf found the files, but it came up with several dependency issues, so I did not proceed. Instead I upgraded from DVD with manual partitioning to keep the old /home