Installation fails because of bootloader job (Lx 4.3 & Rome)


  • OpenMandriva Lx version:

I tried Lx 4.3 and the last Rome snapshot (from July 17th I believe)

  • Desktop environment (KDE, LXQT…):


  • Description of the issue (screenshots if relevant):

I have worked through Calamares and assigned a partition (FAT32) for EFI with the appropiate mountpoint and flag as well as two other partitions on a different harddrive for root and home. Calamares seems to nearly finish its installation but fails and reports an error about not being able to create a bootloader.

  • Relevant informations (hardware involved, software version, logs or output…):

This should be the logfile of my installation

calamares-install.log.txt (89,8 KB)

And here is my inxi -F output

System:    Host: omv-1262 Kernel: 5.17.1-desktop-2omv4050 x86_64 bits: 64 Desktop: KDE Plasma 5.23.5 
           Distro: OpenMandrivaLinux 4.3 Rome 
Machine:   Type: Desktop System: Gigabyte product: X570 AORUS ULTRA v: -CF serial: <superuser required> 
           Mobo: Gigabyte model: X570 AORUS ULTRA v: x.x serial: <superuser required> 
           UEFI: American Megatrends LLC. v: F34 date: 07/08/2021 
CPU:       Info: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP cache: L2: 4 MiB 
           Speed: 1995 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 1995 2: 1964 3: 2131 4: 2723 
           5: 2195 6: 2194 7: 2196 8: 2058 9: 2197 10: 2193 11: 2052 12: 2124 13: 2195 14: 2194 15: 2194 
           16: 2196 
Graphics:  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT / 6800M] driver: amdgpu v: kernel 
           Display: x11 server: OpenMandriva driver: loaded: amdgpu,ati 
           unloaded: fbdev,modesetting,radeon,vesa resolution: 2560x1440~144Hz 
           renderer: AMD Radeon RX 6700 XT (NAVY_FLOUNDER DRM 3.44.0 5.17.1-desktop-2omv4050 LLVM 13.0.0) 
           v: 4.6 Mesa 21.3.7 
Audio:     Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT] driver: snd_hda_intel 
           Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel 
           Sound Server-1: ALSA v: k5.17.1-desktop-2omv4050 running: yes 
           Sound Server-2: PipeWire v: 0.3.51 running: yes 
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi 
           IF: wlp6s0 state: down mac: 1e:87:a1:6f:00:b2 
           Device-2: Intel I211 Gigabit Network driver: igb 
           IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: b4:2e:99:a2:05:bc 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb 
           Report: hciconfig ID: hci0 state: up address: 50:E0:85:BD:B8:29 bt-v: 3.0 
Drives:    Local Storage: total: 3.01 TiB used: 5.3 MiB (0.0%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB size: 931.51 GiB 
           ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO Plus 500GB size: 465.76 GiB 
           ID-3: /dev/nvme2n1 vendor: Samsung model: SSD 970 EVO Plus 500GB size: 465.76 GiB 
           ID-4: /dev/sda vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB 
           ID-5: /dev/sdb vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB 
           ID-6: /dev/sdc type: USB vendor: SanDisk model: Extreme size: 59.63 GiB 
Swap:      ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 16.8 C mobo: N/A gpu: amdgpu temp: 36.0 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
Info:      Processes: 320 Uptime: 19m Memory: 31.36 GiB used: 8.88 GiB (28.3%) Shell: Bash inxi: 3.3.06

Please tell me if I can provide more useful information and thank you in advance for any help :slight_smile:

The installation of the 5.0 technical preview however works without any problems. :woman_shrugging:

I have used the same settings and assignments and all iso - files are checked.

For comparsion this is the installation log for the technical preview:

calamares-install.log.txt (86,4 KB)

Should there be no other solution I think I would just stick with it and downgrade it to rolling as soon as it is possible. :slight_smile:


I take also the OpenMandrivaLx.5.0-TP,
which is in reality with the cooker repo
as I understood,
to be downgraded to rolling afterwards

1 Like

That is a great idea. The reason for boot loader not installing with OMLx 4.3 iso are looks like you are using btrfs.

That is fixed now for the OMLx Tech Preview.

And yes if someone installs the OMLx Tech Preview and changes the repos to rolling at the time we move all the new stuff in cooker to rolling repos you will then have a Rolling system.

1 Like

Yes, I used btrfs. Thank you for the clarification :slight_smile:

I will wait then and keep an eye out for the announcement.