Inactive keyboard after a suspend mode

Tags: #<Tag:0x00007fc0be486ee0>

Hello,
I have just installed Lx4 on a Sony VAIO. Everything (almost) works fine so far, great stability - well done as usual, congratulations :slightly_smiling_face::+1:! - just a little problem that would make my life easier if solved:
When I start the laptop from a suspend mode, the keyboard do not respond. No other way to enter the password but the virtual keyboard. Once I was able to recover an active keyboard by playing (with the mouse) around the inputs settings but I have not been able to reproduce the fix since then.
Anyone could help? Shall I open a bug?
Cheers
Olivier

1 Like

Howdy @olivier.

Yes. Suspend is notoriously inconsistent and buggy in Linux in general. I only say “in Linux” because I don’t know about apple or m$ stuff. I personally don’t use suspend at all.

Hello Ben,

By habit I like getting back quickly my session as I have left it. Or (candid question) is there something equivalent I am not aware of?

I have searched a little more and have found this which solves the issue. In summary it is about updating the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub:
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash atkbd.reset=1 i8042.nomux=1 i8042.reset=1 i8042.nopnp=1 i8042.dumbkbd=1 resume=UUID=…”
then running update-grub2 as root and rebooting.

Shall I still raise a bug to get this added by default or would this solved topic in the forum be enough for future reference?

1 Like

If you use KDE Plasma desktop you can use Power Management to automatically switch off screen after a few minutes. Not exactly the same thing as suspend but works and is safe.

FWIW my comment about suspend applies to all Linux not just OM. The following is speculation by me only:
It is possible that something like this does work in another distro and not in OM for reasons like how kernel flags are set and some of the um, more aggressive performance enhancements that OM employs. Or other differences in how basic system stuff is set.

My best guess is to leave this as a workaround. Also speculation by me: It is unlikely that devs will want to add a long string like that to boot parameters for something that is likely very specific to limited hardware.

Post-edit: As always it is also possible I’m wrong. Especially in any of the parts purposely labeled speculation.