How to install warsaw rpm package - gas antifraud solution

Why is it ‘/usr/lib/systemd/system/warsaw.service’? In Lx 3 it should be in ‘/lib/systemd/system/warsaw.service’.

What version of OpenMandriva are you using?

OpenMandriva Lx 3.03

I also believe it should, maybe some bug related to installing many different dependencies packages.
When I try to access any internet banking (have account on three and tested in all of them) the websites says I don’t have warsaw, even warsaw web page has a diagnostic that says I don’t have it installed, so I filed a bug report asking for that package.

I think that is relevant because common users won’t have virtual machines with another os just to access their internet banking, if it is not possible, that is what I am going to do, not leaving openmandriva.

Could you post a link here to the bug report?

I believe it should be active (running)

bug report for warsaw RPM package


Thanks, I just confirmed the bug report.


It has been decided that OpenMandriva can not package this. The Fedora and other Linux packages for this are 3rd party not from the various Linux distros. It needs to be that 3rd party to package this for OpenMandriva as well.

I’ve just send the company an e-mail, it is worth the try.
If they indeed get in touch, they will probably do that in portuguese, but I can help with the translation if it become necessary.

I do not have a working OpenMandriva installation at this time …: / but I think the problem is here:

I found Arch Linux package where change from sysVinit to systemd. Maybe this creates a problem. Look code from Arch PKDBUILD:

  # Use systemd service instead of SysVinit script
  install -Dm644 "$srcdir/warsaw.service" \
  rm -rf "$pkgdir/etc/init.d"
    # Symlink to /usr/local, as the binaries still expect them to be valid
  install -dm755 "$pkgdir/usr/local/"{etc,bin,lib}
  ln -s /etc/warsaw/     "$pkgdir/usr/local/etc/warsaw"
  ln -s /usr/bin/warsaw/ "$pkgdir/usr/local/bin/warsaw"
  ln -s /usr/lib/warsaw/ "$pkgdir/usr/local/lib/warsaw"

So maybe u can try:

sudo systemctl enable warsaw
sudo systemctl start warsaw

Here is PKGBUILD from Arch.

I found here also .run installers (maybe works better?) here:
x86 and x86_64

Also this is Package for Arch in AUR , where u can find also many comments on how to run this program and fix issues. Check it. Unfortunately, all in Brazilian and I do not understand much.

I tried the .run installer for x86_64, the one you linked give me error of folders that does not exist, so I tried the installer provided by banco do brasil (bank of brazil) following the instructions in this page of their website.

The package installs but it complains of a missing library: and asks me if I want to go on with the install procedure, wich I answered yes.

I even installed these packages befre because they are pre-requisited by other distros (debian/ubuntu/fedora/opensuse) so I decided to give it a try.

- dbus
- libdbus-1_3
- libnss3
- libcurl4
- zenity
- python-pyopenssl

after rebooting, because the installer asked me to, the service is still not recognized by the web pages from the banks, not even in the company diagnostic page, it says it is not installed.

Today in the afternoon I successfully instaled and accessed my bank accounts on Debian, with no major problems, just had to install the pre requisited packages.

here are the outputs for systemctl comands:

    matheus@matheus-notebook:~$ LC_ALL=C sudo systemctl enable warsaw.service       
    warsaw.service is not a native service, redirecting to systemd-sysv-install.
    Executing: /lib/systemd/systemd-sysv-install enable warsaw
    Failed to execute /lib/systemd/systemd-sysv-install: No such file or directory


matheus@matheus-notebook:~$ LC_ALL=C sudo systemctl status warsaw.service 
* warsaw.service - LSB: Handles Warsaw - core
   Loaded: loaded (/etc/rc.d/init.d/warsaw; generated)
   Active: active (exited) since Sat 2018-07-21 20:55:05 -03; 4min 9s ago
     Docs: man:systemd-sysv-generator(8)
    Tasks: 0 (limit: 4915)
   Memory: 0B
   CGroup: /system.slice/warsaw.service

Jul 21 20:55:02 matheus-notebook systemd[1]: Starting LSB: Handles Warsaw - core...
Jul 21 20:55:02 matheus-notebook warsaw[4104]: Starting core                                                                                         
Jul 21 20:55:02 matheus-notebook warsaw[4104]: Verifying...                                                                                          
Jul 21 20:55:03 matheus-notebook warsaw[4104]: Ok!                                                                                                   
Jul 21 20:55:05 matheus-notebook systemd[1]: Started LSB: Handles Warsaw - core.

The company has just answered me.

Mr. Matheus, good afternoon!

I inform that our security solution is not homologated for use in the Distribution in question. At the moment there is a possibility of distribution from Warsaw to OpenMandriva, but there is no forecast.

Warsaw is approved in the following distributions:

Debian 8.6 or higher
Mint 18 or higher
Canaima 4,1 or higher
Ubuntu 16+

Have a great day!


Maria Fernanda
Information Security Analyst | LoB Software

Diebold Nixdorf

Well, time to wait and see. Even people using windows have problems with this warsaw s#!%

1 Like

Ah, yes, corporate speak in any language… At least they know how to politely tell people _ _.

1 Like

Don’t know

Canaima Linux

But I guess its packages are Debian like the others.

OMV is rpm (5). Wouldn’t alien help anyway?

Canaima is maintained in Venezuela by the government (warsaw is also used in Bank of Venezuela). It is used in governamental organizations, schools etc.
I have a desktop running Debian and OpenMandriva in my notebook, so for now I’ll just use the desktop anytime I need to access my account.
Also, why would I try alien if there are RPM packages for OpenSuse and Fedora? Wich I’ve been able to install after resolving dependencies, but the service didn’t work anyway.

Yes, I forgot you mentioned this rpm packages…