Gnucash ver. 2.7.x


#1

Con l’aggiornamento fatto oggi è stato aggiornato anche Gnucash 2.7.8

Da questo momento non è più partito e lanciandolo da una console da il messaggio

Questa una versione in sviluppo. Potrebbe anche non funzionare.
Segnalare i problemi a gnucash-devel@gnucash.org
possibile anche cercare e compilare rapporti d’errore all’indirizzo http://bugzilla.gnome.org
Per ottenere l’ultima versione stabile, fare riferimento al sito http://www.gnucash.org
Found Finance::Quote version 1.47
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injectorboost::bad_lexical_cast >'
what(): bad lexical cast: source type value could not be interpreted as target
Annullato (core dump creato)

Per fortuna ho trovato in rete il file rpm di una versione 2.6.13 (mi sembra) che funziona correttamente.

Chi verifica?


(Ben Bullard) #2

Grazie per la segnalazione.
Thanks for reporting.

Utenti. È una distribuzione comunitaria.
Users. It’s a Community distro.

Il team QA ha chiesto molte volte a più volontari di controllare i pacchi ma la risposta da parte della comunità non ha dato alcuna risposta. Quindi il team QA fa il meglio che possiamo, ma altrimenti è lasciato agli utenti la segnalazione di problemi.
QA-Team has asked many times for more volunteers to check packages but response from Community has been no response. So QA-Team does the best we can but otherwise it is left to users to report issues.


(Ben Bullard) #3

Come membro del QA-Team non mi piace la situazione attuale riguardo il controllo dei pacchetti. È molto frustrante Sospetto che i miei colleghi sarebbero d’accordo. Vorrei poter ottenere più aiuto.

As a member of the QA-Team I don’t like the current situation regarding checking packages. It is very frustrating. I suspect my colleagues would agree. Wish we could get more help.


#4

Ciao Ben
capisco che la situazione non ti piaccia ma vedere mettere sui repo ufficiali un pacchetto che dice

Questa è una versione in sviluppo

non suona proprio bene.

Chiedo scusa per la mia frase

Chi Verifica

volevo dire se devo aprire un bug o bastava questo post

Hi Ben
I undestand the situation but if someone put on the official repo a package that display

This is an version under cunstruction

it doen’t sound good

Sorry for my phase

Chi Verifica

I wanted to ask if is sufficent this post o must open a bug to solve the problem


(Ben Bullard) #5

Riportare un errore. Ci vorrà uno sviluppatore per cambiare questo e le segnalazioni di bug sono il modo migliore per attirare l’attenzione degli sviluppatori.


(Ben Bullard) #6
$ gnucash


This is a development version. It may or may not work.
Report bugs and other problems to gnucash-devel@gnucash.org
You can also lookup and file bug reports at http://bugzilla.gnome.org
To find the last stable version, please refer to http://www.gnucash.org

Report bugs and other problems to gnucash-devel@gnucash.org

Questo è un bug a monte. Probabilmente un messaggio non voluto o obsoleto. Non solo la versione 2.7 NON è una versione di sviluppo, l’ultima versione stabile è la 3.0.

To find the last stable version, please refer to http://www.gnucash.org

Nota: se creo una voce di menu in KDE Editor di menu e apro da Avvio applicazioni non c’è un messaggio di errore simile.

FWIW: il pacchetto predefinito in OM Lx 3 per questo tipo di utilizzo è Skrooge.


(Ben Bullard) #7

Ma non so se Skrooge sia davvero un sostituto diretto di GNUCash. Vedi anche Qui.

Per quanto posso dire, GNUCash sta funzionando e Skrooge funzionerà se l’utente installa i 2 pacchetti menzionati Qui.


(Cris) #8

2.7.8 was the release candidate for 3.0 and as far as i know was then released as 3.0 without any changes.

it worked ok for me when i built it, still works ok for me. i left it up for a week before publishing for anyone to comment, no one did.


#9

Sorry Crisb but I’m not a cooker.
If I user the command

uprmi --auto-update

it downloads the versione 2.7.8 but it is a test-version ad I’ve the problem previous reported


(Cris) #10

no one is saying you’re using cooker, it was a release candidate (not an alpha, not a beta) which was released as 3.0 during the time that package was in testing. in fact there is a bug where they left the dev message warning in, even in 3.0 which is the stable release and redhat had to patch so that warning is not there, which i have also applied to our package now.


#11

sorry but the version 3 doesn’t work.

While it’s opening the file saved dump with this error

[root@localhost albertolx3]# gnucash
Found Finance::Quote version 1.47
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injectorboost::bad_lexical_cast >'
what(): bad lexical cast: source type value could not be interpreted as target
Annullato (core dump creato)


(Ben Bullard) #12

Non uso gnucash, quindi qui posso solo confermare che si apre e si chiude senza nient’altro che gli errori GTK. Gli errori GTK fanno parte di ciò che rende GTK :poop:

I don’t use gnucash so here I can only confirm that it opens and closes without anything other than the GTK errors. GTK errors are part of what makes GTK :poop:


(Bruno) #13

Uso gnucash v.3.0 su openmandriva Lx3.0 aggiornato e funziona normalmente.
Vedo che lo lanci da root shell (?)
Anche da utente normale ti dà lo stesso errore?


(Ben Bullard) #14

Buona pesca. @albpanig probabilmente staresti meglio aprendo gnucash come utente.

Good catch. @albpanig you’d probably be better off opening gnucash as user.


#15

aperto bug.
hanno rilasciato la versione 3.1 che ha sistemato il tutto.

chiudo


(Ben Bullard) #16