Flashing Display

I’ve just upgraded, taska-plasma and last kernel 4.17, with all the signalled packages.
i can’t use anymore the desktop since, after booting, display stays black, flashing every two minutes, showing the block-desktop wallpaper for a second. I both tried the noveau and the nvidia drivers, but the unstability still occurs.
Even when using the old kernels the problem appears. Guess, problems with the new X-org package ?
I can’t provide files, since I can access to the system only using the backupped system.
Don’t know what to do, since if I update the system I can’t access to it anymore.

First do this.

If the list is very long please put it in a file and attach it here.

I have the same experience.
I use 4.15.18 kernel. It works.

uname -a
Linux localhost.localdomain 4.15.18-desktop-1omv #1 SMP Tue May 1 11:02:23 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Please provide output from omv-bug-report tool.

1 Like

Bug Report Tool instructions here. Can we get both of you to post this? And if you both believe it is package updates causing this issue could you post the list of updates as described here.

And finally please attach the omv-bug-report.log as a file and the updated packages list here also as a file. See the upload button with arrow pointing up in the bar at the top of this window where we write our posts. You can attach more than one file in one post.

Hoping this was helpful. It is after my bed time so I might not get my allowance this week. :worried: :monkey:

1 Like

Here’s what to do:


You may boot from a live image, access to the file /var/log/Xorg.0.log (in your installed system) and post it here.

I think I know what may be causing this, lets see; to those who have the problem do you have virtualbox and the nVidia dkms drivers installed on your systems?

Yes, I do. Still, I use the noveou driver.

Do you think I should unistall the dkms

? And how to install Virtual box after ?

As well, the problem still remain if I don’t install the new dkms.

That’s unfortunate; there’s a libdrm update in the testing repos you could try installing that.
What you can do to minmise the problems when something like this happens is to use urpm.recover to set a checkpoint. This causes urpmi to archive any packages that are uninstalled so that you can roll your system back to an earlier time. Check out the man page “man urpmi.recover” in a terminal.
Be careful though that you have enough space on your root filesystem to store the rpms. You can change the storage location if you have spare space at anothe location. Again see the manpage.
Do you have single or dual screens?

Single, at moment.

Can you come onto skype or irc?

No, I’m working now.

Maybe later then.

Ok. Thank you for your kindness.

Finally I succeded after many tests, to upgrade BUT:

  1. I had to uninstall and remove all the dkms modules
  2. I had to uninstall dkms itself
    3 Flashing diplay by iitsel seemed due to the grphic drive: neither nvidia nor xorg noveau worke. I had to select nomodesettings.

After that I reinstalled only virtualbox (no dkms-vboxadditions) and everthing seems go right.

Question: Need I to install dkms for any reason ?

Anothee question, appearently not connected: kwave doesn’t save modified files (the error I’ll post in the rfollowing). Does it anything to do with a bad installation of KDE ?

Thank you for your attention.
Pleas give further suggestions or, if you think so, I will send you some reports or logs

Please open a new thread. So we can close this as solved (if it’s solved). Thanks.

Answer a question with a question. Do you use anything besides nvidia that requires kernel module to be installed by dkms. For nvidia you will need dkms. For VirtualBox now we don’t need it. You also will need to use latest kernel and keep kernel up to date. You can and should get rid of old kernel packages. 2 or at most 3 different kernel versions should be more than enough.

Let’s do close this thread. Any more discussion of dkms can go here. Any discussion of kwave needs it’s own thread.