Error in libcrypto


  • OpenMandriva Lx version: Lx4.2 plasma x86 64

  • Desktop environment (KDE, LXQT…): KDE

  • Description of the issue (screenshots if relevant):

When I launch an operation involving reading the keys under ./ssh I get the following error
Error in libcrypto
and I cannot perform what I need.
By the way my simple operation was just linking to KDE site:
svn checkout svn+ssh://

I need to use the keys I have under .ssh directory. This is because I need to testwhat I have in other pc to the pc where I installed OpenMandriva.
I make this operation on other linux distros woth KDE without any problem (for instance SolidXK, but not only).
The permissions are all the same I used on other systems, so I think it is not permission dependable.
Maybe something linked to a different handling of ssh, but I do not know.
Thank you

  • Relevant informations (hardware involved, software version, logs or output…):

Yes we are aware of that issue. It is reported to OpenSSL upstream.

For now you may want to convert you current ssh key:

cp id_rsa id_rsa_pem
ssh-keygen -p -m PEM -N '' -f id_rsa_pem

Hi , I tried, but I got the same error

Failed to load key id_rsa_pem: error in libcrypto

If you are using Windows / WSL do dos2unix id_rsa in right directory, where this file is located

Welcome to OpenMandriva forum.

OpenMandriva wiki.

Forum Resources Index.