Drakconf does not work / hostname changes

I’ve found an analogous topic here in this forum:


However, my french is too poor. Also a mageia bug report on the same problem,


Thus, this seems not to be rare in mandriva-like systems!

Both references have neither an ultimate solution to the problem nor a diagnostic of its basic cause:

Something (some application) is changing hostname!

Since, for example, drakconf does not work if hostname is not “localhost”, I have to alter hostname several times a day

What is changing hostname, why, and how to avoid it/correct the problem?

Any help?

I still have a computer with OMV 2014.2. There, hostname also changes but drakconf does not stop working! So, is it a problem to have hostname changes or the problem is in those applications that do not accept these changes?

Hi @adelson.oliveira,
this happens after you connected to wifi?

If yes

What happens when drakconf doesn’t work if you logout/login?

Hello Adelson,
here’s the way to solve the problem (at least my problem was solved) with the CCM thanks to Jcl.Vanier
1°)choose a hostname2°)type hostnamectl set-hostname new_name (instead of new_name, type the hostname you chose)3°) restart your computer
Now everything should work. I hope it helped you and solved your problem.Cheers !

Hi Luca,

I boot the computer and logged in,
$ hostname

Drakconf working fine.

then I disconnected and reconnected the wifi, yes, hostname changed,

$ hostname

Drakconf stopped working.

Then I logged off and in,

$ hostname

and drakconf is working fine again!

Hence, drakconf works whatever hostname is, it stops when hostname is changed in a particular session (??). It must be said that this seems to be a drakconf problem since many other applications do not fail in the same situation and, in particular, the authentication window for drakconf is open without any problem! How could it be related to Xorg?

Hy highwaystar81,

I’ve tried

$ hostnamectl set-hostname new_name

but did not reboot the machine.

As far as I could see, this has the same effect as

$ hostname new_name

doesn’t it?

It seems strange that old OMV 2014 did not show this problem! It makes me to think that something else could be done to avoid new users to face this problem …
I will try your suggestion and post here the result. This test may be useful for understanding the problem.

change hostname during a session is a problem for some apps.


  • # hostnamectl set-hostname new_name (new-name different from localhost)
  • or you can set manually your ip adress and avoid dhcp in network-manager

Hi Highwaystar81 and Luca,

I changed the hostname with hostnamectl to pc-local

$ hostnamectl set-hostname pc-local

Then, not only drakconf stopped working but many other graphical applications until I reboot the machine.

After reboot, hostname is indeed pc-local and everything seems to work fine as it happened to Highwaystar81 following suggestion from JCLXavier.

A few observations:

At drakconf=>network=>others (machine names …) one can change the file /etc/hosts which was kept like,

$ cat /etc/hosts localhost localhost.localdomain

with no effect so far,

the command hostnamectl altered the file /etc/hostname only.

So, Luca, the file /etc/hosts has the ip address you mention ( Why should I not change the hostname to localhost simply? And I still wonder what made OMX LX 3.0 users have this problem after all since OMV 2014 users had not.

Thanks a lot for the help!


it seems that DHCP, if hostname=localhost, replace it.

Sorry for popping :stuck_out_tongue: Can we consider this topic solved, or still pending?

I have no more problems since I’ve followed JCLXavier suggestion and Luca’s tips. However, for a new user, it seems that the problem is still pending since everything can happen again. The default hostname is localhost and networkmanager will change it if it is so.

So, what can I say, my personal problem is solved but … May I let to the forum administration the decision on marking the topic solved or pending?

I went into troubles that made me reinstall the system …

Why things like this are still a problem with the version 3.02?

Although I had defined a new hostname during installation, the hostname is localhost!

Now, I’m going to change it with,

hostnamectl set-hostname newname


No, original poster is supposed to mark an issue solved if it has been.

Or is it the reverse? Why does your hardware have so many problems with OpenMandriva 3.02. Not very many people had a problem with this.

Edit: How many times does it need to be said. Developers can’t fix things they don’t know about. How do developers know users have a certain specific problem?

Right! These problems were discussed in the forum, not at a bug in bugzilla. I did not want to seem upset with these problems. I prefer to face them than to use other proprietary OS. Back to the virtuous cicle where people report bugs and help development of the distro, I guess I should report at bugzilla things like:

1 - SDDM, by default, starts with “NUM LOCK on” which yields messages of wrong passwords in laptops if users define passwords that uses shared keys … this was reported in the forum and still happens with the new 3.02.
2 - Passwords of new users are not correctly set with OMCC (It is in the Errata, I guess). To set passwords one should use kusers, but kusers has to be installed…this was also reported in the forum and still happens with 3.02.
3 - Those who have hybrid graphical support (Nvidia + other) may have problems if proprietary nvidia drivers are installed (in the ERRATA, isn’t it?). Here, the problem was solved with XFdrake which creates a xorg.conf file. It happened with OMV LX 3.0 and is still a problem with 3.02.

Shouldn’t I?

Yes and no. I don’t file bug reports on everything I could.

The only point I’m really trying to make is that talking about a problem in the forum is not the same thing as reporting the problem.

OK, this is just me saying but developers read the forum less than just about anyone.

I would like to suggest we close this topic:

  1. KUser is dead upstream, don’t know how much longer the current version will be around.

  2. Drakconf is old, antiquated, and near deprecated. As such OM developers are looking to replace it.

  3. That leaves the command line. Managing users on the command line is one of the easier things to do on command line. So do it.