DNS_PROBE_FINISHED_NXDOMAIN

Hello everyone!
I am asking for help in solving the problem with the internet connection.
I am currently connecting to the internet using a router or LTE telephone. When I connect to the LTE router after starting the computer, I cannot open any website. “DNS_PROBE_FINISHED_NXDOMAIN” But in the console, ping 1.1.1.1 works.
The clock and date are also not updating. All I need to do is connect another source of wired internet for a moment, the clock updates after a while, and websites work even on the LTE connection.

Linux st-korek 5.5.0-desktop-1omv4001 #1 SMP Mon Jan 27 23:34:32 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Below the content in the resolv.conf file:
#Generated by NetworkManager
nameserver 1.1.1.1
nameserver 8.8.8.8

Thanks for your help and I apologize for my English.

1 Like

Welcome back @Stan. Sorry you are having problems.

I start by assuming you are using OM Lx 4.2?

Some things to try:

  1. Disable the ufw firewall and reboot. If this works and you are behind a router then you do not need a firewall on you OS anyway so you can make the permanent by running in Konsole:

$ sudo systemctl mask ufw.service

to unmask:

$ sudo systemctl unmask ufw.service

  1. Check to see if you have a package called latest version of systemd:
$ rpm -qa | grep systemd
rpm-plugin-systemd-inhibit-4.16.1.2-2.x86_64
systemd-kcm-1.2.1-5.x86_64
systemd-macros-247.20210315-4.x86_64
lib64systemd0-247.20210315-4.x86_64
lib64nss_systemd2-247.20210315-4.x86_64
systemd-analyze-247.20210315-4.x86_64
systemd-cryptsetup-247.20210315-4.x86_64
systemd-console-247.20210315-4.x86_64
systemd-coredump-247.20210315-4.x86_64
systemd-locale-247.20210315-4.x86_64
systemd-hwdb-247.20210315-4.x86_64
systemd-polkit-247.20210315-4.x86_64
systemd-247.20210315-4.x86_64

All except rpm-plugin-systemd-inhibit and systemd-kcm should have the same version #. There should not be a systemd-resolved packages.

  1. If neither of those help or point to a cause then you may get a faster answer on IRC. Traditional way is to connect to #openmandriva @ Freenode IRC. Also we have this. IRC is where developers are. They are more likey to be able to resolve your issue.

Tip: Please post code as code with the </> icon.

1 Like

Hello Ben!
Thank you for your fast answer. My system is OM Lx4.1. I will check your suggestions and give you an answer.
Thank you for no

[root@st-korek skorek]# rpm -qa | grep systemd
systemd-coredump-244.20191203-2.x86_64
lib64nss_systemd2-244.20191203-2.x86_64
systemd-polkit-244.20191203-2.x86_64
lib64systemd0-244.20191203-2.x86_64
systemd-macros-244.20191203-2.x86_64
systemd-244.20191203-2.x86_64
systemd-console-244.20191203-2.x86_64
systemd-hwdb-244.20191203-2.x86_64
systemd-analyze-244.20191203-2.x86_64
rpm-plugin-systemd-inhibit-4.15.1-8.x86_64
systemd-cryptsetup-244.20191203-2.x86_64
systemd-locale-244.20191203-2.x86_64
systemd-kcm-1.2.1-5.x86_64
[root@st-korek skorek]# ^C
[root@st-korek skorek]#

Those are probably the latest version of systemd for OM Lx 4.1. Lx 4.1 is EOL (End Of Life), latest version is Lx 4.2. What I posted was relevant to Lx 4.2.

If I bring this issue to developers they are going to say to upgrade to Lx 4.2 or Rolling.

Hello Ben!
Yesterday I reinstalled the system on OM lx4.2 and the problem is the same!
DNS_PROBE_FINISHED_NXDOMAIN”

Please help.

[root@st-koreklinux etc]# sudo systemctl mask ufw.service
Created symlink /etc/systemd/system/ufw.service → /dev/null.

[root@st-koreklinux etc]# sudo systemctl unmask ufw.service
Removed /etc/systemd/system/ufw.service.

[root@st-koreklinux etc]# rpm -qa | grep systemd
lib64systemd0-247.20210207-1.x86_64
systemd-macros-247.20210207-1.x86_64
lib64nss_systemd2-247.20210207-1.x86_64
rpm-plugin-systemd-inhibit-4.16.1.2-2.x86_64
systemd-resolved-247.20210207-1.x86_64
systemd-analyze-247.20210207-1.x86_64
systemd-cryptsetup-247.20210207-1.x86_64
systemd-console-247.20210207-1.x86_64
systemd-coredump-247.20210207-1.x86_64
systemd-locale-247.20210207-1.x86_64
systemd-hwdb-247.20210207-1.x86_64
systemd-polkit-247.20210207-1.x86_64
systemd-247.20210207-1.x86_64
systemd-kcm-1.2.1-5.x86_64

[root@st-koreklinux etc]# uname -a
Linux st-koreklinux 5.10.14-desktop-1omv4002 #1 SMP PREEMPT Mon Feb 8 18:13:34 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Apologies for falling asleep on this issue. Sometimes we get busy and a few things are forgotten along the way. My participation in OpenMandriva project has been weak lately because of other life issues.

You are showing you have:

systemd-247.20210207-1.x86_64

The latest version in Lx 4.2 main/updates repo is:

systemd-247.20210315-4-omv4002.x86_64

I am baffled why you have the older systemd package group. For repositories in Lx 4.2 you should at a minimum have these:

$ dnf repolist
repo id                                                                                          repo name
rock-updates-x86_64                                                                              OpenMandriva Rock - x86_64 - Updates
rock-x86_64                                                                                      OpenMandriva Rock - x86_64

It is OK if you have additional repositories like this:

$ dnf repolist
repo id                                                                                         repo name
rock-updates-x86_64                                                                             OpenMandriva Rock - x86_64 - Updates
rock-updates-x86_64-non-free                                                                    OpenMandriva Rock - Non-free - x86_64 - Updates
rock-updates-x86_64-restricted                                                                  OpenMandriva Rock - Restricted - x86_64 - Updates
rock-updates-x86_64-unsupported                                                                 OpenMandriva Rock - Unsupported - x86_64 - Updates
rock-x86_64                                                                                     OpenMandriva Rock - x86_64
rock-x86_64-non-free                                                                            OpenMandriva Rock - Non-free - x86_64
rock-x86_64-restricted                                                                          OpenMandriva Rock - Restricted - x86_64
rock-x86_64-unsupported                                                                         OpenMandriva Rock - Unsupported - x86_64

Either way if you have rock-updates-x86_64 and you run:

$ sudo dnf clean all ; sudo dnf upgrade
or:
$ sudo dnf clean all ; sudo dnf distro-sync

you should get the latest systemd package group. (sudo dnf clean all is very important).

The systemd upgrade was done specifically in response to folks reporting internet issues. Whether it would fix the “DNS_PROBE_FINISHED_NXDOMAIN” issue I do not know. However before we get developers involved it is imperative that we get you upgraded to the most recent systemd packages available.

Edited: To correct the upgrade and distro-sync commands to include dnf clean all. It matters.

1 Like

Helpful hint: Please post code as code withe the </> icon like this:

$ sudo dnf clean all ; sudo dnf upgrade
[sudo] password for ben79: 
0 files removed
OpenMandriva Rock - x86_64                                                                                                                                                        4.4 MB/s |  35 MB     00:07    
OpenMandriva Rock - x86_64 - Updates                                                                                                                                              290 kB/s | 1.4 MB     00:05    
OpenMandriva Rock - Unsupported - x86_64                                                                                                                                          4.6 MB/s | 8.9 MB     00:01    
OpenMandriva Rock - Unsupported - x86_64 - Updates                                                                                                                                398  B/s | 531  B     00:01    
OpenMandriva Rock - Restricted - x86_64                                                                                                                                           105 kB/s | 136 kB     00:01    
OpenMandriva Rock - Restricted - x86_64 - Updates                                                                                                                                 6.9 kB/s | 3.3 kB     00:00    
OpenMandriva Rock - Non-free - x86_64                                                                                                                                              61 kB/s |  90 kB     00:01    
OpenMandriva Rock - Non-free - x86_64 - Updates                                                                                                                                   366  B/s | 344  B     00:00    
Dependencies resolved.
Nothing to do.
Complete!

You copy and paste your output from terminal to reply windo here, highlight your copy and select the </> icon. It does help people trying to help with technical problems to know what exactly is code and what is explanation of a problem.

Hello Ben,
I did all the activities you recommended to me before and without a positive result.
I noticed that the problem persists until the clock and date are updated. For some time I have been getting messages at startup (BIOS) “error - defaults loaded”
The source of my problems was the dead battery on my PC motherboard.

Ben - thank you for your involvement in my problem and sorry.

1 Like

No worries, and I learned a few things myself. That is always a good thing.

That was probably preventing the connection from happening and I did not pay enough attention to that part or you original post. In review any users computer that is not correctly setting date and time is likely to run in to problems.n