Displaylink support needed


  • OpenMandriva Lx version:
    OpenMandriva Lx 5.0 (Iodine) Rock

  • Desktop environment (KDE, LXQT…):

  • Description of the issue (screenshots if relevant):
    I am trying to enable Displaylink on my machine. My kernel version is 6.7.0-desktop-0.rc2.1omv2390, so I downloaded and installed the right version: displaylink-5.8-2-omv2390.x86_64.rpm, and my machine seemed to recognize my monitors for a moment before the dialog disappeared. However, xrandr does reveal that the external monitors are recognized and connected, but they do not appear in the Display Configuration. I have also tried using dkms as a last resort to install the drivers but it isn’t recognizing the kernel headers in /lib/modules/6.7.0-desktop-0.rc2.1omv2390/{build,source}. Any help would be appreciated. Thanks.

  • Relevant informations (hardware ed, software version, logs or output…):

systemctl status displaylink-driver.service
● displaylink-driver.service - DisplayLink Driver Service
     Loaded: loaded (/usr/lib/systemd/system/displaylink-driver.service; static)
    Drop-In: /usr/lib/systemd/system/service.d
     Active: active (running) since Sat 2023-12-16 20:44:33 EST; 18min ago
   Main PID: 7287 (DisplayLinkMana)
      Tasks: 51 (limit: 18120)
     Memory: 41.0M
        CPU: 1.983s
     CGroup: /system.slice/displaylink-driver.service
             └─7287 /usr/libexec/displaylink/DisplayLinkManager

Dec 16 20:44:33 suhas-open-mandriva systemd[1]: Starting displaylink-driver.service - Dis>
Dec 16 20:44:33 suhas-open-mandriva systemd[1]: Started displaylink-driver.service - Disp>

Have you tried kernel 6.6? it works great with 6.6 and I don’t have 6.7 yet. Let me do some testing with 6.7 and see…

What brand of DisplayLink Device you have? I have tested it with HP and Lenovo brands (USB Type C)


Welcome @suhashoysala to OpenMandriva and our forum. This forum is for users of OpenMandriva Linux operating systems.

We are a small group. All the contributors and developers here are unpaid volunteers.

You are welcome to talk to our developers at OpenMandriva Chat.

The first thing when a new user has an issue is to look in the documentation for OMLx. OpenMandriva wiki and Forum Resources guide.

If you don’t find what you are looking for try an Internet search (googling). One can find out a lot from documentation or forum posts at other Linux distros. If user finds something written for another distro but you have some doubt ask at OpenMandriva Chat.

For serious technical issues and package/feature requests please file a bug report here.

Thanks for your response. Just reverted the distro and reinstalled the above binary package ensuring that I’m on 6.6, and I’m encountering the same issues.

[suhashoysala@suhas-openmandriva ~]$ uname -r
[suhashoysala@suhas-openmandriva ~]$ systemctl status displaylink-driver.service
● displaylink-driver.service - DisplayLink Driver Service
     Loaded: loaded (/usr/lib/systemd/system/displaylink-driver.service; static)
    Drop-In: /usr/lib/systemd/system/service.d
     Active: active (running) since Sun 2023-12-17 21:25:45 EST; 2min 9s ago
    Process: 2039 ExecStartPre=/bin/sh -c modprobe evdi || (dkms install $(ls -t /usr/src | grep evdi | head >
   Main PID: 2051 (DisplayLinkMana)
      Tasks: 51 (limit: 18169)
     Memory: 42.3M
        CPU: 360ms
     CGroup: /system.slice/displaylink-driver.service
             └─2051 /usr/libexec/displaylink/DisplayLinkManager

Dec 17 21:25:45 suhas-openmandriva systemd[1]: Starting displaylink-driver.service - DisplayLink Driver Servi>
Dec 17 21:25:45 suhas-openmandriva systemd[1]: Started displaylink-driver.service - DisplayLink Driver Servic>
[suhashoysala@suhas-openmandriva ~]$ xrandr | grep -A 2 ' connected' 
eDP-1 connected primary 1680x1050+0+0 (normal left inverted right x axis y axis) 301mm x 188mm
   2560x1600    120.00 +  96.00    72.01    60.00    50.00    48.00    60.00  
   1920x1200    120.00  
DVI-I-5-2 connected (normal left inverted right x axis y axis)
   1920x1080     60.00 +
   1680x1050     59.95  
DVI-I-4-1 connected (normal left inverted right x axis y axis)
   1920x1080     60.00 +  50.00    59.94  
   1600x900      60.00  
[suhashoysala@suhas-openmandriva ~]$

so it appears 6.6 isn’t working either. I’m using an HP USB-C Universal Dock, model HSA-B005DS. I have Windows 10 dual-installed on this machine and it’s working fine on that OS, so there isn’t an issue with the machine, dock, cables, or monitors.

I do not have the hardware in question so can’t test anything regarding this issue.

There are three evdi packages one or more of which might help your problem. They are lib64evdi, lib64evdi-devel, and python-evdi. My best guess, and it is only a guess, would be:

$ sudo dnf --refresh in python-evdi

That will also install lib64evdi.

Edit: This is from the evdi .spec file:

The Extensible Virtual Display Interface (EVDI) is a Linux kernel module that
enables management of multiple screens, allowing user-space programs to take
control over what happens with the image. It is essentially a virtual display
you can add, remove and receive screen updates for, in an application that
uses the libevdi library.

It is needed primarily for DisplayLink driver.

Thanks, tried installing those packages and restarting but it didn’t help. I now notice the Display Configuration icon in the tray in the bottom right – somehow it knows there are external monitors connected but it won’t project to them or even identify them in the menu. Weird.

You need the packages @ben79 mentioned, plus the displaylink package from the non-free repositories.

rebooted and still not working

What kernel are you using? (uname -r)

[suhashoysala@suhas-openmandriva ~]$ uname -r

reverted to 6.6 upon advice from @ZekeMX

Still not working after 6.6 revert?

I used this and I got a firmware upgrade

This is strange… What brand of displaylink you have? dell, hp, lenovo?

Please take note of this release notes: → Release Notes

Seems there aren’t any firmware upgrades available…

It’s an HP USB-C Universal Dock, model HSA-B005DS.

Also wanted to mention that this dock worked fine with Ubuntu and Fedora on this machine, after the required drivers were installed.

Hello Suhas,

The Ubuntu Displaylink 5.8 Release note specifies.

C.8 Changes in 5.8 release

  • Alpha support for DisplayLink DL-7400 products
  • Support for new DisplayLink DL-6150 products
  • Support for Ubuntu 23.04
    - Added preliminary support for kernel 6.5

It might be that it does runs fine with kernl 6.6 but it does not with 6.7.

Did you roll back to 6.6?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.