Desktop died

Tags: #<Tag:0x00007fe32268ee78>

Hello,

OMV LX 3.03

All updates that were set available by last july, 14.

(Ben, I cannot list 333 updated packages. I can list kernel 4.16 and nvidia 396.24)

Although nvidia 396.24 has built fine against kernel 4.16 in my laptop, it has not in the desktop (???)
Upon rebooting, besides no graphical support because of nvidia’s failures, desktop also does not connect to internet (by cable) and also does not see USB devices …

This is certainly a rather vague problem report so far, I’m posting it anyway just in case someone else has had such problems and can say something about.

I wonder if some packages are lacking in the new updates, particularly those related to the specific motherboard I have in the desktop (intel DB85FL).

I’ll try installation disk in live mode to download packages like kernel, nvidia, for reinstallation with replacepkgs replacefiles

Thanks for any comment

Nown, using installation disk in live mode, I’m uploading nvidia’s build make.log at kernels 4.15 and 4.16.

make_4.15_.log.txt (218,8 KB)
make_4.16_.log.txt (218,8 KB)

Downloaded x11-driver-nouveau in live mode with the installation disk. Then, rebooting in recovery mode, I’ve installed x11-driver-nouveau and reconfigured X with XFdrake to use xorg-nouveau. Reboot. Graphical environment OK. Also then cable internet was OK.

Then I did,

# urpmi --replacepkgs --replacefiles --force kernel-firmware kernel-firmware-extra kernel-release-headers kernel-release-desktop-4.16.13-1omv kernel-release-desktop-latest kernel-release-desktop-devel-4.16.13-1omv kernel-release-desktop-devel-latest

But, after downloading and preparation phase, even using --force option, I got,

dracut: Will not override existing initramfs (/boot/aa6af5e767044ce2823a171f079f4b35/4.16.13-desktop-1omv/initrd) without --force

and,

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
make -C /lib/modules/4.16.13-desktop-1omv/build M=/var/lib/dkms/nvidia-current/396.24-1/build clean
make: Entering directory '/usr/src/linux-4.16.13-desktop-1omv'
make: Leaving directory '/usr/src/linux-4.16.13-desktop-1omv'

{ 'make' CC=gcc CXX=g++ SYSSRC=/lib/modules/4.16.13-desktop-1omv/build modules -j16; } >> /var/lib/dkms/nvidia-current/396.24-1/build/make.log 2>&1

Error!  Build of nvidia.ko.gz failed for: 4.16.13-desktop-1omv (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-current/396.24-1/build/ for more information.

Remaining questions:

1-Why nvidia 396-24-1 worked (downloaded from testing non-free repos) was built in kernel 4.16.13 in my laptop and the nvidia 396.24-1 (downloaded from regular non-free repos) was not built with the same kernel at my desktop?
2-Why, in the recovery mode, cable network connections and usb’s were not working?

Tried uninstall of nvidia packages for a new installation with packages from testing non-free repos.

# urpme dkms-nvidia-current-396.24-1-omv2015.0.x86_64 x11-driver-video-nvidia-current-396.24-1-omv2015.0.x86_64

went OK.

But, when I tried to reinstall,

# LC_ALL=C urpmi --replacefiles --replacepkgs --force dkms-nvidia-current-396.24-1-omv2015.0.x86_64.rpm x11-driver-video-nvidia-current-396.24-1-omv2015.0.x86_64.rpm nvidia-current-doc-html-396.24-1-omv2015.0.x86_64.rpm
found package(s) nvidia-current-doc-html-396.24-1-omv2015.0.x86_64 in urpmi db, but none are installed

Rebuilding rpm database did not help,

# cd /var/lib/rpm
# rm __db*
# rpm --rebuilddb

After urpme you just have to urpmi (without --replacefiles --replacepkgs), isn’t it?

So many questions left! But I have tried that.

The problem seems to be solved although I don’t know why.

Building nvidia drivers with kernel 4.16 became successful after I removed many old kernels (since 4.13.X). Just would like to know why is this so!

Just noticed that x11-driver-video-nvidia was found in old kernels trees and guessed my urpmi database could have something to do with it … After removing old kernels I’ve installed nvidia packages with no problem.

Thanks!

@rugyada was kind enough to provide us with a solution to this issue here.

Post-edit: If the issue is resolved just save this information for next time you may need it.

1 Like

Thanks to Ben and rugyada

1 Like