[cooker] Dummy makes big mistake with Lx 4.0 packages (Solved)

Tags: #<Tag:0x00007f64033018f8> #<Tag:0x00007f6403301740> #<Tag:0x00007f6403301560>

Hello,

I built the i3-wm desktop for Rolling and Lx 4.0. In doing so I had to upgrade some perl packages and stupidly published them to updates repo in Lx 4.0.

These got published to updates: perl, perl-JSON-XS, perl-common-sense, perl-Template-Toolkit, and perl-Canary-Stability >>> They probably should be reverted but I don't know how to do this. If I knew how I would do it myself.

And I'm kicking myself pretty good over this stupid mistake. Learning and all that but I hate learning stuff this way in front of other people. I also hate that it might affect Lx 4.0 users.

The workaround to upgrade Lx 4.0 or Rock until this is fixed is:

$ sudo dnf clean all

$ sudo dnf -x=perl* -x=lib64perl5 upgrade

For users notice published here: https://forum3.openmandriva.org/t/notice-updating-in-lx-4-0-is-messed-up-workaround/3215

Hello,

The idiot with the help of more knowledgeable people got this fixed now.

Unfortunately any packages built in 4.0 that depend on perl packages will probably need to be rebuilt.

Apologies to everyone.

Ben Bullard
ben79

Or if you wish tell me and I'll rebuild any packages that need it.

Ben Bullard
ben79