Can't install 3.0 to notebook from DVD

I am trying to install Lx 3.0 (686) from DVD to an Asus X555DA-WS11 notebook.
Using the second line item from the menu (Install OpenMandriva Lx) as my first choice, and setting the verbose option, I can see that Calamare is encountering problems, and eventually gives up, leaving the process stopped with plenty of screen info, but I can’t copy it before it disappears. The pause/break key is not effective.
Does Lx have an interactive start-up mode that would allow me to force selection and confirmation on a line by line basis during boot-up? That would enable me to record the on-screen feedback to assist in diagnosing the problem.
Or, is there a way to have the boot process write the boot log to a USB drive for later inspection
Any other ideas would be most welcome.
Thank you.

what about start in live mode and run command
# calamares
in konsole?

So you can read the install log.

Thank you, Rugyada.
I will try that and reply with the results.

I can’t start up the live system from the default DVD menu… it will process some of the start up sequence, but will stop, yielding a blank screen with a flashing underscore cursor.

I have to select the basic graphics mode option under the Troubleshooting menu. When I do that, open Konsole, and enter the command you show, nothing happens. I get a carriage return and a new line with a prompt, but that is all.

I’m not technician, so here below some quick and dirty random clues:

  • if your hw supports, the x86_64 ISO is surely the best choice

  • instead of DVD try with USB stick (use rosa-imagewriter tool)

  • you’re not specifying which ISO you used, we are supposing it’s the official announced one right?

  • check the md5/sha1 sum to be sure your ISO file is not corrupted

  • read also the Errata
    3.0/Release Notes - Wiki [en] OpenMandriva

  • FWIW here are the first rows of my latest install attempt log (don’t care of calamares version, it’s current experimental ISO, failed to install but live mode ok) - just to give you an example:

    [live@localhost ~]$ su
    [root@localhost live]# calamares
    14:59:53 [1]: Calamares version: 2.4.1
    14:59:53 [1]: Default font =====
    Pixel size: -1
    Point size: 10
    Point sizeF: 10
    Font family: “Noto Sans”
    Metric height: 18
    14:59:53 [1]: Font height: 18
    14:59:53 [1]: Available languages: (“ar”, “ast”, “bg”, “ca”, “cs_CZ”, “da”, “de”, “el”, “en”, “en_GB”, “es_MX”, “es”, “eu”, “fr”, “hr”, “hu”, “id”, “is”, “it_IT”, “ja”, “lt”, “nl”, “pl”, “pt_BR”, “pt_PT”, “ro”, “ru”, “sk”, “sv”, “th”, “tr_TR”, “zh_CN”, “zh_TW”)
    14:59:53 [1]: CalamaresApplication thread: 0x24d20f0
    14:59:53 [1]: Using log file: “/root/.cache/Calamares/Calamares/Calamares.log”
    14:59:53 [1]: Using Calamares settings file at “/etc/calamares/settings.conf”
    14:59:53 [1]: Using Calamares branding file at “/etc/calamares/branding/auto/branding.desc”
    14:59:53 [1]: WARNING: the selected branding component does not ship translations.
    14:59:53 [1]: Loaded branding component “auto”
    14:59:53 [1]: STARTUP: initQmlPath, initSettings, initBranding done
    14:59:53 [1]: STARTUP: initModuleManager: module init started
    14:59:53 [1]: STARTUP: initModuleManager: all modules init done
    14:59:54 [1]: STARTUP: initJobQueue done
    14:59:54 [1]: Proposed window size: 1080 648

In latest TC meeting there is serious discussion of adding a warning to i586/i686 .iso’s to detect if hardware is actually x86_64 and if so to warn user to install x86_64 not i586/i686.

It’s bizarre that people keep doing this.

Your hardware should support 64bit, shouldn’t it? It case x86_64 ISO could be a better choice, as suggested by @rugyada.

Thanks for the responses.

I’m sorry for the earlier entry error, but I am using the official Lx 3.0 Plasma x86_64 iso DVD.
I have not yet had an opportunity, but as suggested, I will verify the checksum.
If that is confirmed correct, I will then attempt the USB drive installation.
I will advise as soon as I have results with that.
I truly appreciate your help.

I have not determined the answer to this post, but the latest version (3.03) now installs and runs beautifully without a hitch.

Good news. :joy:


I’ve been trying to load it for the last several releases onto a pre-loaded Windows machine, and now it finally works!

Got rid of all the Windows clutter, and am exploring the new 3.03 after long-time use of 2014.2 and so far, what a difference!


1 Like

Ummm… Must be getting old or older. This is kinda embarrassing but I have no idea what I might have done that led to this being solved. :flushed:

Don’t be too self-critical, I think it was my mistake.
Just meant to close the thread, didn’t mean to present another dilemma!

No worries, I was just trying to be funny. Closing thread.