Booting time too long

I’ve updated the kernel to 4.16.3 and, remembering problems with new kernels when using the NVIDIA graphic driver, I selected the NOVEAU one. But I’ve got the big problem of very high booting times. It hangs up on “building kernel modules by DKMS”, as says diagnostics. But the modules building shouldn’t occur only for the first booting time ?
But this actually happens. Why ?
Thank for your suggestions.

This is usually a sign of an installed dkms module that fails to build – on next boot, dkms will notice again that the binary module isn’t there, and therefore try to compile it, which (obviously) is going to fail again.
“systemctl status dkms” can often tell you what exactly is going on.
Usually the best thing to do is to just not install (or uninstall) dkms modules (the VirtualBox ones aren’t required anymore, we build them inside the kernel these days).


I can verify that VirtualBox works in OM Lx 3 without the dkms package (dkms-virtualbox) oh Host Machine and the VirtualBox Guest Additions work without dkms package (dkms-vboxadditions) on Guest Machine. With present kernel 4.16.13 and most recent kernels such as 4.15.18.

Post edit: Also I saw that message, or error message if it is one, on some of my computers and removing dkms eliminated it as @bero suggested.

So…what practically means NOT installing the DKMS modules ?
What I have to do ?

1 Like

Remove them with urpme. To find what dkms packages you have installed:

$ rpm -qa | grep dkms

If you know that you don’t need any of them then the easiest way would be to remove dkms itself. That will remove all of them.

# urpme dkms

(AFAIK). With a normal install neither dkms itself or any dkms-< something> packages are part of the default packages. So these are added by the user after install.


:monkey_face: Linux_Monkey_Hint: One advantage of using CLI (Command Line Interface) for package management is that if you did remove something you needed it’s easy to fix. You have the list of removed packages in the output so just add what ever you wish back with ‘urpmi’. It’s simply copy and paste. I find it in general way easier to fix any mistakes I make if I use CLI for package management. That’s because you have the output right in front or you and exact package names and so forth.

:monkey: Linux_Monkey_Hint: For more verbose output using CLI for package management a lot of commands have the --verbose or -v option such as ‘urpmi -v < package_name>’.

1 Like

I solved problems in the following way:

  1. I unistalled the kerneel 4.16.13 ( and the 4.15.18 too, that got the same problems.
  2. I uninstalled dkms and all related packages, included nvidia.
  3. I installed again tha latest 4.16.13 kenrel, rebooted and everything went well.
  4. I installed agian dkms and the related packages, and no problems arose more.

I ignore why things go well now, neither they went wrong before.
But it’s all right, after all.
Than you for your kind support, ben and bero.

1 Like