Altri problemi di aggiornamento


#1

Ciao

vi segnalo che l’aggiornamento di OMA LX3.0 LXQT segnala da un po’ di giorni questo oggetto mancante

[root@localhost albertolx3]# urpmi --auto-update --test --clean
il supporto “main” risulta gi aggiornato
il supporto “main updates” risulta gi aggiornato
il supporto “Main32” risulta gi aggiornato
il supporto “Main32 Updates” risulta gi aggiornato
il supporto “contrib” risulta gi aggiornato
il supporto “contrib updates” risulta gi aggiornato
il supporto “contrib32” risulta gi aggiornato
il supporto “contrib32 updates” risulta gi aggiornato
il supporto “non-free” risulta gi aggiornato
il supporto “non-free updates” risulta gi aggiornato
il supporto “Non-free32” risulta gi aggiornato
il supporto “Non-free32 Updates” risulta gi aggiornato
il supporto “restricted” risulta gi aggiornato
il supporto “restricted updates” risulta gi aggiornato
Uno dei pacchetti richiesti non pu essere installato:
gdb-headless-8.0.1-1-omv2015.0.x86_64 (perch non soddisfatto pkg-command(debuginfo-install))
Continuo comunque l’Installazione? (S/n) s
L’installazione possibile
Nonostante qualche pacchetto sia stato installato, si sono verificati dei malfunzionamenti.
Uno dei pacchetti richiesti non pu essere installato:
gdb-headless-8.0.1-1-omv2015.0.x86_64 (perch non soddisfatto pkg-command(debuginfo-install))
Continuo comunque l’Installazione?

ma li becco tutti io?


#2

la situazione si complica

ora dice

Alcuni dei pacchetti richiesti non possono essere installati:
gdb-headless-8.0.1-2-omv2015.0.x86_64 (perch non soddisfatto urpmi-debuginfo-install)
systemd-doc-236-1-omv2015.0.i586 (per conflitti con lib64udev-devel-236-1-omv2015.0.x86_64, per conflitti con lib64udev-devel-236-1-omv2015.0.x86_64, per conflitti con lib64udev-devel-236-1-omv2015.0.x86_64)
systemd-doc-236-1-omv2015.0.x86_64 (per conflitti con lib64udev-devel-236-1-omv2015.0.x86_64, per conflitti con lib64udev-devel-236-1-omv2015.0.x86_64, per conflitti con lib64udev-devel-236-1-omv2015.0.x86_64)


(Ben Bullard) #3

Il pacchetto gdb è rotto vedi [bug report.] (Https://issues.openmandriva.org/show_bug.cgi?id=2282) Per ora è necessario modificare ‘/etc/urpmi/skip.list’ e aggiungere:

/^gdb/

Per l’altro problema prova questo:

# urpmi lib64udev-devel

Quindi esegui il tuo regolare:

# urpmi --auto-update --test --clean

e fammi sapere se funziona. Potrei aver bisogno di presentare un bug report su ‘lib64udev-devel’ se riesco a trovare un modo per riprodurre il problema. Finora non riesco a riprodurlo.

Package gdb is broken see bug report. For now you need to edit ‘/etc/urpmi/skip.list’ and add:

/^gdb/

For the other problem try this:

# urpmi lib64udev-devel

Then run your regular:

# urpmi --auto-update --test --clean

and let me know if that works. I may need to file a bug report on ‘lib64udev-devel’ if I can find a way to reproduce the problem. So far I can not reproduce it.


#4

ok. sembra andare.

seguo soluzione bug

grazie


(Ben Bullard) #5

Vedi riportare un errore. Prima installa il pacchetto mancante da QUI. Quindi rimuovere / ^ gdb / da ‘/etc/urpmi/skip.list’. Quindi puoi aggiornare gdb. O semplicemente esegui l’aggiornamento del sistema come fai normalmente.

See bug report.. First install the missing package from HERE. Then remove /^gdb/ from ‘/etc/urpmi/skip.list’. Then you can update gdb. Or simply run system update as you normally do.


#6

Ottimo. Funziona a meraviglia.
Grazie