After installing new 3.02 iso some packages are broken


This is a fresh installed OMV LX 3.02 with all updates available (3.03?)_

I’m reporting this here just in case somebody else has something to suggest …
I’m adding this to the bug 2208 at bugzilla since it also seems to be related to llvm dependecies.

There seems to be no llvm packages to be installed!


urpmi abf-c-c

and got,

$ urpmi abf-c-c

(urpmi:6013): Gtk-WARNING **: Unable to locate theme engine in module_path: “adwaita”,

(urpmi:6013): Gtk-WARNING **: Unable to locate theme engine in module_path: “adwaita”,
GOT: lib64llvm-devel-3.8.1-1.1-omv2015.0.x86_64
GOT: llvm-polly-4.0.1-1-omv2015.0.x86_64
In order to satisfy the ‘’ dependency, one of the following packages is needed:
1- lib64llvm-devel-3.8.1-1.1-omv2015.0.x86_64: Development files for LLVM (to install)
2- llvm-polly-4.0.1-1-omv2015.0.x86_64: Polyhedral optimizations for LLVM (to install)
What is your choice? (1-2) 1
A requested package cannot be installed:
lib64llvm-devel-3.8.1-1.1-omv2015.0.x86_64 (due to unsatisfied llvm[== 3.8.1-1.1:2015.0])
Continue installation anyway? (Y/n)

Here’s a hint. When you see an error like that look in the repositories and see which (if any) of the listed packages are available. In this case one of two listed is available.

Edit: Actually both packages are in the repository. So try selecting 2 instead of 1.

Did you check in the repository?

I’ve followed the hint: tried the second option. During installation of abf-c-c, a package named llvm was said to be installing. Indeed, now,

$rpm -qa|grep llvm

But, if not otherwise proved, I’m not crazy enough :slight_smile: ! I’m certain I’ve tried,

$urpmi llvm

and got error messages about lacking llvm packages …

Thanks anyway

Um, I’m not doubting that either. I know all is not perfect or as well polished as most of us would prefer in OpenMandriva. That’s just a consequence of not enough contributors, not enough developers.

OpenMandriva seems to have achieved the unenviable position of the perfect size to not grow itself.

This is going to be fixed in llvm-5.0.0-3

1 Like

Great! I got a similar issue here.

This should be fixed.

1 Like

Still not. I updated the issue at bugzilla.

I’ve “met” this issue when I was trying to install abf-c-c. Then, I was required to select one in two packages to install abf-c-c and llvm was just the first choice. Following Ben79’s hint, I’ve choosed the second, not broken, option and got abf-c-c installed.

How do I know which of the many choices are better? Is llvm-devel better than the second option?

I don’t which is “better” in this or other instances. I tend to look for the latest package versions and in this case that works. However, Both choices should work of there is no reason to have the choice. Unless there is something at work here I don’t understand (very possible).

Strange as i applied obsoletes correctly :expressionless:

Some of rpm-build dependency requires and lib64llvm-devel provides for it:

$ urpmq --whatprovides ""

I’m not sure even if _Provides: %{lib}llvm-devel can fix it.

Postedit: I got a similar issue with cooker. In fact I can’t install ffmpeg related libraries.

I think all packages requiring and all their dependencies may cause the same issue.

Not sure this is relevant to the current discussion, but I use FORTRAN all the time (and I guess) and have had no problems

Well yes, as is not versioned provide :frowning:

1 Like